[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

Cisco 877 Natting to ATM

Posted on 2008-11-17
5
Medium Priority
?
426 Views
Last Modified: 2012-05-05
I am trying to set up a cisco 877 for sweden with vpn, at the moment O cant get the natting working right, the router is online and ok and I can ping IP address and dns from there, however from the Lan I cannot, it all looks right to me, Sweden do not need to authnticate so there is no need for dialer interfaces, it should be working but is not can anyone help,

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname xxxxxxxxxxx
!
boot-start-marker
boot-end-marker
!
logging buffered 10000
enable secret 5 $1$.hQu$/QquleAdC41S3WtAtJ61d/
!
no aaa new-model
!
!
dot11 syslog
ip cef
!
!
!
!
ip name-server 213.50.29.170
ip name-server 213.50.29.180
ip inspect name hdb cuseeme
ip inspect name hdb ftp
ip inspect name hdb h323
ip inspect name hdb icmp
ip inspect name hdb netshow
ip inspect name hdb rcmd
ip inspect name hdb realaudio
ip inspect name hdb rtsp
ip inspect name hdb esmtp
ip inspect name hdb sqlnet
ip inspect name hdb streamworks
ip inspect name hdb tftp
ip inspect name hdb tcp
ip inspect name hdb udp
ip inspect name hdb vdolive
ip inspect name hdb http
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
!
!
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key hdbswd! address xxxxxxxx no-xauth
!
!
crypto ipsec transform-set trans1 esp-3des esp-sha-hmac
!
crypto map hdb 1 ipsec-isakmp
 set peer xxxxx
 set transform-set trans1
 match address 120
 qos pre-classify
!
archive
 log config
  hidekeys
!
!
!
class-map match-all voice
 match access-group 150
!
!
policy-map LLQ
 class voice
  priority 170
 class class-default
!
!
!
!
interface ATM0
 no ip address
 ip virtual-reassembly
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.1 point-to-point
 ip address x.x.x.x 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 atm route-bridged ip
 pvc 8/35
  encapsulation aal5snap
 !
 crypto map hdb
!
interface FastEthernet0
 duplex full
 speed 100
!
interface FastEthernet1
 duplex full
 speed 100
!
interface FastEthernet2
 duplex full
 speed 100
!
interface FastEthernet3
 duplex full
 speed 100
!
interface Vlan1
 ip address 192.168.2.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 x.x.x.x
!
!
no ip http server
no ip http secure-server
ip nat inside source route-map hdb interface ATM0.1 overload
!
access-list 100 deny   ip 192.168.2.0 0.0.0.255 192.168.1.0 0.0.0.255
access-list 100 permit ip 192.168.2.0 0.0.0.25 any
!route-map hdb permit 1
 match ip address 100
!
!
0
Comment
Question by:webleyaxsor
  • 3
  • 2
5 Comments
 
LVL 15

Expert Comment

by:bkepford
ID: 22975968
access-list 100 permit ip 192.168.2.0 0.0.0.25 any
In this line were you meaning to put .25 in the last octect of the wildcard mask?
0
 

Author Comment

by:webleyaxsor
ID: 22978980
Hi bkepford,

Thanks for your comment, I already found the the typo should have been 0.0.0.255, cant beleive i missed it,

Changed it works a treat now,

Many thanks for your comment, even though i had already found more than happy to give u the points

cheers
0
 

Author Comment

by:webleyaxsor
ID: 22978990
thanks very much
0
 
LVL 15

Accepted Solution

by:
bkepford earned 1000 total points
ID: 22979078
You are showing that you are closing without awarding points
0
 

Author Comment

by:webleyaxsor
ID: 22980062
Hi, sorry did not mean to close without points do you have them now,
andy
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

For months I had no idea how to 'discover' the IP address of the other end of a link (without asking someone who knows), and it drove me batty. Think about it. You can't use Cisco Discovery Protocol (CDP) because it's not implemented on the ASAs.…
As managed cloud service providers, we often get asked to intervene when cloud deployments go awry. Attracted by apparent ease-of-use, flexibility and low computing costs, companies quickly adopt leading public cloud platforms such as Amazon Web Ser…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
As a trusted technology advisor to your customers you are likely getting the daily question of, ‘should I put this in the cloud?’ As customer demands for cloud services increases, companies will see a shift from traditional buying patterns to new…

873 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question