• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 619
  • Last Modified:

Problem sending emails to a particular domain name

Hello,

Here is my problem : i have set up an exchange 2007 platform. My hub transport server is configured to use DNS to send emails directly through the Internet. For the moment, it works for every domain except one.

When I try to send emails to this exception, in the queue viewer I have an error message returned : "451 4.4.0 DNS Query failed".

But when I open a command prompt on my hub transport server, I type these lines :
nslookup
server my_dns_server
set type = MX
domain_name_causing_problems

The name resolution is done successfully...

Does anyone have an idea that could help me ?

Thanks in advance.

0
xelablub
Asked:
xelablub
  • 3
  • 3
1 Solution
 
hodgeyohnCommented:
i have seen dns have issues.
try changing exchange to use dns servers 4.2.2.2, and 4.2.2.3.  test it then.

0
 
Xyptilon2Commented:
Flush the cache and retry?
0
 
xelablubAuthor Commented:
HI,

I tried with the public DNS server 4.2.2.2: same error.

I flushed the DNS cache: same error.

I added a new send connector with a weight of 1 for the domain causing problem. This connector sends emails directly to the IP (to be sure there is no dns resolution): same error.......

Good night.
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
Xyptilon2Commented:
I found this: (which may be relevant to you:) http://technet.microsoft.com/en-us/library/bb851512.aspx

Have you tried forwarding DNS queries to an external DNS server and retry sending the message?


0
 
xelablubAuthor Commented:
Hi,

Thanks for the link but i have found a solution.

On my hub transport send connector (i have no edge server for the moment), in the network tab I selected the "Use DNS MX records to route automatically" option.
On the bottom of this screen there is a checkbox: "Use the external DNS lookup settings on the transport server". I checked it and now it works...

But I still do not understand a thing: my internal DNS settings are the same as my external DNS settings which both point to my internal DNS server. So in fact, this checkbox has not changed many things... except that now it works...

Thanks for the time you spent giving me ideas !

Regards.
0
 
Xyptilon2Commented:
I believe that is what i suggested, forwarding queries to an external DNS server, anyway, glad to see that it is working, perhaps your DNS cache is corrupt, it happens all the time :)
0
 
xelablubAuthor Commented:
The thing is that it was already sending emails through an external DNS. But my exchange server was using only the internal settings (my internal DNS server was relaying emails to an external DNS afterwards). The thing is that my external DNS settings also point to my internal DNS server !

Anyway, if I was not using an external DNS at all, no emails could be sent, don't you think ? But my issue concerned only one domain. All others were working fine.

0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now