?
Solved

1811 Load Balancing (E0 DHCP/E1 Static) NAT not working when using E1

Posted on 2008-11-17
3
Medium Priority
?
631 Views
Last Modified: 2012-05-05
Hello,

I have question similar to this but having a NAT issue when going to the E1 link.  Here is my config.  Also I have configured SLA, and I have this very similar confiig at another site but both links static and working fine.  The reason I question NAT is because in dual mode the VPN Tunnel works fine.  If I move from one link to another it works fine.  But when going outside (internet surfing) it does not work with the E1.   If I flip to use E1 i still have the problem only when I connect E0 and shutdown the interface E1 everything is ok.  When I show nat translations it is working on E0, but not E1.  Can anyone help?

FYI: I have removed stuff from  the config,  Crypto, DNS, DHCP, etc...

!version 12.4
 
hostname TEST 
!
clock timezone PCTime -6
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
no ip source-route
!
!
ip cef
!
!
!
ip tcp synwait-time 10
no ip bootp server
no ip domain lookup
ip domain name 
ip name-server x.x.x.4
ip name-server w.w.w.w
 
ip sla 1
 icmp-echo y.y.y.y source-interface FastEthernet1
 timeout 3000
ip sla schedule 1 life forever start-time now
ip sla 2
 icmp-echo z.z.z.z source-interface FastEthernet1
 timeout 3000
ip sla schedule 2 life forever start-time now
!
!
username admin privilege 15 secret 5 $1$E6Cw$DYJqv.IeEFgNhoelTOyra0
!
!
track 10 rtr 1 reachability
!
track 20 rtr 2 reachability
!
track 101 list boolean or
 object 10
 object 20
 delay down 15 up 10
! 
!
!
!
!
!
interface Tunnel0
 bandwidth 1000
 ip address a.a.a.3 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication DMVPN_NW
 ip nhrp map 
 ip nhrp map 
 ip nhrp map 
 ip nhrp map 
 ip nhrp network-id 100000
 ip nhrp holdtime 360
 ip nhrp nhs 
 ip nhrp nhs 
 ip nhrp registration no-unique
 ip tcp adjust-mss 1360
 delay 1000
 tunnel source FastEthernet0
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile SDM_Profile1
!
interface Tunnel1
 bandwidth 1000
 ip address b.b.b.3 255.255.255.0
 no ip redirects
 ip mtu 1400
 ip nhrp authentication DMVPN_NW
 ip nhrp map 
 ip nhrp map 
 ip nhrp map 
 ip nhrp map multicast 
 ip nhrp network-id 100000
 ip nhrp holdtime 360
 ip nhrp nhs 
 ip nhrp nhs 
 ip nhrp registration no-unique
 ip tcp adjust-mss 1360
 delay 1000
 tunnel source FastEthernet1
 tunnel mode gre multipoint
 tunnel key 100000
 tunnel protection ipsec profile SDM_Profile1
!
interface FastEthernet0
 description $ES_WAN$$FW_OUTSIDE$
 ip address dhcp client-id FastEthernet0
 ip access-group 105 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip inspect SDM out
 ip virtual-reassembly
 ip route-cache flow
 duplex auto
 speed auto
!
interface FastEthernet1
 description $ETH-WAN$
 ip address 1.1.1.5 255.255.255.248
 ip access-group 108 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat outside
 ip inspect SDM out
 ip virtual-reassembly
 ip route-cache flow
 speed 10
 full-duplex
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface FastEthernet9
 switchport access vlan 2
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-FE 2$$ES_LAN$$FW_INSIDE$
 ip address x.x.x.1 255.255.255.0
 ip access-group 104 in
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly
 ip route-cache flow
 ip tcp adjust-mss 1452
!
interface Vlan2
 ip address c.c.c.200 255.255.255.0
!
router eigrp 222
 network x.x.0.0
 network y.y.y.0 0.0.0.255
 network z.z.z.0 0.0.0.255
 network 1.31.0.0
 network 192.168.0.0 0.0.255.255
 no auto-summary
!
ip local policy route-map SDM_BACKUP_RMAP_1
ip route x.x.0.0 255.255.0.0 FastEthernet1 track 101
ip route y.y.0.0 255.255.0.0 FastEthernet1 track 101
ip route 192.168.0.0 255.255.0.0 FastEthernet1 track 101
ip route 10.0.0.0 255.0.0.0 FastEthernet1 track 101
ip route 0.0.0.0 0.0.0.0 FastEthernet0 dhcp
ip route 0.0.0.0 0.0.0.0 1.1.1.15
ip route 10.0.0.0 255.0.0.0 FastEthernet0 254
ip route x.x.0.0 255.255.0.0 FastEthernet0 254
ip route y.y.0.0 255.255.0.0 FastEthernet0 254
ip route 192.168.0.0 255.255.0.0 FastEthernet0 254
!
!
ip nat inside source route-map SDM_RMAP_1 interface FastEthernet0 overload
ip nat inside source route-map SDM_RMAP_2 interface FastEthernet1 overload
!
logging trap debugging
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit x.x.x.0 0.0.0.255
access-list 100 remark SDM_ACL Category=4
access-list 100 remark IPSec Rule
access-list 100 permit ip x.x.x.0 0.0.0.255 x.x.0.0 0.0.255.255
access-list 101 remark SDM_ACL Category=2
access-list 101 permit ip x.x.x.0 0.0.0.255 any
access-list 102 remark SDM Backup Route-Map ACL
access-list 102 remark SDM_ACL Category=1
access-list 102 permit icmp any host 4.2.2.1 echo
access-list 102 permit icmp any host y.y.y.y echo
access-list 102 permit icmp any host z.z.z.z echo
access-list 103 remark SDM_ACL Category=4
access-list 103 remark IPSec Rule
access-list 103 permit ip x.x.x.0 0.0.0.255 10.0.0.0 0.255.255.255
access-list 104 remark auto generated by SDM firewall configuration
access-list 104 remark SDM_ACL Category=1
access-list 104 deny   ip host 255.255.255.255 any
access-list 104 deny   ip 127.0.0.0 0.255.255.255 any
access-list 104 permit ip any any
access-list 105 remark auto generated by SDM firewall configuration
access-list 105 remark SDM_ACL Category=1
access-list 105 permit udp any eq domain any
access-list 105 permit udp any any eq non500-isakmp
access-list 105 permit udp any any eq isakmp
access-list 105 permit esp any any
access-list 105 permit ahp any any
access-list 105 permit gre any any
access-list 105 permit icmp any host 7.6.9.8
access-list 105 deny   ip x.x.x.0 0.0.0.255 any
access-list 105 permit tcp host 6.0.5.9 host 7.6.9.8 eq 443
access-list 105 permit tcp host 6.0.5.9 host 7.6.9.8 eq 22
access-list 105 permit tcp host 6.0.5.9 host 7.6.9.8 eq cmd
access-list 105 permit udp any eq bootps any eq bootpc
access-list 105 permit icmp any any echo-reply
access-list 105 permit icmp any any time-exceeded
access-list 105 permit icmp any any unreachable
access-list 105 deny   ip x.x.0.0 0.15.255.255 any
access-list 105 deny   ip 192.168.0.0 0.0.255.255 any
access-list 105 deny   ip 127.0.0.0 0.255.255.255 any
access-list 105 deny   ip host 255.255.255.255 any
access-list 105 deny   ip any any log
access-list 108 remark auto generated by SDM firewall configuration
access-list 108 remark SDM_ACL Category=1
access-list 108 permit udp any eq domain host 1.1.1.5
access-list 108 permit udp any host 1.1.1.5 eq non500-isakmp
access-list 108 permit udp any host 1.1.1.5 eq isakmp
access-list 108 permit esp any host 1.1.1.5
access-list 108 permit ahp any host 1.1.1.5
access-list 108 permit gre any host 1.1.1.5
access-list 108 permit icmp any host 1.1.1.5
access-list 108 permit icmp any host 1.1.1.5 echo-reply
access-list 108 permit icmp any host 1.1.1.5 time-exceeded
access-list 108 permit icmp any host 1.1.0.145 unreachable
access-list 108 permit tcp host 6.0.65.159 host 1.1.1.5 eq 443
access-list 108 permit tcp host 6.0.65.159 host 1.1.1.5 eq 22
access-list 108 permit tcp host 6.0.65.159 host 1.1.1.5 eq cmd
access-list 108 deny   ip x.x.2x.0 0.0.0.255 any
access-list 108 deny   ip 192.168.0.0 0.0.255.255 any
access-list 108 deny   ip 127.0.0.0 0.255.255.255 any
access-list 108 deny   ip host 255.255.255.255 any
access-list 108 deny   ip host 0.0.0.0 any
access-list 108 deny   ip any any log
dialer-list 1 protocol ip permit
snmp-server community parent RW
snmp-server community child RO
no cdp run
!
!
!
route-map SDM_BACKUP_RMAP_1 permit 1
 match ip address 102
 set interface Null0
 set ip next-hop 1.1.1.15     <- Default gateway FE1
!
route-map SDM_RMAP_1 permit 1
 match ip address 101
 match interface FastEthernet0
!
route-map SDM_RMAP_2 permit 1
 match ip address 101
 match interface FastEthernet1
!
!
!
!

Open in new window

0
Comment
Question by:pvieira33
  • 2
3 Comments
 
LVL 32

Expert Comment

by:harbor235
ID: 22986740

Are you filtering traffic via ACL 108? Look in the log since you are logging all denied packets, see if this is causing the problem.

harbor235 ;}
0
 

Author Comment

by:pvieira33
ID: 22989631
Hi,
Thank you for the reply and suggestion.  I have checked and nothing filtering the traffic also I completely removed the ACL to have the interface wide open and the issue is still there.  

NAT enteries show 172.0.0.1 at times when trying that interface.   I wondered if it would be a cost issue on the link one static and one DHCP.  More likely a NAT.  Not sure why this config on another site I have except that both links are static.  This is why I question the link type but things point to NAT.  It is as if NAT overload is not working when it goes through that interface.

Thanks..
0
 

Accepted Solution

by:
pvieira33 earned 0 total points
ID: 23038111
In case anyone is wondering I solved my problem.  Has to do with the IP route on E0 (DHCP).  I use the following statement:
ip route 0.0.0.0 0.0.0.0 fastethernet 0

Which worked fine and does work until I introduced a second external link.  I changed the ip route to the following:
ip route 0.0.0.0 0.0.0.0 dhcp

now both links work correctly and load balance.
:)
0

Featured Post

What Security Threats Are We Predicting for 2018?

Cryptocurrency, IoT botnets, MFA, and more! Hackers are already planning their next big attacks for 2018. Learn what you might face, and how to defend against it with our 2018 security predictions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you’re involved with your company’s wide area network (WAN), you’ve probably heard about SD-WANs. They’re the “boy wonder” of networking, ostensibly allowing companies to replace expensive MPLS lines with low-cost Internet access. But, are they …
Tech spooks aren't just for those who are tech savvy, it also happens to those of us running a business. Check out the top tech spooks for business owners.
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
Michael from AdRem Software explains how to view the most utilized and worst performing nodes in your network, by accessing the Top Charts view in NetCrunch network monitor (https://www.adremsoft.com/). Top Charts is a view in which you can set seve…

807 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question