Using WAT for membership in

Posted on 2008-11-17
Last Modified: 2012-05-05

I have set up an membership on sqlserver.
I created users and roles.
I am testing this from VS2005 locally and running fine.
I am trying to deploy it to the prodution server and it doesn't recognize users and password.
Everything looks pretty standard on web.config but can't figure out why it is not authenticating.

I have one question. When I run WAT and look under the provider tab.
I see my member/role provider names and checked but I don't see that test link button.
Do you know why?? Do you think that's the reason it is not working?
Can you advise??
Thanks much.


     <add name="MyDB" connectionString="..." />



    ... authentication & authorization settings ...

    <membership defaultProvider="CustomizedProvider">


         <add name="CustomizedProvider"





              minRequiredNonalphanumericCharacters="0" />





<location path="manageronly.aspx">



<allow name="managers">

<deny name=*>

Open in new window

Question by:dkim18

    Author Comment

    Mine is similar to this thread but he just recreated the whole membership database instead.
    Is there a way to fix this??

    LVL 9

    Expert Comment

    please make sure the have the same ApplicationName in membership configuration section ..

    Author Comment

    I have a question.
    My web application name is AppProject.
    But ApplicationName in membership config section is Something else.
    It works fine from my VS2005.
    Would that be the problem??

    I made them same and tried but it failed me to login.

    Why I don't get the TEST link in the WAT provider tab??
    LVL 9

    Accepted Solution

    in order to successfully login the ApplicationName must be the same.

    Author Comment

    It is killing me.

    I dropped the membership DB from sql server and recreated.
    I have one question.
    My web app name is AppProject.
    From the WAT's home page, I see this application:/AppProject.
    Membership provider's AppName=AppProject.

    When I looked at the Application table, I see two ApplicationIds for /AppProject and AppProject.
    I think this might be causing problem.

    I am trying to understand this memebership/role things and this is making me all confused.
    Why does it get called Application :/AppProject?
    Why is this creating two ApplicationId??  I just created this DB for this App only??
    How can I change this?
    LVL 9

    Expert Comment

    you must have been modified or added the applicationName after adding users , that's why 2 applicationIDs exist .

    Author Comment

    Man I can't figure this out.
    I don't understand why it is not working.
    When I loaded to the production server, it doesn't authenticate. It kept failed.

    Why is there / on WAT home tab in application name and even the applicatID table??


    Author Comment

    OK This is my last post.

    My application name is AppProj as an example

    So from my production server, it is accessed by

    In my WAT home tab, it shows application: /AppProj
    In my ApplicationID table of Membership Provider database, it lists as /AppProj

    In my web.config, appanme = AppProj.

    It runs fine in my VS but not in production server.

    Why is it putting / in front of my AppName?
    Why is not working on production server when it runs fine in VS??

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    Today is the age of broadband.  More and more people are going this route determined to experience the web and it’s multitude of services as quickly and painlessly as possible. Coupled with the move to broadband, people are experiencing the web via …
    Introduction This article shows how to use the open source plupload control to upload multiple images. The images are resized on the client side before uploading and the upload is done in chunks. Background I had to provide a way for user…
    It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
    This video gives you a great overview about bandwidth monitoring with SNMP and WMI with our network monitoring solution PRTG Network Monitor ( If you're looking for how to monitor bandwidth using netflow or packet s…

    745 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    16 Experts available now in Live!

    Get 1:1 Help Now