• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1708
  • Last Modified:

Getting 80072f7d on one PC only - I have already disable LSP protocol

Hi, I have dealt with this issue for a month now.  My PC at home started throwing this error during a Sync with ActiveSync when connected via USB cable:  

80072f7d - Synchornization could not be completed - try again later.  

- I can still Sync over wireless and at other locations via USB with this phone.
- Some colleagues can still sync with their phones, but always wireless as they do not have local access to Exchange

I have searched and tried everything on the Net.  I do not think I have a certificate problem because it works remotely via USB and a fresh load of XP Pro SP3 on a neutral box.  My homemade certificate does not expire for three more years.

I followed this article closely which involves a registry tweak to disable the LSB protocol and one minor setting on the PC in ActiveSync 4.5 and I did power off the phone and PC before trying again.
http://forum.xda-developers.com/showthread.php?t=368012

Any help is appreciated.  Keith
0
rowek
Asked:
rowek
  • 5
1 Solution
 
rowekAuthor Commented:
I have done much more testing and find this to be true:
1) Several WM 6.1 devices regularly sync across the the wireless connection.
2) After I added a SonicWall router/firewall local USB connections halted.  I did not see the pattern until now.
3) If I sync offsite back to the same Exchange server all is well even over a USB connection on a guest PC running XP and ActiveSync 4.5
4) If I sync offsite back to the same Exchange server all is well even over a USB connection on my laptop running Vista Ultimate 64 it works great.  The same laptop on my LAN will not sync.

Bottom Line: Local LAN connections no longer work via USB connection. Wireless connections have always worked.  Remote PC's that host the USB connection work great.
Could it be that the SonicWall is blocking ports?

This seems so wierd because you think it would be more aggressive coming over a WAN connection.
Thanks, Keith
0
 
rowekAuthor Commented:
Here's what I get with NSLOOKUP on the LAN:

C:\>nslookup myExchange.selfip.net
*** Can't find server name for address 192.168.1.11: Non-existent domain
Server:  UnKnown
Address:  192.168.1.11

Non-authoritative answer:
Name:    myExchange.selfip.net
Address:  78.23.98.112

I was able to remote in and run this from my Server.  Its a Small Business Server so Exhange is running there, too.  When I run the command on a PC on the LAN I get the same exact msg but it does add

"*** Default servers are not available"

*** Can't find server name for address 192.168.1.11: Non-existent domain
*** Default servers are not available

This never affected us until we loaded the Sonic Wall.  I personally think it is keeping us from routing to the outside then back in.  

PS Not using a proxy server.  Thanks, Keith
0
 
rowekAuthor Commented:
Can somebody tell me how to setup a DNS entry to route myExchange.selfip.net back to my local server?

I am told this will solve the problem.   When I added the SonicWall router to my network it no longer allows me to "go out" and "back in".   I have confirmed this with several apps that used to refer to an address of "myExchange.selfip.net".   I am now forced to use "myExchange" instead of the longer form.   I just want to interecept all requests for "myExchange.selfip.net" and re-route them to "myExchange".   That should solve my original issue with ActiveSync.
0
 The Evil-ution of Network Security Threats

What are the hacks that forever changed the security industry? To answer that question, we created an exciting new eBook that takes you on a trip through hacking history. It explores the top hacks from the 80s to 2010s, why they mattered, and how the security industry responded.

 
ParanormasticCryptographic EngineerCommented:
Here is the troubleshooting guide from MS for AS 4.5 for USB issues.  Note that they have the firewall settings in there:
http://www.microsoft.com/windowsmobile/en-us/help/synchronize/activesync-usb.mspx

You can point your DNS name back to localhost address by adding this as the last line in this file - note there is not a file extension for this file (open with Notepad - use Save, not Save As.. so you don't accidentally add a file extension):

Add this line:
127.0.0.1       myExchange.selfip.net

At the bottom of this file:
C:\WINDOWS\system32\drivers\etc\hosts



If by local server you mean an actual server that isn't running on your workstation then substitute the 127.0.0.1 with the IP address of that server.
0
 
rowekAuthor Commented:
Paranormastic, I am sorry I did not know you replied.  I am forced to do the DNS entry on my SonicWall router as it is trumping us.Before I bought the SonicWall we worked great.  I did add the DNS entry on our server way back in December but it did not work.

ince the solution is DNS and I have clarified WHERE the entry must be made I am awarding points. Sorry about the delay.  Keith
0
 
rowekAuthor Commented:
Just in case anyone wants to know exactly what I had to do:
1) Open my SonicWall mgt console
2) Add an access rule for "SSL"
3) Allow traffic from * to myExchangeServer
That's it!  Piece of cake.  I do not consider this a risk as I already needed a rule that allowed a source of WAN which is the outside anyway.  
My phone syncs just like the good old days and web pages that were once denied over SSL are flowing again.  Keith
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now