BES talking to MS SQL 2000

Hi All,

For one reason or another, we are going through a process of changing every password on our network. Everything is going to plan, until we get to BES.

We have 2 servers, BES and SQL Server 2000, of which they both talk to eachother. The majorty of the Blackberry services on BES use a domain 'Log On' account. This password has been changed successfully without issue.

I have since logged into the SQL Sever and changed the 'sa' password. As soon as that happens, BES stops working, and the event logs show the error:

"Unable to open BESMgmt database: Login failed for user 'sa'"

I cannot for the life of me find where I need to tell BES the new 'sa' password. I would have thought it shouldn't need it because of the domain service accounts - but it's obviously not the case. If it helps, we run a Lotus Domino email client.

Any help is very welcome. Many thanks,

Pete
LVL 2
PeterHingAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ALogvinCommented:
On your BES, run the BlackBerry Server Configuration Utility. There should be a section where you specifiy your database, and you can change the authentication username and password there.
0
PeterHingAuthor Commented:
Hi ALogvin,

You're Right, there is a 'Database Connectivity' tab which states the database and authentication method. At the moment, the authentication method is 'Windows (Trusted)'.

This is why i'm confused as to why BES fails to work when I change the 'sa' password locally on the SQL Server. It's using it somewhere - I just can't see where!

Any further ideas or if you can see where i'm going wrong, please don't be afraid to shout!

Pete
0
ALogvinCommented:
I found this...

1.       Open the SQL Server Configuration Manager. (Start | All Programs | Microsoft SQL Server 2005 | Configuration Tools)

2.       Select the SQL Server 2005 Service node and then select the SQL Express instance that is no longer working.

3.       Open the Property dialog for the instance. (Right-click menu or Action | Properties)

4.       Change the 'Log on as:' selector to Local System and click Apply.

5.       Once the server has restarted, change the 'Log on as:' selector back to Network Service and click Apply.
0
HTML5 and CSS3 Fundamentals

Build a website from the ground up by first learning the fundamentals of HTML5 and CSS3, the two popular programming languages used to present content online. HTML deals with fonts, colors, graphics, and hyperlinks, while CSS describes how HTML elements are to be displayed.

PeterHingAuthor Commented:
Hi ALogvin - Thanks for your reply.

We're currently using SQL Server 2000, so can't find that option unfortunately.

I have been digging a little more throughout the day, and ran SQL Profiler on the BESMgmt database. It appears it's the Blackberry Messaging Agent that's using the 'sa' credentials to access the database. Everything else appears to be using the network account for the database.

I now can't find anything referencing the Messaging Agent and a password? Does that help or give you any ideas?

Thanks again for your help so far.

Pete
0
ALogvinCommented:
DOMINO!

http://www.blackberry.com/btsc/articles/750/KB03543_f.SAL_Public.html

http://www.blackberryforums.com/bes-admin-corner/13966-problem-bes-connecting-sql-server.html

This is a domino specific problem, which is why it took me so long to find it ;)


Looks like you will need to add a registry key to fix it. I've never done this...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
PeterHingAuthor Commented:
ALogvin,

It worked perfectly, and allowed me to fix the problem. Thanks for sticking around to the end - a great help!

For anyone coming back to this post: You need to set the password in:
HKEY_USERS\.DEFAULT\Software\Research In Motion\BlackBerry Enterprise Server\Database
It's probably best to also restart BES after the change to ensure the Domino Connector works correctly

Thanks again,

Pete
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
BlackBerry

From novice to tech pro — start learning today.