Why am I unable to uninstall Exchange System Manager from XP or see correct store status?

I tried to uinstall Exchange System Manager from my XP workstation because in the Administrative Groups, one of my Exchange servers is now showing its mailbox store and public folder store as unmounted even though that is not true. When I try to mount it, it says that I have insufficient rights. I am trying to uninstall the System Manager so that I can do a clean install on it and get the correct status of my stores back, but when I run the wizard it does not let me choose the option to uninstall saying that it is not compatible with Professional. I have tried just deleting the Program Files folder and registry keys assocatied with Exchange. Can someone tell me who to get the correct status of the stores or how to copletely uninstall the remote install of Exchange System Manager? Thanks!
gfcnetworkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MightySWCommented:
Try doing the manual removal:

http://support.microsoft.com/kb/833396/en-us

HTH
0
gfcnetworkAuthor Commented:
Stores are still showing as unmounted after a re-install. Was not able to find many of the components that I was supposed to disable or delete....any more advice??
0
MightySWCommented:
But your exchange server is ok right????
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

MightySWCommented:
Also, can you give some more details on the error that you might be getting when deinstalling?  Can you look at the event viewer and let me know what you see as far as errors that pertain to this?  Also, what is the error that it gives you when you try to mount the stores (exact).

Thanks
0
MightySWCommented:
Also, do you have the XP firewall running on your system or another endpoint protection?  This really seems like an firewall blocking RPC issue.

Let me know.
0
gfcnetworkAuthor Commented:
The exchange server and stores in question are fine and show up correctly from any of the actual exchange servers in our environment.
 
The exact error when trying to uninstall is: The component "Microsoft Exchange Forest Preparation" cannot be assigned the action "Remove" because: - You cannot install this product on a computer running Windows Professional
The error I receive when I try and mount the store is: You do not have the permissions required to complete the operation on the infomation store. ID no: c1041723 Exchange System Manager
I have researched both errors and have tried following the KB article instructions that pertain to them already.
 
I do not have the XP firewall or any firewarll running on my workstation. I will try unloading my anti-virus which may have an embedded firewall and try again, but if you have any other suggestions in the meantime, please let me know! Thanks!
 
0
MightySWCommented:
You might want to check this out:

Its about the permissions of the full administrative delegations.  

Download AD explorer and install from here:
http://technet.microsoft.com/en-us/sysinternals/bb963907.aspx

Navigate to CN=Configuration,
CN=Services, CN=Microsoft Exchange, CN=First Organization, CN=Administrative
Groups, CN=First Administrative Group, and check to see if  "deny" permissions have been set for ANYTHING...
0
gfcnetworkAuthor Commented:
There are deny permissions for an individual account we use pertaining to our backups for Send As and Receive As and a deny permission for Exchange Domain Servers for the Receive As permission. These permissions are no different than other servers in the same organization.
0
MightySWCommented:
Is this the security tab or the AD explorer?

Also, check this thread out.

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_21511622.html

You will have to run ADSI edit.
0
gfcnetworkAuthor Commented:
AD explorer
I looked at the thread, but don't think this applies since it has to do with an environment that Forest Prep already was run successfully on. It's just a System manager console that is showing the stores as down...
0
MightySWCommented:
What version of service pack do you have on your XP box and on your exchange install?  Does your SP on your machine match your server's

If not, then be sure to update or reinstall on your workstation.  We need to reset some permissions here.  Just for grins, you are a Full administrator in exchange right?  Domain admins are not by default a member of this group.
0
gfcnetworkAuthor Commented:
Workstation has SP3 and Server has SP2.
Yes, I am a full admininstrator in Exchange as well as an Enterprise Admin in AD.
0
MightySWCommented:
No, I am talking about the exchange service pack.  You have to service pack exchange on your workstation too even if you are just running the ESM in administrative mode.  And unless you delegate yourself as a full administrator then you don't have it.  Even enterprise admins do not have this right by default.

I would go with exchange SP2.  Check the server ESM to see what version of exchange you are running and what SP it has.

You can do this by opening the ESM on the server, open up the administrative groups, DOMAIN, and open the Servers folder only.  You should see the Edition and the Service pack on the right pane.
0
gfcnetworkAuthor Commented:
You are correct. It is SP2. To be exact. It is Version 6.5 (Build 7638.2) on the server. I see this information from my workstation console. I have not put the Exchange SP on my workstation.
Please confirm that I need to install this SP2 on my workstation.
And yes, I have explicitly been designated a Full Exchange admin through the Delegation Wizard from the ESM. I was just giving you more background about my network rights.
0
MightySWCommented:
Ok, cool.  Yes install exchange SP2 on your workstation.

Also when was the last time you ran some spyware/malware program like adaware and spybot S&D on your workstation?
0
gfcnetworkAuthor Commented:
SP2 for Exchange was installed on my workstation. I rebooted just in case and still the stores do not show up as mounted. I have not run spyware/malware in a quite a while, but I do have our corporate antivirus on my workstation and our network is pretty well protected.
0
MightySWCommented:
And when you try to re-install / uninstall?
0
gfcnetworkAuthor Commented:
Still getting the "cannot install on a Windows Professional product" error message when I try to uninstall...
0
MightySWCommented:
alright, try this:

do the add remove and select exchange and click change/remove

and then under the component selection select the "Change" and NOT the Remove.

Set the second option (MS Exchange System Management tools to remove.

That will get it off of your machine.

Try a reinstall after that from the CD and just do the admin tools.

have fun
0
gfcnetworkAuthor Commented:
I have tried this already with the same results.
0
MightySWCommented:
I get the same results when I try to do the remove on the first option, but when I select change on the first option and then remove on the 2nd it works...no?
0
MightySWCommented:
The only other thing that I can think of is that when you originally did the install you installed with the /forestprep switch.

Let me do some more digging and see if can't replicate.
0
gfcnetworkAuthor Commented:
I can guarantee that I did not use that switch during the workstation install or the server on which the stores in question reside. I did not run the forest prep at all since I've taken over Exchange since there was already an Exchange 2003 box on the domain....any other help would be greatly appreciated....
0
MightySWCommented:
ok dude, did you try with another profile (domain admin profile) on your workstation?  Be sure that the profile doesn't exist on your machine before you try it.

I was at the gym tonight thinking about this one... We will get it fixed!
0
gfcnetworkAuthor Commented:
I was able to see the stores correctly when signed in as a different user...
0
MightySWCommented:
Ok, then that is it then.  Are you up to recreating your profile?  I would just copy your favorites and desktop and startmenu and then sign on as local administrator and delete your profile.

When you sign back in and you profile automatically recreates itself be sure to test it.

I think that this is the quickest and best way to go.  This way you will have a fresh profile and you won't lose anything as long as you save it and then copy back.  The whole procedure should take about 10 minutes.

0
gfcnetworkAuthor Commented:
Unfortunately for me, there's a lot more to it, since my workstation tests out applications for all the departments at times too, but at least I know what it is...I don't suppose you know how to cleanly remove Exchange without leaving any traces from the whole computer and that way it would just be Exchange that I would have to re-install?
0
MightySWCommented:
That MS article that I refered to before is the true and tested method on how to do it.

Another way is to try using the msclean up utility.  It is kind of cheesy, but it might do the trick.  

You can DL it here: http://support.microsoft.com/kb/290301

Also, have you tried to do a runas on the ESM?  You can try to run it as the user that previously worked.  Its worth a shot.

Let me know
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gfcnetworkAuthor Commented:
You're a genius! Until I do a complete re-install the "runas" works! Thanks!
0
MightySWCommented:
LOL, can you believe that...

I can't believe I didn't think of that before...

Glad to help.
0
gfcnetworkAuthor Commented:
I can't believe I didn't think of that either! Cripes!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.