Exchange with 2 seperate DNS names

We are running an Exchange 2003 server with a complete windows enviorment. We have two different domain names for two companies we run. We want to be able to get and send email from both joe@company1.com and joe@company2.com from the same Outlook session. I created the accounts and configured it, but every time we try to response to an email from company2 from outlook we get an error that we are don't have permissions to this reciepent. They can send and recieve from a Online Outlook access but would like to send and recieve from the local outlook program.

Thanks
gilby54Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

gupnitCommented:
Hi,
have you configured the Recipeint Policies http://support.microsoft.com/kb/268838
Thanks
Nitin
0
butor69Commented:
I suppose you have set the two mail domain in the recipient policy?
am I correct ijf I say that joe@company1.com and joe@company2.com are two different Acticve directory users? If no , that will never work because one AD user has only one reply address.

If you want two email addres for the same user, you have to create two usaer account with two diffent mail address so joe for company1 and joe2 for company2. Then you have to give rights to joe to sendas joe2 mailbox. and also full mailbox access maybe.
0
gilby54Author Commented:
Yes the company2 domain is listed in there and has a checkmark next to it.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

gilby54Author Commented:
They are two different AD accounts. The main account does have sendas and full access.
0
gupnitCommented:
Hi,
Well you will have to keep the 2 domains in the Recipeint Policies. Also, same user can have 2 email addresses configured to same mailbox.
But, I am kind of confused now, what is your trouble?
Thanks
Nitin
0
gilby54Author Commented:
The problem is that when an email comes into the Outlook that is for the joe@company2.com and the user responds to it, he will get an message that it is undelieverable and he doesn't not have access to send to the reciepent.
0
MarkMichaelCommented:
The only issue here is send as rights.

He has 2 separate users, as the limitations with Exchange only allow you to send OUTBOUND as a single address.
gupnit: whether you have 10 email addresses under your user recipient policy, you can only send out from a the primary address and this is the address all users receiving the email will see.

The issue that gilby54 seems to be a 'send as' issue.

Please open up each account within MS Outlook by logging into them with the necessary account details and check the 'delegate' options.

Also, check in Active Directory to see if anyone has been added to the Account for Send As rights under Active Directory Users and Computers.
When trying to 'send as' please add the 'username' of the user in the From box, by selecting him/her from the GAL (global address list).
0
gupnitCommented:
Mark - I am aware of that, it is bread and butter for me. I was confused about the question, and thats why asked for more information. I was thinking both domains are not getting the mails.
Now thay my query has been answered here are your steps:
  • Start ADUC (dsa.msc) | View menu | Advanced Features.
  • Now right click  joe@company2.com  | Properties.
  • Security | Advanced | Add | Type joe@company.com ( you want to grant Send As permissions to him)
  • Click Check Names | Click OK
  • Select "This object only" in "Apply to" dropdown,
  • Check "Allow" under "Send As" in the Permissions
  • Click OK to close
In Outlook:
  • Make sure both Mailboxes are configured
  • Now send a reply, it should work
Let me know
THanks
Nitin

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.