Turns on but blank screen

Working on very important work PC. Running the P5E3 Deluxe. I have 4 sticks of 1gb TeamExtreme 1333 ram. I am using an 8600GTS graphics card. The CPU is intel Quad core Q9550 -  the C1 stepping.

I originally had a Q9550 with a E0 Stepping, but the PC would give me blank screen. I switched to C1 - still nothing. So, I used an older quad core, put in only 1 stick of ram, erased CMOS and finally got into BIOS.

I used a flashdrive to update bios and was able to do that. I then tried putting all sticks of memory back in, and got it to work with that. Then once I tried putting the new Q9550 CPU back in (c1 stepping again) - nothing.

The bios is supposed to support it officially. Also, I tried both CPUs in another pc - worked great.

Please help!
StaindSou11Asked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wassa_rCommented:
I think you have a problem with your powersupply.

Try using an old or less powerconsuming graphic card and you will know if you need a bigger powersupply.. you can also try to disconnect things like your dvddrive or harddisk and try to boot.

Looking at the specifications you would need to have a powersupply with 500watts or even more.
0
StaindSou11Author Commented:
Im sorry, I should have stated my power supply - my brain is getting pretty worn out on this problem so Im forgetting things.
My power supply is a Rosewill 950 watt. That shouldnt be a problem, correct? I will try unplugging some things and see what happens.
0
CallandorCommented:
Try using one memory module again to get into the BIOS, as you did before.  When you use 4 memory modules, you present a greater electrical load and the signal edges may get "smudged".  The way around that is to slow down the timings so that the signals are always detected unambiguously.

If that doesn't do it, your motherboard may have some bad capacitors which may or may not be visible (see www.badcaps.net).
0
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

wassa_rCommented:
Just to make sure.. check that the 4/8 pin power connector next to the cpu is connected.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
StaindSou11Author Commented:
Looks like the 4/8 pin power connector went bad on my  PSU - fixed it and everythings good now. thanks!
0
StaindSou11Author Commented:
Thanks man!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Components

From novice to tech pro — start learning today.