Transfer Text - Character missing from input data

If I manually import a .csv file in an access table, I have no problem.  However I am now trying to use Transfer Text in a macro to import the data.  When I do the import using Transfer Text, the first character of the third column of data is missing in the table.  For example, if a cell in the the third field in the.csv contains K11, the table field contains 11.(Note - the fomat of the data in this field is a letter followed by a number such as K11, J5, etc. )   I do get an error stating type converion error, but the table field is text.
I'm confused and could use your help!  Thank you.
kshumwayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Rey Obrero (Capricorn1)Commented:
are you using an import specification? try editing the import specification
0
kshumwayAuthor Commented:
I guess I'm not sure what an import specification is.  I've attached how the Transfer is set up in the macro.  If there is something more, please enlighten me!  Thank  you!!!
EEAttach.doc
0
Rey Obrero (Capricorn1)Commented:
there is no import specification used in the macro.

try importing the csv to a non-existing (new) table
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

kshumwayAuthor Commented:
When I use a new table, it pulls the values in as currency.  Instead of using the macro, I used the statement:

DoCmd.TransferText acImportDelim, , "tblNew", _
        "\\ksqldb\dbapps\KathyTest\SpecimenCount\SpecimenCnt.csv", False

The second parameter is the specification?  How would I set one up?
0
Rey Obrero (Capricorn1)Commented:
to create an import specification

1. File>get external data>import
2. select in the File of types box   Text files (*.txt etc..
3. select the file
4. in the import text wizard window select  delimited
5. Click advanced
6. in the import specification window
    type the name of the field in the Field Name column
    (here you can use the field names of the destination table, specify data type,
      check the box Skip if you do not want to import the column)


7 click save as, give the specification a name  <-- this is the specification name that you will use in the command line

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kshumwayAuthor Commented:
That worked!   Thank you so much!!!!!
0
kshumwayAuthor Commented:
Worked perfectly!!!! Thank you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Access

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.