Remote Desktop locks up at login - black screen

I have recently reformatted 2 machines and downgraded from Vista Ultimate to XP Professional SP3.  One is at my house, and the other is at work.  Both workstations are completely different hardware-wise, and I have used remote desktop successfully when they were both Vista for 8+ months.  Nothing has changed on either network, and the hardware is exactly the same as it was when it was Vista.  

Now, when connecting to either computer remotely via Windows Remote Desktop, either between the two, or from a 3rd (or 4th) completely separate computer (on randomly different networks), I get the bar at the top with the IP address, and the login screen, I log in, and the screen goes black and basically locks up the computer until i do a manual shutdown of it via the power button on the front of the machine.  

I have searched and searched for answers and have found various different solutions, but none of them seem to be the right one. Again, this is just with these two newly formatted computers with all service packs and patches, and the firewall has been adjusted accordingly.  Anyone have any ideas?  I'm thinking it has to do with something in a patch because both computers were redone within a week of each other, but nothing on Microsoft's site seems to shed some light on this really strange problem.
CompguyGAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RayData AnalystCommented:
what additional software is on both xp machines ??  Firewalls, AntiVirus, anything along those lines.
Also, have you tried connecting with a different user account??
0
jckingjcCommented:
Hi CompguyG,

I have problem with Terminal services on SP3 as well. What i did is uninstall SP3 and install SP2. It works perfect for me.

Or if you want to keep SP3 you can try download Terminal Services Client 6.0.

http://support.microsoft.com/kb/925876 

Good luck.
0
Rob WilliamsCommented:
The most common solution to fixing a black screen at logon is to disable "Bitmap Caching", in the Remote Desktop client connection properties, under options/Experience'.

A gray or other color screen is usually due to a screen saver being active on the host/server computer, but you could try disabling that as well.
0
Acronis True Image 2019 just released!

Create a reliable backup. Make sure you always have dependable copies of your data so you can restore your entire system or individual files.

RayData AnalystCommented:
PS...  Not a solution, but I strongly recommend REALVNC instead of RDP.  Free for personal use and it has far more options and offers better performance.

Link to free edition
http://www.realvnc.com/products/free/4.1/winvnc.html
0
CompguyGAuthor Commented:
I have found the solution and it works great.

The root of the problem is that the session image space is too small and it can't load any more drivers into it.  The session image space is shared for the display driver drivers and printer drivers.  There tends tobe an issue with rdpdd.dll = remote desktop protocol display driver.

You can fix this bug by increasing the size of the session image space via a registry key.  Add the following key:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]

"SessionImageSize"=dword:00000020

Thanks to all for your input.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
CompguyGAuthor Commented:
After looking closer at jckingjc's comment about service pack 3, I did some extensive browsing today to find this solution.
0
tlatackiCommented:
FYI, we had to increase the setting CompguyG indicated above to 80 for it to work

Final value was 00000080(128)
0
sigmon_wCommented:
thanks, that worked great!!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.