• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 698
  • Last Modified:

Issues with a voice vlan

We're trying to set up some new cisco switches. These new cisco siwtches are replacing some old dell switches. The dell switches are tied together via fiber and are on opposite ends of the building.

At each workstation in the building, there is a network drop running into a cisco phone, then it goes out of the phone and into the PC.

The cisco phones are configured for VLAN 100. The default access VLAN is 1 (must be what the workstations are using). THe phones receive DHCP from a cisco 1841 router that is currently connect to the old dell switches.

We configured the new switches via the GUI so that it showed each port to be configured for Cisco Phone and PC, and we changed the VLANs for each accordingly (100 and 1, respectively).

However, when we changed out the switches the phones never came back up. We noticed that the port on the new cisco switch that was connected to a cisco 1841 router was disabled. A look into the console showed that it was err-disabled. What should we do to make this work?
0
dajwilso
Asked:
dajwilso
  • 3
  • 3
1 Solution
 
devangshroffCommented:
you need two create 2 VLAN

onle VLAN 100 for Data and VLAN 200 Vocie and created 2 DHCP scope for VOice and data
  connect switch---------IP phone-------PC if phone with 2 ethernetg
else connect in saperatle
0
 
dajwilsoAuthor Commented:
The switches do have 2 VLANS. One is VLAN 1 (data) and the other is VLAN 100 (voice). However, any time we connect the Cisco 1841 Router to the switch (it is what feeds the phones DHCP) the port becomes err-disabled.

We do not have access to the Cisco 1841 Router but the whole system is already working, we just want to change out the switches (currently Dell) with new Cisco Switches.

I read that we have to make sure the port that the router is plugged into is trunked. We used the following command in that port's (port 23) configuration terminal:

switchport mode trunk

But the port still becomes err-disabled. The switch gives a message about BPDU guard causing this. Any ideas?
0
 
harbor235Commented:

The phone essentially has a l2 switch embedded, turn off BPDU guard on the phone switch port, then shut, no shut the interface. Also, make sure CDP is enabled and that you see the phone on the switch port

show cdp neighbor <phone_switch_port> detail

If it is not on, turn CDP on

harbor235 ;}
0
What is SQL Server and how does it work?

The purpose of this paper is to provide you background on SQL Server. It’s your self-study guide for learning fundamentals. It includes both the history of SQL and its technical basics. Concepts and definitions will form the solid foundation of your future DBA expertise.

 
devangshroffCommented:
its ok , but you need to creaet VLAN in switch and a trunk port in cisco switch
0
 
dajwilsoAuthor Commented:
How do I go about making a trunk port on the cisco switch? Could I see an example? I look at the documentation and I thought it was just:

switchport mode trunk

but not sure.

Thanks!
0
 
devangshroffCommented:
its mendatory to creat
 TRUNK else how vlan traffic will pass
0
 
dajwilsoAuthor Commented:
Ended up turning off BPDU guard and portfast on the interface the router was connected to
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now