to install imagemagick and ghostscript on linux server for doc to pdf conversion using openoffice

Posted on 2008-11-17
Last Modified: 2013-12-21
To get the task done, I used the listed steps (along with urls)

Steps followed
- rpm -q ImageMagick
- yum install ImageMagick

imagemagick installed, now trying ghostscript
cd /usr/local/src/
tar zxf ghostscript-8.63.tar.gz
cd ghostscript-8.63
make install

-- problem --
[root@server ghostscript-8.63]# ./configure
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
echo $PATH
output : /usr/kerberos/sbin:/usr/kerberos/bin://sbin://bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin

-- problem --
[root@server ghostscript-8.63]# updatedb
-bash: updatedb: command not found

find / -name gcc
output : /usr/libexec/gcc
update path ???
this is for current login - need more permanent solution
(view) cat .bash_profile
(edit) vi .bash_profile
(view changes) cat bash_profile

run the script
. /root/.bash_profile
check path
echo $PATH
Output : /usr/kerberos/sbin:/usr/kerberos/bin://sbin://bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/root/bin:/usr/libexec/gcc

now trying ghostscript install
[root@server ghostscript-8.63]# ./configure
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

-- problem --
path updated but still does not find compiler - why ???

I searched about this but could not figure out what am i missing. I am a newbie on linux, please provide detailed answer if possible.
Question by:SWB-Consulting
    LVL 3

    Expert Comment

    I'm not into this but i think you can solve the compiler problem with installing gcc

    would be something like:

    yum install gcc

    Author Comment

    wassa, I tried your suggestion
    yum install gcc
    output :
    Installed: gcc.x86_64 0:4.1.2-42.el5
    Dependency Installed: glibc-devel.x86_64 0:2.5-24 glibc-headers.x86_64 0:2.5-24 libgomp.x86_64 0:4.1.2-42.el5

    this worked, so i got back to my original task
    trying ghostscript install
    cd /usr/local/src/ghostscript-8.63
    output :
    after doing lot of stuff, last four lines printed
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating cups/pstopxl
    config.status: creating cups/pstoraster

    trying next command 'make'
    -bash: make: command not found

    -- problem --
    make missing ?
    apt-get install
    -bash: apt-get: command not found
    yum -y install gcc automake autoconf libtool make
    output :
    Installed: libtool.x86_64 0:1.5.22-6.1 make.x86_64 1:3.81-3.el5
    Dependency Installed: autoconf.noarch 0:2.59-12 automake.noarch 0:1.9.6-2.1 imake.x86_64 0:1.0.2-3

    again trying make command
    output :
    after doing lot of stuff, last few lines printed
    /usr/bin/ld: cannot find -lstdc++
    collect2: ld returned 1 exit status
    make: *** [obj/mkromfs] Error 1
    LVL 3

    Accepted Solution

    Maybe try to just install the things that cannot be found, this worked for me before.. but not sure if it will work in your case.

    Hope you will be able to get the next error away by installing the lstdc++ ting:)

    yum install

    Featured Post

    How your wiki can always stay up-to-date

    Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
    - Increase transparency
    - Onboard new hires faster
    - Access from mobile/offline

    Join & Write a Comment

    In a previous article published here at Experts Exchange, Signature Image with Transparent Background (, I explained how to cre…
    PaperPort has a feature called the "Send To Bar". It provides a convenient, drag-and-drop interface for using other installed software, such as Microsoft Office. However, this article shows that the latest Office 2016 apps (installed with an Office …
    In this video, we show how to convert an image-only PDF file into a PDF Searchable Image file, that is, a file with both the image (typically from scanning) and text, which is created in an automated fashion with Optical Character Recognition (OCR) …
    This video Micro Tutorial is the first in a two-part series that shows how to create and use custom scanning profiles in Nuance's PaperPort 14.5 ( But the ability to create custom scanning profiles al…

    730 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    19 Experts available now in Live!

    Get 1:1 Help Now