How do I reinstall deleted USB Controllers?

Hello,

My computer was not recognizing plug-and-play USB devices so I tried to fix it.

First I ran a Widows update to make sure my computer was up-to-date. It said it was.

Then I did the "show all hidden devices" and deleted all the entries in the USB section of the device manager. I recognized entries for many devices I'd tried to plug-and-play that hadn't been recognized.

However, when I rebooted and the Found New Hardware  Wizard came up asking for the USB controllers, I put in the OEM CD that I thought came with my computer and... it was the wrong one. I am traveling and took the OEM CD for my other computer... I won't be able to get the correct CD for another three weeks.

I tried to do system restore, but was unable to.

Please tell me if it is possible to find the USB controllers elsewhere, or if there is another way to solve this problem.

My computer info is as follows:
Model: Toshiba Satellite A105
OS Version: Windows XP Home 5.1.2600 Service Pack 3
BIOS Version: 1.50
CPU: Intel (R) Celeron(R) M Processor 1.70 GHz

In the Device Manager, I've got big yellow question marks and exclamation points on "Other Devices" and nested under it Universal Serial Bus (USB) Controller, three times.

However, there are 4 USB ports on the computer.

Expert help will indeed be highly appreciated!

Best regards,

Polichinelle

polichinelleAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Milan_OjhCommented:
Havw a look of this web page.

http://support.microsoft.com/kb/283657

thanx..
0
orangutangCommented:
Also, what do the details of the exclamation marks when you look at their properties?
0
polichinelleAuthor Commented:
Hello Milan Ojh,

Thanks for the webpage. I tried to roll back the driver as per the instructions,
and I got the message: "No driver files have been backed up for this device."

Any other suggestions?

Polichinelle
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

polichinelleAuthor Commented:
Hello Orangutang,

The USB Controller Properties are as follows:

Device tupe: Other devices
Manufacturer: Unknown
Location: PCI bus 0, device 19, function 2

Device Status:
This device is not configured correctly. (Code 1)
To reinstall the drivers for this device, click Reinstall Driver

(If I click on "reinstall driver" is opens the Hardware Update Wizard and as I mentioned in my first message, I don't have the OEM CD that came with my computer.)

I have the same properties for the three USB Controllers with exclamation points.

(If you need information from the "Driver" "Details" or "Resources" tabs, let me know and I'll copy that too.)

Thanks,

Polichinelle
0
sensored2008Commented:
use  driverupdater
0
polichinelleAuthor Commented:
Hello Sensored2008,

Where can I find driverupdater? If it's on my computer, please give a file path. If not, please send a link.

Thanks,

Lynn
0
sensored2008Commented:
0
JonveeCommented:
Polichinelle,
Here's an article explaining how to update a hardware driver, which should help >

How to update a Windows hardware driver:
http://www.bleepingcomputer.com/tutorials/tutorial119.html
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JonveeCommented:
Also useful ideas in these two links>

"Troubleshooting Device Conflicts with Device Manager":
http://support.microsoft.com/default.aspx?scid=kb;en-us;Q310126

Device drivers.Indentifcation & Installation:
http://www.experts-exchange.com/Software/System_Utilities/Drivers/Q_22433189.html
0
polichinelleAuthor Commented:
Hello again sensored2008,

Thanks for the link. I downloaded the file, copied it on a CD and then installed it on the computer with the USB problem.

I got an error message "The System cannot find the file specified" and then another one "z1D_camaxalig
runtime error '35756' Unable to complete request"

I looked on the FAQ at the driver updater website, but saw no answers to this problem. I also send a message to their technical support.

Any suggestions on how to correct this, or another way to solve the initial problem?

Thanks,

Polichinelle
0
JonveeCommented:
>> error message "The System cannot find the file specified" and "z1D_camaxalig .. " <<

Have you previously & thoroughly checked for Malware & Viruses?  
If in any doubt, please run these >
Malwarebytes' Anti-Malware:
http://www.malwarebytes.org/mbam.php

Also the Kaspersky free online virus scanner which is a good way to find out if you have any viruses or spyware without having to uninstall your existing antivirus software>
http://www.kaspersky.co.uk/virusscanner
0
sensored2008Commented:
scan your pc as Jonvee suggested but  just  for viruses to see what will come out  when u  fully  scan the  machine  for  viruses, however, if you have been using any registery tweakers or antispyware or malware  to detect them, and  the scanning for virus found nothing and  just repair your os using the  second repair option from the xp  cd.
0
polichinelleAuthor Commented:
Hello Jonvee,

Thank you for the very informative links. I tried to indentify the drivers needed through the instructions on
"Device drivers.Indentifcation & Installation":

The vendor number is 1002, which I looked up www.pcidatabase.com and came up with "ATI"
However, when I looked up the device numbers ( 4374, 4375 ) there are no devices listed. Looking up device number 4373 showed me a NEC chip reference, so that wasn't correct either.

I looked on the ATI website and couldn't see anything that looked like a USB driver.

Any other suggestions, or have you noticed something I've done wrong here?

Thanks,

Polichinelle


0
sensored2008Commented:
orginally  you only  need the intel  chipset for the machine, if you give me your mb model  i'll get it  for you
0
polichinelleAuthor Commented:
Hello Jonvee,

I just ran the anti-malware, nothing was found.

I have Norton Internet Security 2008 running on that machine and was doing regular updates and scans, but I'll try to bring the computer to a wi-fi connection point and run the on-line virus scan.

I'll let you know if that uncovers anything.

Thanks,
Polichinelle

0
polichinelleAuthor Commented:
Hello sensored2008,

See above comment for anti-malware/virus update.

I am not sure where to find my motherboard model.

My processor is
x86 Family 6 Model 13 Stepping 8 GenuineIntel ~1691 Mhz

The model no. on the bottom of the laptop is:
Toshiba Satellite A105 - S2071 System Unit
Model no. PSAA2U-04U019

If these don't help, please tell me where I might find the information.

Thanks,

Polichinelle
0
JonveeCommented:
To find your computer motherboard details you could download and run Lavalys "EVEREST Free Edition 2.20":
http://www.majorgeeks.com/EVEREST_Free_Edition_d4181.html

Have to logoff for a few hours, but will checkout all comments here immediately upon my return.
0
JonveeCommented:
You may well be pleased with Norton Internet Security 2008 but no system can guarantee catching every parasite, hence the suggestion of using the scanners above  ;)  

As you are trying to identify a driver for a driverless component, scroll to phototropic's comment in this previous thread, it may help >
"How to find the manufacturer and model of your hardware device":
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_23634665.html
0
polichinelleAuthor Commented:
Hello Jonvee,

Thanks for the additional info. I've downloaded Everest and will install it on the other computer and report back with the info.

I, too, have to work on other things, so it might be a couple hours before I can report back the results.

Until then,

Polichinelle
0
CallandorCommented:
The USB controller is part of the motherboard chipset support, so installing the motherboard drivers (specifically the Southbridge chipset) will get your laptop USB ports working again.  Since you have a laptop, the drivers have to be very specific; typically only from your laptop manufacturer.  Try
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/home.jsp?nav=Download for your specific model.
0
jimilicaCommented:
You can check this link and find there  comon module driver and PC Diagnostic tool
http://eu.computers.toshiba-europe.com/innovation/download_drivers_bios.jsp?service=EU

HTH
0
polichinelleAuthor Commented:
Hello Callandor,

Thanks for your answer. I followed the link and looked up my model (Toshiba Satellite A105 - S2071)
and clicked on the "Drivers" but I'm not sure which one is applicable.
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=DL&os=&category=&moid=1310939&rpn=PSAA2U&selCategory=3&selFamily=1073768663&selModel=1310939|PSAA2U#

The first listed is 'ATI UMA Chipset and Display Driver for Windows XP'

Is this the correct driver? Will I risk messing up the display (which works fine, the only problem is the missing USB Controller drivers) ?

Thanks,

Polichinelle

0
polichinelleAuthor Commented:
Hello Jimilca,

Thanks for joining the fray. I already have the Toshiba PC Diagnostic Tool on the computer,
and it when I run it, everything is "PASS" except the USB, which is "FAIL".

Forgive my ignorance, but what is a "Common Module Driver" ? I don't see that on the list of drivers offered for my model. Here's a link to the list :
http://www.csd.toshiba.com/cgi-bin/tais/support/jsp/modelContent.jsp?ct=DL&os=&category=&moid=1310939&rpn=PSAA2U&selCategory=3&selFamily=1073768663&selModel=1310939|PSAA2U#

If you could point me towards the correct driver, I'd appreciate it.

Thanks,

Polichinelle
0
CallandorCommented:
>The first listed is 'ATI UMA Chipset and Display Driver for Windows XP'

That should be the one.  Create a system restore point if you are afraid your display drivers may be messed up, but Toshiba should have the correct drivers for their product.
0
orangutangCommented:
Also, try opening to C:\WINDOWS\inf and right-clicking:
usb.inf
usbport.inf
usbprint.inf
usbstor.inf
and click "Install"
0
polichinelleAuthor Commented:
Hello orangutang,

I opened C:\WINDOWS\inf as suggested, but I must have done a good job deleting the USB controller drivers because I don't have any .inf files of those names.

I have only usb.PNF, usbport.PNF, usbprint.PNF, usbstor.PNF
and a "setup information" file for each of those file names.

I wish that could of worked, it sounded so easy! Pity.

Polichinelle



0
polichinelleAuthor Commented:
Hello Callandor,

I set a restore point. Just to be extra safe, is it possible to add the driver in "Safe Mode" or is that not at all applicable here?

Thanks again for the advice.

Polichinelle
0
☠ MASQ ☠Commented:
Whilst you have deleted your .inf files when Windows wants to install the USB controllers have you pointed it at C:\Windows\System32\ ??
0
CallandorCommented:
>is it possible to add the driver in "Safe Mode" or is that not at all applicable here?

Not applicable - safe mode does not use the specific drivers installed, and should always be available.
0
JonveeCommented:
Have you been able to fix your problem using any of the drivers (or comments!) above, or have other difficulties arisen?
Or perhaps you've decided on a work around, and then wait until you can intercept the correct CD in a little under three weeks ...
0
polichinelleAuthor Commented:
Hello Masqueraid:

I tried pointing it to C:\Windows\System32. No luck. Drat.

Thanks for trying,

Polichinelle
0
polichinelleAuthor Commented:
Hello Jonvee,

Thanks for your concern. I've been forced to put solving this USB problem aside momentarily
because of work concerns. I should be able to find some time to try the  solutions I haven't yet tried (and look for this mysterious OEM CD) this weekend.

I'll let you know what solutions worked and award point then.

Thanks again,

Polichinelle
0
polichinelleAuthor Commented:
I am actually not sure what response fixed the computer. I had accidentally let the battery completely go dead. When I restarted it again, it worked. I think it must have been fixed earlier, but since I simply did restarts without removing the battery, maybe the changes didn't take effect. Also, I had the recovery CD in my hand, (but did not need to use it). The mere threat of it was enough to make the computer behave... I'm very sorry that I can't be more precise so that someone else will be able to benefit from this solution.
0
JonveeCommented:
Glad you appear to have resolved the problem, & thanks for reporting back.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.