virtual server 2005 - can not use cached account details

Using Microsoft Virtual Server 2005 on a Vista Buisness Laptop, remote from office (and hence domain controller).
I have a domain account with local admin rights, and for all normal purposes it validates my password using locally cached security information when away front he office network.
However, last night I set-up Virtual server (I previously used Virtual PC) and successfully fired up several virtual machines. But when I set one of them to start automatically, using specified account, it refuses to start; giving the error:
"The virtual machine could not be started. The account name and password are invalid"
I have worked around this by creating a new local admin  account (which Vista allows me to do away from the domain controller) and using that.

Can anyone explain what is happening here? Is the problem:
- Vista needs to connect to domain controller to validate a domain account
- Virtual Server needs to connect to domain controller to validate a domain account
- Would it work OK if I had run it once whilst connected to the domain controller?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Virtual server must authenticate the user to a DC if it is a domain account.

You can create a local user just to run the VMs as you did. It does not need to be an admin account however, it just has to have full rights to the VM configuration files and the VHDs

It will not work with any cached credentials.
dcp002Author Commented:
Thanks for comment.
The local account allowed me to manually start the virtual server.
However, if I set the server to automatically start under this account, it has no network access. (Just says network cable is disconnected).  Starting manually, not referencing this account, and it works OK.

The reason I was doing this was an investigation into the possibility of running a Windows Server Small Business Server as a virtual machine in the event of a disaster recovery situation. In that situation, the domain controller which is on the SBS would not be available until AFTER the virtal server was running -with network access.  So it looks like in the disaster recovery situation, if this approach was adopted, it would not be possible to have the virtual server auto-start on re-start of the host pc?
In addition to the folder where the VM VHD files are kept grant full permissions on the host to the default folders:

C:\Documents and Settings\All Users\Documents\Shared Virtual Machines
C:\Documents and Settings\All Users\Documents\Shared Virtual Networks

The network folder is what is stopping you right now.
IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

dcp002Author Commented:
Is there any accont I can use on the host PC that would enable automatic startup of the virtual domain server, where the host pc is a member of the domain managed by the virtual server ?
Not sure I follow that question, are you saying if the virtual server is the domain controller?
but maybe this example will explain, this is our production environment:

I have:
VSHOST1 (physical system) Windows 2003 R2 SP2 64 bit Two Dual core AMD, 10GB RAM - HP DL145
       hosts guest VMs:
               ADC1 (Windows 2003 R2 SP2 32 bit - Active Directory Controller, master, FSMOs, DNS, DHCP )
               PS1   (Windows 2003 R2 SP2 32 bit - print server)
               Netmanage (Windows 2003 R2 SP2 32 bit - WSUS, WDS-RIS)
VSHOST2 (physical system) Windows 2003 R2 SP2 64 bit Two Dual core AMD, 10GB RAM - HP DL145
       hosts guest VMs:
               ADC2 (Windows 2003 R2 SP2 32 bit - Active Directory Controller, secondary, DNS, DHCP)
               Netmanage2 (Windows 2003 R2 SP2 32 bit - AntiVirus Master, othe IIS network services )

If both VSHOST systems reboot at the same time (such as during patch management maintenance windows) then the VMs can NOT auto-start because there is no active DC to authenticate a domain user against.
So I set ADC1 and ADC2 to use local accounts created for them alone on VSHOST1 and VSHOST2 respectively.
All other VMs use a domain account that is explicitly for VMs only.

The local account can be either a member of the local system administrors group (not neccessary but easier) or a special user with the file permissions as described previously.

Remember this user does not have any rights to/on the guest VM after it starts. I just has to have sufficient rights on the physical host to start the VM up. Access to the configuration files and vhd files.

dcp002Author Commented:
You say:
So I set ADC1 and ADC2 to use local accounts created for them alone on VSHOST1 and VSHOST2 respectively.

So do these auto-start using these local accounts? I was finding that when I used local accounts the virtual server would not auto-start, but cold be started manually.

Mine autostart fine with the local accounts.
On shut down of the host are you doing a "Saved State" of the VM? That combination will not autostart. You need to have the VM do a shutdown when the Host Virtual Server Service stops. Virtual Server 2005 sees a "Saved State" and it considers that VM already started. It's a Microsft thing.
dcp002Author Commented:
Doing that I have managed to get the virtual server to auto-start - BUT I then get a problem that the virtual server can not access the network - it just shows "network cable is unplugged" against the network adaptors.

If I run the server up manually under my domain account it has network connectivity.

The local account I am using has administrator privilidges on the host machine, but it seems no network access.
That is odd to confirm the details I just tested it again on my desktop system.

My desktop is Windows Vista 64 bit, Virtual Servr 2005 R2 64 bit, Virtual Machine is WIndows XP 32 bit
I use VMRC Plus v1.8 to manage my VMs.

I changed my XP VM to auto-start as a local user with only User rights, and modify to the shared Virtual Network folder and share Virtual Machines folders.

On Vista:
C:\Documents and Settings\Public\Documents\Shared Virtual Machines
C:\Documents and Settings\Public\Documents\Shared Virtual Networks

My VHD folder for this system:

Full network access.

dcp002Author Commented:
Sorry for delay in coming back, and thanks for going to trouble of testing.
I have re-checked , and with following:
Host = Vista Business 64Bit fully patched to date,
VirtualServer 2005 R2 64 bit
Virtual machine = Windows Server 2003 R2 (32 bit) fully patched to date.
Virtual machine set to turn off when virtual server stops.
If I use a local administrator account from the host to automatically start the virtual machine, it starts OK, but has no network access - it just shows "network cable is unplugged" against the network adaptors.
But if I start it manually when logged onto the host with my (cached) domain account which is a member of the local admin group on the host, then the virtual server starts and has full network access.

I am using 2 network adaptors on the host  - a gigabit physical network, and a wireless network. Both are affected in the same way.

Interesting, I would have to conclude it is a quirk with Vista as the host system.
I can not duplicate the problem using Server 2003 as host, works as described.
Would be interesting to see if this issue is reproducable on Windows Server 2008.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
dcp002Author Commented:
Thanks for your help, and time.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Virtual Server

From novice to tech pro — start learning today.