?
Solved

How can i setup the FXS port to receive FAX over PSTN on Cisco 2811?

Posted on 2008-11-18
4
Medium Priority
?
4,299 Views
Last Modified: 2012-05-05
Hi,

In my Cisco 2811 router i am running 12.4(20T) IOS and i have the following cads attached:

VIC2-2FXS
VIC2-2FXO
PVDM2 8

Right now i am using this router to route the outbound calls over PSTN using the 2FXO card (also the incoming calls are being routed to 2FXO card).

How can i setup the router to route all the incoming FAX calls to my FAX machine over the PSTN telco?

I have attached my running config that works perfect (please note that the 2FXS card is not yet attached, i will attach it when someone tells me how to config it because the router is in a working enviroment).

Router#sh config
 
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$pNpv$kw6GblwCklVhVsTeluqhg/
!
no aaa new-model
clock timezone Greece 5
!
dot11 syslog
ip source-route
!
!
ip cef
ip dhcp excluded-address 10.10.10.1 10.10.10.10
!
ip dhcp pool phone
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   option 150 ip 10.10.10.1
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
 supplementary-service h450.12
 no supplementary-service sip refer
 h323
 sip
  registrar server expires max 3600 min 3600
!
!
!
voice class codec 1
 codec preference 1 g711alaw bytes 160
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface BRI0/0/0
 no ip address
 encapsulation hdlc
 shutdown
!
ip forward-protocol nd
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/gui
!
!
!
!
!
!
!
!
!
tftp-server flash:Desktops/320x212x12/CampusNight.png
tftp-server flash:Desktops/320x212x12/CiscoFountain.png
tftp-server flash:Desktops/320x212x12/List.xml
tftp-server flash:Desktops/320x212x12/MorroRock.png
tftp-server flash:Desktops/320x212x12/NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/TN-CampusNight.png
tftp-server flash:Desktops/320x212x12/TN-CiscoFountain.png
tftp-server flash:Desktops/320x212x12/TN-Fountain.png
tftp-server flash:Desktops/320x212x12/TN-MorroRock.png
tftp-server flash:Desktops/320x212x12/TN-NantucketFlowers.png
tftp-server flash:Desktops/320x212x12/Fountain.png
tftp-server flash:gui/admin_user.html
tftp-server flash:gui/admin_user.js
tftp-server flash:gui/CiscoLogo.gif
tftp-server flash:gui/Delete.gif
tftp-server flash:gui/dom.js
tftp-server flash:gui/downarrow.gif
tftp-server flash:gui/ephone_admin.html
tftp-server flash:gui/logohome.gif
tftp-server flash:gui/normal_user.html
tftp-server flash:gui/normal_user.js
tftp-server flash:gui/Plus.gif
tftp-server flash:gui/sxiconad.gif
tftp-server flash:gui/Tab.gif
tftp-server flash:gui/telephony_service.html
tftp-server flash:gui/uparrow.gif
tftp-server flash:gui/xml-test.html
tftp-server flash:gui/xml.template
tftp-server flash:phone/7970-7971/apps70.8-3-2-27.sbn alias apps70.8-3-2-27.sbn
tftp-server flash:phone/7970-7971/cnu70.8-3-2-27.sbn alias cnu70.8-3-2-27.sbn
tftp-server flash:phone/7970-7971/cvm70sccp.8-3-2-27.sbn alias cvm70sccp.8-3-2-2
7.sbn
tftp-server flash:phone/7970-7971/dsp70.8-3-2-27.sbn alias dsp70.8-3-2-27.sbn
tftp-server flash:phone/7970-7971/jar70sccp.8-3-2-27.sbn alias jar70sccp.8-3-2-2
7.sbn
tftp-server flash:phone/7970-7971/SCCP70.8-3-3S.loads alias SCCP70.8-3-3S.loads
tftp-server flash:phone/7970-7971/term70.default.loads alias term70.default.load
s
tftp-server flash:phone/7970-7971/term71.default.loads alias term71.default.load
s
tftp-server flash:ringtones/Analog1.raw
tftp-server flash:ringtones/Analog2.raw
tftp-server flash:ringtones/AreYouThere.raw
tftp-server flash:ringtones/AreYouThereF.raw
tftp-server flash:ringtones/Bass.raw
tftp-server flash:ringtones/CallBack.raw
tftp-server flash:ringtones/Chime.raw
tftp-server flash:ringtones/Classic1.raw
tftp-server flash:ringtones/Classic2.raw
tftp-server flash:ringtones/ClockShop.raw
tftp-server flash:ringtones/DistinctiveRingList.xml
tftp-server flash:ringtones/Drums1.raw
tftp-server flash:ringtones/Drums2.raw
tftp-server flash:ringtones/FilmScore.raw
tftp-server flash:ringtones/HarpSynth.raw
tftp-server flash:ringtones/Jamaica.raw
tftp-server flash:ringtones/KotoEffect.raw
tftp-server flash:ringtones/MusicBox.raw
tftp-server flash:ringtones/Piano1.raw
tftp-server flash:ringtones/Piano2.raw
tftp-server flash:ringtones/Pop.raw
tftp-server flash:ringtones/Pulse1.raw
tftp-server flash:ringtones/Ring1.raw
tftp-server flash:ringtones/Ring2.raw
tftp-server flash:ringtones/Ring3.raw
tftp-server flash:ringtones/Ring4.raw
tftp-server flash:ringtones/Ring5.raw
tftp-server flash:ringtones/Ring6.raw
tftp-server flash:ringtones/Ring7.raw
tftp-server flash:ringtones/RingList.xml
tftp-server flash:ringtones/Sax1.raw
tftp-server flash:ringtones/Sax2.raw
tftp-server flash:ringtones/Vibe.raw
tftp-server flash:/Desktops/320x212x12/List.xml
tftp-server flash:/Desktops/320x212x12/CiscoFountain.png
!
control-plane
!
!
!
voice-port 0/1/0
 compand-type a-law
 cptone GR
 connection plar opx 1000
 impedance complex2
 caller-id enable
!
voice-port 0/1/1
 connection plar opx 1001
 caller-id enable
!
!
!
!
dial-peer cor custom
 name internal
 name local
 name domestic
 name international
 name 900
 name 976
!
!
dial-peer cor list call-internal
 member internal
!
dial-peer cor list call-local
 member local
!
dial-peer cor list call-domestic
 member domestic
!
dial-peer cor list call-international
 member international
!
dial-peer cor list call-900
 member 900
!
dial-peer cor list call-976
 member 976
!
dial-peer cor list user-internal
 member internal
!
dial-peer cor list user-local
 member internal
 member local
!
dial-peer cor list user-domestic
 member internal
 member local
 member domestic
!
dial-peer cor list user-international
 member internal
 member local
 member domestic
 member international
!
dial-peer cor list user900-internal
 member internal
 member 900
 member 976
!
dial-peer cor list user900-local
 member internal
 member local
 member 900
 member 976
!
dial-peer cor list user900-domestic
 member internal
 member local
 member domestic
 member 900
 member 976
!
dial-peer cor list user900-international
 member internal
 member local
 member domestic
 member international
 member 900
 member 976
!
!
dial-peer voice 22 pots
 destination-pattern .T
 port 0/1/0
!
dial-peer voice 23 pots
 destination-pattern .T
 port 0/1/1
!
dial-peer voice 24 pots
 destination-pattern A0
 port 0/1/0
!
dial-peer voice 25 pots
 destination-pattern A1
 port 0/1/1
!
!
!
!
gatekeeper
 shutdown
!
!
telephony-service
 fxo hook-flash
 load 7970 SCCP70.8-3-3S
 max-ephones 5
 max-dn 108
 ip source-address 10.10.10.1 port 2000
 calling-number initiator
 service phone videoCapability 1
 timeouts interdigit 4
 time-zone 28
 time-format 24
 date-format dd-mm-yy
 max-conferences 8 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded
 moh music-on-hold.au
 web admin system name admin secret 5 $1$V8aq$gqrjzYSKmtUvmZBuhDxCE0
 dn-webedit
 time-webedit
 transfer-system full-consult dss
 transfer-pattern .T
 directory last-name-first
 create cnf-files version-stamp 7960 Nov 17 2008 19:41:52
!
!
ephone-dn  1
 number 1001
 label Grammh 1
 description Stathis
 name Stathis
!
!
ephone-dn  2  dual-line
 number 1000
 label Grammh 1
 description Panagiotis
 name Panagiotis
 corlist incoming user900-international
!
!
ephone-dn  3
 number 1002
 label Grammh1
 description Menios
 name Menios
!
!
ephone  1
 device-security-mode none
 video
 mac-address 001B.D4A0.DBF8
 type 7970
 button  1:1
!
!
!
ephone  2
 device-security-mode none
 video
 mac-address 0019.E811.BC0E
 type 7970
 button  1:2
!
!
!
ephone  3
 device-security-mode none
 video
 mac-address 0019.AA96.D34A
 speed-dial 1 1001 label "Stathis"
 speed-dial 2 1000 label "Panagiotis"
 type 7970
 button  1:3
!
!
!
line con 0
line aux 0
line vty 0 4
 password ####
 login
!
scheduler allocate 20000 1000
ntp master
end
 
Router#

Open in new window

0
Comment
Question by:PredatorGR
  • 2
  • 2
4 Comments
 
LVL 6

Expert Comment

by:greekstones
ID: 22984466
OK

I had a look at your configs you need another FXO port for the fax to be routed or use the 0/1/1

dial-peer voice 3810 pots
 description FAX
 destination-pattern 1001
 port 2/0/1
0
 

Author Comment

by:PredatorGR
ID: 22984551
Thanks for your answer, i would like to inform you that i am using ISDN so i got 2 phone lines in one.

Problem is, i want to use those 2 lines for my office so when someone is already talking the other employee can make a call.

Right now i am using the ab1 channel from my ISDN box to FXO port 0 and the ab2 channel from the ISDN box connects directly to the FAX machine.

How i can use both ISDN channels (one channel to FXO 0 and the other to FXO 1) and when a fax arrives to either channel the fax gets routed to FXS 0 port?

I know i can use an ISDN BRI card but right now is out of my budget.

I think this is kinda tricky, any further help is much appreciated.

By the way, are you Greek?

Thanks

0
 
LVL 6

Accepted Solution

by:
greekstones earned 2000 total points
ID: 22985063
Hi again

Ok you can not do that because of the  Plar destination. In every organization you have one fax line and one telephone line or Tel with Fax.

I don't beleve that is possible but u never know.

Yes i'm half greek .

regards.



0
 

Author Closing Comment

by:PredatorGR
ID: 31517805
Thanks, i putted a new telco line to my office and now everything is ok
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On Feb. 28, Amazon’s Simple Storage Service (S3) went down after an employee issued the wrong command during a debugging exercise. Among those affected were big names like Netflix, Spotify and Expedia.
This article is in regards to the Cisco QSFP-4SFP10G-CU1M cables, which are designed to uplink/downlink 40GB ports to 10GB SFP ports. I recently experienced this and found very little configuration documentation on how these are supposed to be confi…
Both in life and business – not all partnerships are created equal. As the demand for cloud services increases, so do the number of self-proclaimed cloud partners. Asking the right questions up front in the partnership, will enable both parties …
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses
Course of the Month13 days, 12 hours left to enroll

755 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question