How do i setup backupexec to forward emails externally through exchange 2003 / 7

we have a number of clients that use backup exec for tape backups. we need to setup email alerts to forward to us for backup success and failure events.

weve configured the smtp settings inside the app and setup recipents however external emails are not delivered. usually there is a primary contact onsite that is set to recieve the alert emails which always are delivered. however emails sent to us externally on a different domain never get through.

we have setup backup exec with smtp authentication for the administrator account to send out on but no joy.

i have played with exchange 2003 and 2007 relay settings but it doesnt seem to help.

does anyone have some definitive steps to get this working?

Thanks
datafocusAsked:
Who is Participating?
 
dmbgoConnect With a Mentor Commented:
I am very pleased to see that you got this working. If the problem was due to the smtp authentication, I wonder if it needed the domain\username, rather than just  username?
Well Done
Dave
0
 
RobinHumanCommented:
I'm pretty sure this is a relay issue;
see this link - gives you the steps for ex2k3
http://www.experts-exchange.com/Storage/Backup_Restore/Backup_Exec/Q_23391789.html
hope this helps you
0
 
Hedley PhillipsOwnerCommented:
As above, you need to add the Backup Exec Media Server to the allowed relays in Exchange System Manager

ESM - Administrative Groups - Servers - <server name> - Protocols - SMTP - Default SMTP Virtual Server

and select properties (right click) then Access - Relay Restrictions - relay and what we did was add any server that needs to relay through Exchange here.

See image:
relay.gif
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
datafocusAuthor Commented:
just to add a note to this (i will give this a try tommororw) the servers are pretty much all SBS servers so they run backup exec and exchange on the same box if that makes any difference?
0
 
dmbgoCommented:
I have another solution to this problem, it is the one that I use and it works well.
Setup a distribution list in exchange called "server alerts" or something similar, then add the onsite contact/s to the group. In active directory users and computers, right click on foreign security principals and create a new contact for your external recipient, do not create an exchange mailbox.
Once the contact is created right click on the new contact and select exchange tasks a wizard will run and select establish e-mail address, you can then put in your external smtp address.
Lastly add this contact to your server alerts group.

Cheers
Dave
0
 
datafocusAuthor Commented:
ok i have entered exactly as stated by robin human and mr-Madcowz, however this still doesnt work on more than one server
mr madcows the solution you have suggested with relaying seems unneccasary with basic sbs settings as the window is pre populated in the following way
select which server may relay thought this virtual server
Granted 192.168.0.0 (255.255.255.0)
Granted 127.0.0.1

(checked) Allow all computers which successfully authenticate to relay regardless of the list above.
so that should cover the sbs server anyway
I also then added in anyway "Granted 192.168.0.6" (sbs server address, but i still dont get messages through.
my backup exec server is setup in this way
SMTP Configuration
(checked) Enable
SMTP Mailserver: SbsServer
SMTP Port: 25
Sendername: Administrator
Sender Email Address: administrator@domain.co.uk
(checked) Enable SMTP Authentication
SMTP Server Login: Administrator
Sender Password: ************

Recipient Properties
SMTP Mail (checked) Enable
Address: Support@externaldomain.com

dmbgo, i really want to try to get this working thought the native tools and not have to include extra steps but i will impliment your solution as a last resort.
could there be any other problems maybe in my exchange setup that could stop the emails delivering. exchange seems to be working correctly in every other way.
thanks
0
 
RobinHumanCommented:
Are there any alert mails in the mail queue?
do you get any messages in the event log?
Can you send a test mail successfully?
(just trying to narrow down the possible causes here)
0
 
datafocusAuthor Commented:
sorry i should have said, no the test emails do not come through, ill check the event logs and message queues now and get back to you
0
 
datafocusAuthor Commented:
just looked throught he event logs and there is nothing there that stands out from exchange or backup exec. also the message ques are all empty...
0
 
datafocusAuthor Commented:
after searching the internet some more it seems this might be a fairly common problem with no real solution on all versions of backup exec. as i say i have many servers that dont work, but i do have two server that work fine any differently on them than any of the others. and the computers do send internal messages. it just make sus look really bad when sites arnt backing up properly and we dont knwo about it
0
 
datafocusAuthor Commented:
ok so ive just got it to work.
here are the list of things that i did,. now im going to have to go through on one of the other servers and see exactly which bit it was that fixed the issue
i set up my working server side by side to my none working server  and mirrored the smtp settings.
however before that i went into SMTP Properties -> deliver -> advanced and changed the fully qualified domain name from sbsserver.internaldomain.local to mail.externaldomain.com
however after doing this i noticed that the working server was set to an internal domain name and still worked so i dont think this needs changing.
next thing i did was opened up acess tab -> connection control -> connection
the working server has all except the list below checkbox ticked instead i setup the new server with only the list below and added in the network ip info
this still didnt work, so finally i realised that the working server had BE 10d installed which doesnt allow SMTP Authentication so i turned off SMTP Authentication. as soon as i did this the Test emails came in to me straight away
so the solution which i will post in a seperate post with the definate answer seems to be a combination of turning off smtp authentication and either making sure that the relay network information is in the relay restrictions settings, or the connection button has the network information entered with SMTP authentication turned off. or both have the correct settings entered and SMTP auth off.
will test it now on another server
0
 
datafocusAuthor Commented:
ok so got this working on all servers now, it seems the key is to make sure SMTP authentication is turned off in backup exec, and enter your ip address range and subnet into the relay setting. if you still dont recieve the emails open the connection settings in the smtp settings just above the relay settings button, and make sure your network range and mast are set in their correctly also
 
thanks
0
All Courses

From novice to tech pro — start learning today.