anonymous access doesn't work

I've setup a web server in a classroom for internal access only. The web site is seen and it works with windows authentication. Can't seem to get anonymous to work.
shellrAsked:
Who is Participating?
 
shellrConnect With a Mentor Author Commented:
Hi, Back again, for some reason my password wouldn't work. Anyways I reloaded and left all the default settings and it works fine. SOOO  I guess that renaming the server caused problems.

Don't rename your server when you use iis7.
0
 
fosiul01Commented:
Fromm IIs -> directory security , you wil have to tick   "enable Anynomouse access"
0
 
shellrAuthor Commented:
Sorry, maybe I don't understand the point system here. I've done everything that I can think of and my network expert as well. We are new to server 2008 and iis7. We have 38 server running so maybe basic isn't what I want - sorry. We have a few iis6 sites running.  I've tried changing the password on the domain user etc. Anon access won't turn on but windows auth will work. Is it something to do with user rights?/
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
fosiul01Commented:
what do you mean, anynomouse access will not turn on ?? try to change that by using administrative account
0
 
shellrAuthor Commented:
I'm always in as admin. I should clarify - anon access is enabled but I can't get into the site remotely.  I get 401 error. I think I've turned everything on. When I change to windows authentication it works fine and I can access the ftp site via login ok. I did change the name of the server and am wondering if this will change the default user names??
0
 
fosiul01Commented:
when you turn on anynomous access, did you turn off windows authentication ??
0
 
Praveen DMInfra Team LeadCommented:
If you did try to reset the "IUR_machine" ( Ananymouse user ) in IIS then make sure you try to repropagate the permission.

1. Enable Ananymous access.
2. Disable Windows Authentication Integrated...
3.
Rt click site --> Permissions --> check the IUR , Network , Asp.net , Administrator, System , And user group if any permission and grant access to them accordinglly and try accessing the site after clearing the local cache finally.

0
 
shellrAuthor Commented:
This is the problem I think. I just don't know how to solve it.

(i guess I can't cut and paste in here!)
"make sure that the application pool identity has Read access to the physical path"

"make sure that <domain>\<computer_name>$ has Read access"...
Any ideas?
0
 
fosiul01Commented:
Ok have a look at this question

http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_23912390.html?cid=238#a22980337

there is some picture available

when you enable anynomous access , do you have the setting like the picture posted in
comment ID:22980108
0
 
shellrAuthor Commented:
No. Is that IIS 6?
0
 
fosiul01Commented:
yes that one is II6
can you print a picture of your IIS here ??
0
 
shellrAuthor Commented:
I'll try - give me a minute.
0
 
shellrAuthor Commented:
Here is a grab of IIS7
Picture-2.png
0
 
Praveen DMInfra Team LeadCommented:
Is this IIS 6 .. ;-) No ..  
0
 
fosiul01Commented:
ok check this one

http://www.experts-exchange.com/Software/Server_Software/Web_Servers/Microsoft_IIS/Q_23883476.html

and do you have permission on www folder as shown in picture ??
0
 
shellrAuthor Commented:
I'm lost now. This is IIS7 - what I've been talkin about???
0
 
fosiul01Commented:
yes, you said, that you are using IIS 7, and i am trying to find out a solution for IIS 7
0
 
fosiul01Commented:
omm i never worked on IIs7 i thought you are having problem with IIS 6

anyway, i am sending you some link, just check those link and see if you have done all those or not

http://groups.google.com/group/microsoft.public.inetserver.iis/browse_thread/thread/f5ea181d33bcf744?pli=1

last post :
Edit Bindings...     on my website in IIS7 management console
Select the binding, Edit it
Change 127.0.0.1 to *
Save it
0
 
shellrAuthor Commented:
I'm talking to two of you :-)
OK the 4th picture"test connection"  is where I fail.


0
 
fosiul01Commented:
since here 2 of us
if you want ask any one specifically, please ask by name  

like fosiul or servoadmin, it would be easy to understand , to whom you are asking!!
0
 
fosiul01Commented:
so you have setting same as picture 1 to 3 ,
but its fails at 4

and it say this error ?? @make sure that the application pool identity has Read access to the physical path" ?
0
 
fosiul01Commented:
do you get any error like this ??

Resolving HTTP Error 401.3  Unauthorized Error - Application Pool Identity


if not can you provide the full error message with error number please
 
0
 
Praveen DMInfra Team LeadCommented:
1. When enabling Ananymous access for the default site you are still prompted with password authentication window ?

2. You are not atall able to enable Ananymous access for the site.

3. Did you disable Integrated Windows Authentication.

4. Did you checdk the permission for the folder by browsing it in physical location and not in IIS .

5. Can you get a screen shot of the IE browser when you are accessing it with ananymous enabled.
0
 
Praveen DMInfra Team LeadCommented:
Its a new IIS installed and configured server / Vista machine with only very few sites I guess.... Please don't mind taking a site backup ( Data ) and remove IIS and reinstall. Instead of just getting all around this could reset the complete mess hapnd and can get a clear fix...
0
 
Praveen DMInfra Team LeadCommented:
Fixes can be discussed and almost many techs would solve once they have their hands on this server ...but a mere discussion will add more mess ;-) and waste of time.If you have very less sites configured plz don't mind reinstalling the IIS ..complete remove and add once again...
0
 
fosiul01Commented:
0
 
Praveen DMInfra Team LeadCommented:
Hello Shellr..Do let us know if you got things sorted ou or not.. :-)
0
 
fosiul01Commented:
This the problem here, we people try to help asker  but the asker does not respond!!!

anyway good luck
0
 
Praveen DMInfra Team LeadCommented:
:-) ... Maybe the school is closed for the day... Let them enjoy -- fosiul01 ... We had a good time givin solutions too and the user would forsure return tomrw.... bfn
0
 
fosiul01Commented:
yah may be you are right.

i will be off now

0
 
shellrAuthor Commented:
Sorry had to go to class and now we are having exams. I have decided to reinstall and not to change the default name of the server, I'll let the program be and see if it works. I think changing the name messed up my permissions. I'll let you know what happens.
0
 
Praveen DMInfra Team LeadCommented:
Gr8 buddy.... Plz goahead and cheers Goodluck !!! Keep us updated...
0
 
Praveen DMInfra Team LeadCommented:
cool!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.