[Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 849
  • Last Modified:

Incoming PSTN calls are not routed to the correct FXS ports

We have a Cisco 2800 voicegateway with three POTS lines going to three FXS ports (no PRI).  Incoming PSTN calls are not going to the correct ports associated with the respective DIDs.  Instead, incoming PSTN calls ring randomly to any of the three FXS ports-- almost in a round robin fashion.

Also, CLID on outgoing calls to the PSTN are showing up randomly as one of the three DIDs.

Could it be the voice translation-rules?

Thank you for your time!
0
bnguyen714
Asked:
bnguyen714
  • 3
  • 3
1 Solution
 
bkepfordCommented:
Post your config if you don't mind. It's probabably not your translation patterns.
0
 
bnguyen714Author Commented:
Sure:

Router_2801#sho run
Building configuration...

Current configuration : 9345 bytes
!
version 12.4
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname NC_2801
!
boot-start-marker
boot system flash:c2800nm-advipservicesk9-mz.124-15.XZ.bin
boot-end-marker
!
logging message-counter syslog
logging buffered 1000000
no logging console
enable secret 5 $1$Tm87$BV/IRZutU03xdndiS8hJYIUR.
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authorization config-commands
aaa authorization exec default group tacacs+ if-authenticated
aaa authorization commands 0 default group tacacs+ none
aaa authorization commands 1 default group tacacs+ none
aaa authorization commands 15 default group tacacs+ none
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 0 default start-stop group tacacs+
aaa accounting commands 1 default start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting connection default start-stop group tacacs+
!
!
aaa session-id common
!
!
crypto pki trustpoint TP-self-signed-4208127556
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-4208127556
 revocation-check none
 rsakeypair TP-self-signed-4208127556
!

dot11 syslog
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool IP_PHONE
   network 10.145.110.0 255.255.255.0
   option 150 ip 10.162.110.11
   default-router 10.145.110.1
!
!
ip domain name logon.com
!
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 supplementary-service h450.12
 h323
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice translation-rule 1
 rule 1 /^/ /9191/
!
!
voice translation-profile outcallerid
 translate called 1
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
archive
 log config
  hidekeys
!
!
ip ssh time-out 60
ip ssh authentication-retries 5
ip ssh version 1
gw-accounting syslog
!
!
!
!
interface Loopback0
 ip address 192.168.168.140 255.255.255.255
!
interface Loopback1
 ip address 199.163.105.149 255.255.255.255
!
interface FastEthernet0/0
 description connected to EthernetLAN
 ip address 10.140.0.1 255.255.0.0
 ip access-group mydoom in
 ip nbar protocol-discovery
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description connected to Voice VLAN
 ip address 10.145.110.1 255.255.255.0
 ip flow ingress
 ip flow egress
 duplex auto
 speed auto
 h323-gateway voip interface
 h323-gateway voip bind srcaddr 10.145.110.1
!
interface Serial0/1/0
 description MPLS connection to Arl
 ip address 172.21.5.46 255.255.255.252
 ip directed-broadcast
 ip flow ingress
 ip flow egress
 service-module t1 timeslots 1-24
 service-module t1 remote-alarm-enable
!
router eigrp 1
 network 10.140.0.0 0.0.255.255
 network 10.145.110.0 0.0.0.255
 network 172.21.5.44 0.0.0.3
 network 192.168.168.0
 network 199.163.105.149 0.0.0.0
 no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Serial0/1/0
ip route 199.11.1.0 255.255.255.0 172.21.5.45
ip route 199.11.21.0 255.255.255.0 172.21.5.45
!
ip flow-export source Loopback0
ip flow-export version 5
ip flow-export destination 10.162.99.25 2055
ip flow-export destination 10.161.2.9 9996
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
ip tacacs source-interface FastEthernet0/0
!
ip access-list extended mydoom
 deny   udp any any eq 8998 log
 deny   tcp any any eq 1639 log
 deny   tcp any any eq 6667 log
 permit ip any any
!
logging trap debugging
logging 10.162.99.125

!
!
!
!
!
tacacs-server host 10.161.2.9
tacacs-server timeout 10
tacacs-server directed-request
tacacs-server key 7 15060201017A272A273C3A3A2C
!
control-plane
!
!
!
voice-port 0/0/0
 timing hookflash-out 50
 connection plar opx 70000
 caller-id alerting ring 2
!
voice-port 0/0/1
 timing hookflash-out 50
 connection plar opx 70001
 caller-id enable
!
voice-port 0/0/2
 timing hookflash-out 50
 connection plar opx 70002
 caller-id enable
!
voice-port 0/0/3
 timing hookflash-out 500
 caller-id enable
!
ccm-manager fallback-mgcp
ccm-manager redundant-host 10.162.110.14
ccm-manager music-on-hold
!
mgcp rtp unreachable timeout 1000 action notify
mgcp modem passthrough voip mode nse
mgcp package-capability rtp-package
mgcp package-capability sst-package
mgcp package-capability pre-package
no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
mgcp bind control source-interface FastEthernet0/1
mgcp bind media source-interface FastEthernet0/1
!
!
!
dial-peer voice 700 voip
 translation-profile incoming outcallerid
 answer-address 70001
 destination-pattern 7000.$
 session target ipv4:10.162.110.11
 dtmf-relay h245-alphanumeric
 codec g711ulaw
!
dial-peer voice 701 voip
 destination-pattern 7000.$
 session target ipv4:10.162.110.14
 incoming called-number .
 dtmf-relay h245-alphanumeric
 codec g711ulaw
!
dial-peer voice 1 pots
 destination-pattern 9T
 port 0/0/0
!
dial-peer voice 2 pots
 destination-pattern 9T
 port 0/0/1
!
dial-peer voice 3 pots
 destination-pattern 9T
 port 0/0/2
!
dial-peer voice 911 pots
 destination-pattern 911
 port 0/0/0
 forward-digits all
!
dial-peer voice 912 pots
 destination-pattern 911
 port 0/0/1
 forward-digits all
!
dial-peer voice 4 pots
 destination-pattern 91919T
 port 0/0/1
!
dial-peer voice 5 pots
 destination-pattern 9191911
 port 0/0/1
 prefix 911
!
!
!
banner motd ^C
**************************************************
Onsite3
**************************************************
"UNAUTHORIZED ACCESS TO THIS NETWORK DEVICE IS PROHIBITED
Use without authorization is a violation of Federal
Law punishable by fine/imprisonment (Public Law 99-474).
This system is monitored and anyone using this system
or systems linked to this system will be monitored."
^C
alias exec ct conf t
alias exec sta show startup
alias exec t0 term len 0
alias exec t24 term len 24
alias exec t42 term len 42
alias exec sip sh ip route
alias exec sin sh inter
alias exec bri sh ip int brie
alias exec cr clear ip route *
alias exec run sh run
alias exec pro sh ip prot
!
line con 0
 exec-timeout 0 0
 timeout login response 300
 privilege level 15
 password 7 051C51123D791D4324590B5D
 logging synchronous
line aux 0
 password 7 020B544958151211F721F4A
 modem InOut
 no activation-character
 transport preferred none
 transport input all
 transport output all
 speed 115200
 flowcontrol hardware
line vty 0 4
 password 7 0611583213141F0449174F
 logging synchronous
 transport input ssh
line vty 5 15
 password 7 051C511D45791D43590B5D
 transport input telnet
!
scheduler allocate 20000 1000
ntp server 10.161.0.1
ntp server 192.168.168.160
end
0
 
bkepfordCommented:
Well it looks like you have MGCP setup and H323 dial-peers setup on the router. Are you using Call Manager? If so what version and in Call manager how do you have the gateway setup(MGCP or H323)?  
0
[Video] Create a Disruption-Free Workspace

Open offices have their challenges. And Sometimes, it's even hard to work at work. It's time to reclaim your office and create a disruption-free workspace. With the MB 660, you can:

-Increase Concentration
-Improve well-being
-Boost Productivity

 
bnguyen714Author Commented:
We are running CallManager System version: 6.0.1.2000-3.  Yes, we do have a H323 gateway setup.  Thanks!
0
 
bkepfordCommented:
Well to answer your original question I think the reason that your voice ports are being forwarded randomly to your FXS ports is because of your translation rule. Have you tried removing it and seeing if the calls go through.
It looks like you are running SRST but you aren't trying to use your call manager to control your FXS ports.
Here is a Cisco guide on SRST with MGCP that may help incase you want to change things up.
http://www.cisco.com/en/US/docs/voice_ip_comm/cusrst/admin/srst/configuration/guide/srs_wlan.html
 
 
0
 
bnguyen714Author Commented:
There is nothing wrong with the configuration.  It turned out that these three POTS lines were setup as a hunt group.  Argggg.  Thank you for your time!
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now