• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1606
  • Last Modified:

Need BDE5.1.x update download!

Hi all,

A long time ago I have built a Delphi application which used a paradox 5.1 database. This application is used by one of my customers.
Now he is going to extend his company and wants to install the application on new computers. The installation of the application goes well but the database cannot be opened!
I know that this is caused by the fact that my installer install the BDE5.0 version while the database is 5.1. For the current, working computers I did have a small file which I downloaded from borland/inprise at the time to install BDE5.1. Now there's a problem: I do not have this small 5.1 installer any more!
And the borland devsupport site is no longer available... :(

Does anybody know where I can download this installer safely (=>legally, no spyware, no viruses)? Where did borland hide this?

D'Mzz!
RoverM
0
roverm
Asked:
roverm
  • 5
  • 4
1 Solution
 
SteveBayCommented:
I believe that this is a legit DL http://processlist.com/info/bde511en.html
0
 
SteveBayCommented:
Oops. Not a DL I will look some more.
0
 
SteveBayCommented:
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
rovermAuthor Commented:
Thanks for the link!

The upgrade worked just fine however the database can still not be opened... It keep asking for a username/password while I never set this in this db... Any suggestions?
0
 
SteveBayCommented:
What components are you using to access the DB?
If you are using a TDatabase check the LoginPrompt property.
0
 
rovermAuthor Commented:
As I said, this is a very old application :). This prompt was never used. I think it has something to do with how the ODBC connection is created (using the ODBC Admin or the BDE Admin).
0
 
SteveBayCommented:
Sorry, I don't think I can be of much help here. BDE is a long, long way in the rearview for me, though I suspect that you will get some hits if you were to post a new Q.
0
 
rovermAuthor Commented:
Ok, thanks anyway. I will take a look first on how to create the connection. I think this is the problem. If not, you will see the new question.

D'Mzz!
RoverM
0
 
rovermAuthor Commented:
Forgot about this one...
The problem was solved when I created the connection dsn using the BDE Administrator.

D'Mzz!
RoverM
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

  • 5
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now