Vista machines on network can't access SMB printer server, and Toshiba printer / photocopier

We have various vista machines on our network (mixed lan/wireless). Over the last two weeks a problem has developed on all of them. The printer - a toshiba 281 colour photocopier is connected via lan and has its own printserver (as standard). It also has a network smb server used as a data sotrage device for scanned images and saved faxes. Over the last two weeks all the vista machines have developed problems communicating with the toshiba device. One still prints, but cannot access the smb - message comes up saying device won't accept connections from that particular pc. On the other machines, the printer driver won't work - print folder comes up with "printing error". These machines also can't access the smb space. (Same error message)

None of the xp machines or servers are affected.

Bizarrely, when the vista machines which won't print are restarted, the items left in the print queue print out between logging in the profile and the machine completing loading the desktop. To me this suggested a firewall problem, or some software interferring with the print communication, but I can't trace anything.

I've tried:
Reinstalling print driver - installation can detect but can't access printer - installation fails.
Tried installation manually poiting to ip address or device name on network ie \\tosh-281 - but same error reply.
Tried disabling firewall
Tried disabling antivirus
Check for changes on lan/wireless router - no changes over past two weeks.
Tried installing as administrator and through admin profile and using safe mode - no effect.

Run out of ideas after eight hours on this and now reaching for a large mallett. Any help would be much appreciated.
tomtolkienAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PCHoundCommented:
Do you have a server all of these reside on? Or is it just based off the actual print server?
0
tomtolkienAuthor Commented:
The pcs all access the printer via the printer's internal print server, through the lan. No server is is involved.
0
tomtolkienAuthor Commented:
The specific message which appears is: \\TOSH-281 is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permission. This account is not authorised to log in from this station.

I have tried resetting the vista firewall and the netsock  neither has had any effect.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

tomtolkienAuthor Commented:
No network settings have been changed in the last two weeks, and no permissions, authorisation etc has been changed on the print server, or for the matter, any other server - so the message which comes up on the SMB is very puzzling.
0
jrtecCommented:
to print try configuring a standart tcp/ip port pointing to the machine ip address

try activating netbios over tcp/ip on lan connection properties (where you put manual ip address)- advanced - WINS- and mark activate netbois over tcp/ip

try check network configuration usng web based configuartioncon the printer (http://machine_ip)

check workgroup name on the printer

try using a fresh vista installation with out updates to compare. maybe some windows update changed somethink

check SMB version used to autenticate on the printer and pc's (V1, ....)
0
tomtolkienAuthor Commented:
Turned out to be a known problem with toshiba driver - solution was to delete driver manually and add under admin profile.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.