Opening Port 1129 on Godaddy Dedicated Linux server

Hi All,
I am working on a php based application which required Linkpoint payment gateway integration. The application is hosted on a dedicated Linux server hosting at Godaddy.com. To complete the intergation I need port 1129 to be activated. I have found 2 methods to do this. 1. By enabling IPtables and adding the port and accept all inbound request to the destination port 1129.
2. Using the Firewall module installed on Plesk (server management software).
At first I tried the first option of IPtables and found that there is something else which is managing the firewalls. So figured it out to be Plesk based module which is used to manage the firewall. So I added a custom rule for port 1129 on TCP and applied the changes. I check out if the IPTable is updated with the latest information and it was updated. I tried to use few Port scanner to check if the port has been enables. To my surprise this was not open yet. I contact the Godaddy.com support guy which was useless as they can't provide or suggest any solution other than what I did.
I would really appriciate if someone who can help me find a solution for this problem.

Regards,
Brickwork
brickworkAsked:
Who is Participating?
 
fosiul01Connect With a Mentor Commented:
what the out put of this command

netstat -tulpn

netstat -tulpn | grep 1129
0
 
fosiul01Commented:
can you past here what on

cat /etc/sysconfig/iptables ??
0
 
brickworkAuthor Commented:
# Firewall configuration written by system-config-securitylevel
# Manual customization of this file is not recommended.
*filter
:INPUT ACCEPT [0:0]
:FORWARD ACCEPT [0:0]
:OUTPUT ACCEPT [0:0]
:RH-Firewall-1-INPUT - [0:0]
-A INPUT -j RH-Firewall-1-INPUT
-A RH-Firewall-1-INPUT -i lo -j ACCEPT
-A RH-Firewall-1-INPUT -p icmp --icmp-type any -j ACCEPT
-A RH-Firewall-1-INPUT -p 50 -j ACCEPT
-A RH-Firewall-1-INPUT -p 51 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp --dport 5353 -d 224.0.0.251 -j ACCEPT
-A RH-Firewall-1-INPUT -p udp -m udp --dport 631 -j ACCEPT
-A RH-Firewall-1-INPUT -p tcp -m tcp --dport 631 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 22 -j ACCEPT
-A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited
-A RH-Firewall-1-INPUT -m state --state NEW -m udp -p udp --dport 1129 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 1129 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 80 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 21 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 443 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 25 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 3306 -j ACCEPT
-A RH-Firewall-1-INPUT -m state --state NEW -m tcp -p tcp --dport 8443 -j ACCEPT
-A FORWARD -j REJECT --reject-with icmp-host-prohibited
COMMIT
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
fosiul01Connect With a Mentor Commented:
can you please remove this line

-A RH-Firewall-1-INPUT -j REJECT --reject-with icmp-host-prohibited

then restart the iptables
and try again
0
 
brickworkAuthor Commented:
I tried this, but still it doesn't work for the port 1129.
Any other suggestion?
I feel that it's blocking all non standard ports.
0
 
fosiul01Commented:
how this server is connected to Isp ??

directly or do you have any router between isp and this server ??
0
 
brickworkAuthor Commented:
I am not very sure about this. I feel there is a firewall at the ISP level. But the server support people assured me that they are not blocking this port.
I have read that we need to have a service associated to this port to get a response from this port.
Can you help me in adding a service to this port?
0
 
fosiul01Commented:
ommmmm
ok like 25  port, if  mail server is not installed then this port 25 is uselss

so to work with 1129 , oomm i guess you will have to install something in your server

you said " The application is hosted on a dedicated Linux server hosting at Godaddy.com."

so you installed some programm in your server right ?? and this one need to use port 1129 ??
0
 
brickworkAuthor Commented:
Yes you are right I can install anything on the server, but how will I listen that application to the port 1129?
0
 
fosiul01Commented:
ommmm
the programm it self should create the service to listen port on 1129

have you checked the documentation of that programm ??
0
 
fosiul01Commented:
can you telnet the port 1129 ??

0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.