Incomplete downloads and downloads that never begin for files, videos, and other data sources

When I try to download something using OS X, the download doesn't begin or it times out after loading only half-way. When a software like iTerm tries to download its own update, it usually times out, and when I try to download things through the browser, it times out or never begins.

When I try to watch a video on a site like Youtube or Dailymotion, the video does not completely load. If I reload the web page, it loads a bit farther each time, so after two or three refreshes (F5 on Firefox), I can watch the entire video.

On the same machine at the same sitting using the same network connection, if I start up my Parallels VM of Windows XP, I can download these files and watch the videos with no problem at all, so I am sure the cause is somewhere in Mac OS X. This began when I installed Leopard in this computer.

I have already tried fixing permissions.
shinmaikeruAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jhyieslaCommented:
This is a little extreme but it might work.  I'd try doing an Archive and Install from the OS X install disk that came with the Mac. Make sure that you check the boxes to maintain user and network information.

What this will do is to replace all of the Mac system files with the ones that came with the Mac originally.  It will also keep any network settings you have as well as your user settings and folders. Your Apps will also stay in place.

As the link below will point out, you probably want to repair your disk first to make sure that there are no issues with that before starting the Archive and Install.

It will take the OS back to what it was when you first got the Mac.  Once you have finished this process,log back in and start taking on the application patches and security updates one at a time and reboot between each one even if you don't have to.  There should be a combo update for the OS to take you to 10.5.5; leave this for last.  Once you have all of the other patches in place, see if your problem goes away.  Assuming it does, you can then apply the combo update for OS X.  

I am including a link from Apple about the process:

http://support.apple.com/kb/HT1710
0
shinmaikeruAuthor Commented:
Thank you.  I will try this now. However, there is another aspect to this that I just found. Another Mac user at my workplace is having the same problem, with the same 10.5, and she said that it does not happen when she accesses from home.

So I took my Mac home and, whaddyaknow, there is no problem at home.

However, the 10.4 and 10.3 Macs here at work and the Windows machines and one Linux machine (we have a Psych prof that uses Ubuntu) have no problems with downloads of any kind, and as I noted before, the Windows VM (Parallels) on this very Mac also has no problems.

So could it be something to do with 10.5 and my network topology or settings?

This is really strange, I know.

0
jhyieslaCommented:
I can't imagine that the network topology is to blame; it's more likely to be some "incompatibility" between the Mac and how it communicates through your infrastructure.  There are may differences between home and work in most situations.  For example, I have cable at home that actually has a higher throughput than my WAN connection.  My WAN connection to the Internet is highly shared so bandwidth can become an issue, but it should be the same for both Windows VM and OS X.  I know that I have a firewall and IDS/IPS device at work as well as a web filter, which I don't have at home.

Do both the Mac and the VM get static or DHCP IP addresses.  If there is a difference between them you might try configuring the Mac the same was as the VM. Are you binding to Active Directory at work? This would obviously be a difference over what you have at home, but I've not seen this kind of issue with 10.5.

Another difference that will sometimes raise it's head in a filtered work environment is the difference between how IE and another browser such as Safari or FireFox will interact with the various protections many corporate networks have in place. Have you tried running FireFox on the VM instead of IE to see if the problems show up using an alternate browser?  

You can also check in your network preferences to see that you have the appropriate DNS servers and search domain(s).  If you're not binding to AD, make sure you have the right workgroup name in the WINS settings under Advanced in Network Preferences. And make sure you have any necessary proxy information entered as well.

If you have the Mac firewall on, try turning it off temporarily to see if it makes a difference.

Have you tried downloading to the Mac without the VM running?  Is it possible that you have allocated too much in the way of resources to the VM and perhaps that is causing an issue.  Obviously that would only come into play if the VM is always running when you are having this issue.




0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shinmaikeruAuthor Commented:
This did not solve the problem, and I cannot see anything that might do so. I also did an archive install, and the problem persists. It seems to be something to do with my workplace network and the Leopard OS, but I can't figure out what that is. I will return to this issue later. Thank you for your suggestions.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.