• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 622
  • Last Modified:

Changing the default MS-Windows Terminal Service 2003 port

May i have to change the default port (3389) of the windows terminal service 2003 into server and into RDP client application to connect onto other port number (3390).
Because i have a NAT router which tansefer the inbound connections to terminal server1 also i have anther terminal server2 and i need to NAT inbound connections to it through the same NAT router like this:

public IP= 82.23.37.11 on port 3389 NAT to private IP= 192.168.4.20 on port 3389    terminal server1
public IP= 82.23.37.11 on port 3390 NAT to private IP= 192.168.4.21 on port 3390    terminal server2
0
mtarabay
Asked:
mtarabay
  • 2
  • 2
  • 2
  • +1
5 Solutions
 
Jian An LimSolutions ArchitectCommented:
Start Registry Editor.
2. Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TerminalServer\WinStations\RDP-Tcp\PortNumber
3. On the Edit menu, click Modify, and then click Decimal.
4. Type the new port number, and then click OK.  
5. Quit Registry Editor.

http://support.microsoft.com/kb/306759
0
 
mtarabayAuthor Commented:
Good Limjianan:
But this is for changing RDP port into client side application.
How can i change the terminal service port also into server 2003 to connect to.
0
 
Andrew DavisManagerCommented:
what you are saying doesnt make a lot of sence, but that may be your english.
what you have been told will change the port that the server listens on for RDP/terminal server connections from the clients.
The clients will need to connect by typeing in :3390 (for term server 2) after their normal connection string.
eg.
Start MSTSC
type 82.23.37.11:3390
Click connect.
this will connect them to the second terminal server through port 3390
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

 
Jian An LimSolutions ArchitectCommented:
and of course, for internal user, they will have to connect via 192.168.4.21 on port 3390  

means mstsc -v 192.168.4.21:3390

hope it helps
0
 
mtarabayAuthor Commented:
OK i try it but the Terminal server refuse connection because the Terminal server listening via port 3389
How can i change the listening port to 3390 into 2003 Terminal server?
0
 
whsumCommented:
Perform the registry change as informed by limjianan on the server!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

  • 2
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now