Enabling port 636 for LDAP SSL

I'm trying to configure LDAP authentication with SSL. I've installed a certification authority (on our domain controller and yes I'm aware of the associated security risks) and issued certs and installed certs on the application server. I can get LDAP to work on port 389 but not on port 636 which I need for SSL. When I test the connection with the LDP tool I get this.

ld = ldap_sslinit("domainController", 636, 1);
Error <0x0> = ldap_set_option(hLdap, LDAP_OPT_PROTOCOL_VERSION, LDAP_VERSION3);
Error <0x51> = ldap_connect(hLdap, NULL);
Server error: <empty>
Error <0x51>: Fail to connect to domainController.

I think port 636 is not enabled. Does anyone now how to enable this port? I've patched the server for MS08-060 which I think may have disabled port 636.
ESS-IRLAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TolomirAdministratorCommented:
can you run that tool on the server itself?
0
ESS-IRLAuthor Commented:
No I can't. I get the same error message when trying to use port 636.
0
ESS-IRLAuthor Commented:
If it helps I just tried this from my application server to my domain controller.

C:\>telnet domainController 636
Connecting To domainController...Could not open connection to the host, on port 636:
Connect failed

C:\>
0
Discover the Answer to Productive IT

Discover app within WatchGuard's Wi-Fi Cloud helps you optimize W-Fi user experience with the most complete set of visibility, troubleshooting, and network health features. Quickly pinpointing network problems will lead to more happy users and most importantly, productive IT.

TolomirAdministratorCommented:
you can use the tcpview tool to check if your server (run it on the domaincontroller) has that port open.

http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx

Have you checked this already:

http://support.microsoft.com/kb/321051/
0
ESS-IRLAuthor Commented:
Thanks for this. I've gone through that microsoft kb alright and still no joy. I'll try that port tool and see what it says.
0
ESS-IRLAuthor Commented:
When I run that tcpview tool I see no entry for 636. I'm wondering is that normal though. Would I only see 636 as being active when the service receives a LDAP request?

I ran portqry from the application server and see this:

C:\>portqry -n 10.0.0.1 -e 636

Querying target system called:

 10.0.0.1

Attempting to resolve IP address to a name...


IP address resolved to domainController.myDomain.com


TCP port 636 (ldaps service): LISTENING

C:\>

This to me seems to say that the port is available for requests. This would seem to point me back to my configuration of my LDAPS certificates. Does that sounds about right?
0
TolomirAdministratorCommented:
tcpview should show you also listening ports. On the server of cause, not on the client

(Screenshot from my workstation, with tomcat running)
like-this.jpg
0
TolomirAdministratorCommented:
0
ESS-IRLAuthor Commented:
Thanks. That link looks very useful. I'll work through that and post again after I've been through these checks.
0
ESS-IRLAuthor Commented:
I ran this command on my application server:

certutil -v -urlfetch -verify serverssl.cer > output.txt

One thing that stands out in the output file is this.

A certificate chain processed, but terminated in a root certificate which is not trusted by the trust provider. 0x800b0109 (-2146762487)
------------------------------------
Verifies against UNTRUSTED root
Cannot check leaf certificate revocation status
CertUtil: -verify command completed successfully.


I'm thinking that my CA on the domain controller is not trusted by my application server. Do you kow how I check/rectify this?

As well as this when I run the LDP tool on the domain controller itself I can now successfully create an LDAP SLL connection.
0
ESS-IRLAuthor Commented:
This may also point to the same thing.

C:\>certutil -verifykeys
CertUtil: No local Certification Authority; use -config option
CertUtil: No more data is available.

C:\>
0
TolomirAdministratorCommented:
Following the setups on http://support.microsoft.com/kb/321051/ says you have to send a request to a CA

You might want to try this free 90 days valid certificate:

http://www.instantssl.com/ssl-certificate-products/free-ssl-certificate.html

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ESS-IRLAuthor Commented:
Well I just got this working. Yipee!!! I had to manually export the cert for my CA on the domain controller. I copied that onto the application server and imported it into the Trusted Root certification authorities on my applciation server using the certificates snap-in.
0
ESS-IRLAuthor Commented:
Thanks for you help with this. I'll accept your solution and award the points.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.