[Last Call] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 314
  • Last Modified:

apache 2.2.10 login issue with Firefox 3.0.4

Hi,

I have configured Apache 2.2.10 as a SSL reverse proxy to my sharepoint site. When a user browse to this site, he is prompted for his credentials multiple times. Also when ever he tries to access another subsite he is asked for credentials again many times. This is happening in Firefox. I have no issues when I browse with IE.

More Info:
This issues is not there when I use Apache 2.0 as SSL reverse proxy to same site.

How could I fix this?

Thanks
0
TechTiger007
Asked:
TechTiger007
  • 2
2 Solutions
 
caterham_wwwCommented:
You can monitor the HTTP headers with a firefox extension https://addons.mozilla.org/de/firefox/addon/3829  which should show you, how the server's response look like (i.e. if the server replies with 401, if your browser sends credentials etc.).
0
 
TechTiger007Author Commented:
Hi I am sorry for the late reply.
I monitored the HTTP headers with the addon and found that server is replying as unauthorized request. Seems like this is reported as a bug
https://issues.apache.org/bugzilla/show_bug.cgi?id=39673
and this is yet to be fixed.

Did anyone find a work around for this.

Thanks
Toms
0
 
TechTiger007Author Commented:
It turned out to be a bug in the way MS implemented NTLM authentication
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now