SBS2003 R2 Brand New Fully Patched Remote Access via VPN & WWP, Win XP SP3

Hello All

Im having a real problem with remote access, system details are as follows:

1 x DELL SC440 Server       (LAN IP
1 x Intel Xeon Dual Core 2.13Ghz Processor
4 x 1024MB ECC RAM
O/S       MS SBS 2003 R2
A/V      Kaspersky Business Secuirty Suite
IE      v 7.0.5730.13

6 x DELL Optiplex
1 x Intel Core 2 Quad Q6600 Processor
4 x 1024MB RAM
1 x 160Gb SATA HDD (60gb/100gb Split)
O/S      MS Windows XP Pro SP3
A/V      Kaspersky Business Security for MS Win Desktops
IE      v 7.0.5730.13

1 x HP Procurve 1800  8G Network Switch
1 x Linksys WRT54GS Modem      (LAN IP

All the kit is 7 days old, brand new fresh installation and its all configured and working fine except for the remote access, which has the following issues:

Attempts to VPN results in a connection being made, then it verifies username and password, thats where it stops, it never gets past the veryfing process. Ive run the CEICW and checked all the configuration, no issues are apparent. Ports 25, 80, 443, 444, 1723, 3389 & 4125 are set to port frowarding to in the Linksys. VPN Passthrough is also checked.
No issues, you can access and use OWA as one would expect to.

Remote Web Workplace
You can get to the remote web workplace by entering  static IP Address/remote but when you chose the option connect to my computer at work you get the following error message:
This Portion of Remote Web Workplace requires the Microsoft Remote Desktop ActiveX Control. Your browsers security settings may be preventing you from downloading ActiveX controls. Adjust these settings, and try again.

Terminal Service
From the SBS Managment Console select Client Computers and look at the list, highlight any of the PCs (they are all there) and click on the Connect to Computer via Terminal Services the connecting window appears for a plit second and nothing happens.

Given that the OWA works without issue and the Exchange server is receiving e-mail direct I know that the Static IP is poitning to the correct place.
Ive already tried the solutions posted on this site for the Remote Web Workplace which included:
Click on Tools -> Manage Add-Ons - > Enable or Disable Add-Ons in IE to enable Terminal Service ActiveX Control but its not there.
Ive logged in as every user on every PC and Deleted the System Registry Settings identified in the workaround.

Im back to square One, no remote access and no VPN does anyone have any other suggestions?

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

VPN - Do you happen to know what version the Linksys router is? Have you tried the latest firmware from linksys. I know some linksys firmware version had trouple with pptp.

RWW - Have you tried adding this as a trusted site on the machine you are connecting from ? Also can you verify remote desktop is enabled on the PC you are attempting to connect to?
Also does Kaspersky Business Secuirty Suite have firewall software that could be blocking connections?
AndrewKTAKAuthor Commented:

1) Firmware Version 7.50.2
2) RWW yes added Trusted site to each and every user!
3) No Firewall in the KAV Security Suite (there is but it's turned off)

IT Pros Agree: AI and Machine Learning Key

We’d all like to think our company’s data is well protected, but when you ask IT professionals they admit the data probably is not as safe as it could be.

Go ahead and update Linksys to the latest firmware. Do you happen to have another type of router you could try just to rule it out as a cause for VPN problem?
AndrewKTAKAuthor Commented:

The router is on the latest version of Firmware, no updates have been released for the Version 7.
No secondary router here to check for VPN Issue, I'll have to order another one from somewhere
If you have a WRT54GS version 7, then 7.50.5 firmware should be available.
AndrewKTAKAuthor Commented:

Remote Web Workplace

This is a known issue, MS has an Article which can be found at which describes the problem. The problem is that all the fixes appear to be for those users who have upgraded from XP SP2 to XP SP3 and the Terminal Services ActiveX Control has been disabled rather than not installed.

Just had MS Support dial in and take a look:

A) "The clients aren't connected to the network correctly"! Their first response.. Why says I, "becuase we can't connect to them" says MS. "Errr Hello says I, this is a support call becuase we can't connect remotely to the desktops".

B) "The RDP Client on the sver is version 5 but on the desktops it's version 6, so lets update the server" says MS, "OK says I but have you looked at article KB951607 yet becuase that's the problem I'm having" says I. "No it's not" says MS, "you have a different problem".

Anyway cut a long story short, MS just charged me £199 +21% vat for a support call that did not resolve the problem, it still does not work.

Anyone got any ideas, please.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today

From novice to tech pro — start learning today.