pix routing ip to VOIP Vlan

My client has a PIX Firewall, their phone vendor put in a VOIP system and Procurve Power over Ethernet switches.  Then computers, servers and PIX operate on 192.168.1.0 and the VLAN for the phones is 192.168.2.0.  The computers cannot access the IP 192.168.2.2 which would enable them to config certain parts of the phone system,saving a tech visit.  The Phone vendor says I need to setup the Pix to properly route the networks together.  I was not aware that the Pix could route traffic.  Here is the config

PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 100 permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list 101 permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.255.255.0
access-list acl_1 permit icmp any any
access-list acl_1 permit tcp any host x.x.x.x eq 5900
access-list acl_1 permit tcp any host x.x.x.x eq 3389
access-list acl_1 permit tcp any host x.x.x.x eq www
access-list acl_1 permit tcp any host x.x.x.x eq https
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.x 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp x.x.x.x 5900 192.168.1.111 5900 netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.x.x 3389 192.168.1.10 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.x.x www 192.168.1.2 www netmask 255.255.255.255 0 0
static (inside,outside) tcp x.x.x.x https 192.168.1.2 https netmask 255.255.255.255 0 0
access-group acl_1 in interface outside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
route inside 192.168.2.0 255.255.255.0 192.168.1.254 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set trmset1 esp-aes-256 esp-sha-hmac
crypto dynamic-map map2 10 set transform-set trmset1
crypto map map1 1 ipsec-isakmp
crypto map map1 1 match address 101
crypto map map1 1 set peer x.x.x.x
crypto map map1 1 set transform-set trmset1
crypto map map1 interface outside
isakmp enable outside
isakmp key ******** address x.x.x.x netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption aes-256
isakmp policy 10 hash sha
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 192.168.1.0 255.255.255.0 inside
ssh timeout 5
console timeout 0
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd auto_config outside
terminal width 80

The interface that the phone vendor setup to bridge the to networks is 192.68.1.254
LVL 1
mberryazAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Pete LongTechnical ConsultantCommented:
Hello mberryaz,

>> I was not aware that the Pix could route traffic

It cant! the PIX can understand some basic rouTING protocols (RIP and OSPF for example) but it can not intellegently route traffic  - your only option it to put a router/Layer 3 device behing the PIX that can make these routing decisions for you, then make that device the default inside route for the PIX


Regards,

PeteLong
0
JFrederick29Commented:
You are correct.  Your PIX isn't capable of routing traffic received on the inside interface back out the inside interface.  You would need 7.x code running on a PIX that supports 7.x (501 does not) or an ASA.  Do you have a router lying around?  Worst case, you could enable routing on a Windows machine.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mberryazAuthor Commented:
What about if I replaced the 501 with an ASA 5505? could it accomplish the same goals?
0
Become an IT Security Management Expert

In today’s fast-paced, digitally transformed world of business, the need to protect network data and ensure cloud privacy has never been greater. With a B.S. in Network Operations and Security, you can get the credentials it takes to become an IT security management expert.

JFrederick29Commented:
Yes, sir.
0
mberryazAuthor Commented:
Great that is what I will do.
0
mberryazAuthor Commented:
This help point me on the right path, thank you
0
ExEx-AustinCommented:
The PIX 501 with IOS 6.3 does not supprt logical interfaces.  With only one internal interface (connected to a 4-port switch) and no support for logical interfaces, the PIX can not access multiple networks.  Access to multiple networks is required to route.  The best it could do is, like inferred above, is send the packets to a router-device inside your network.

Which Procurve model?  Some support layer 3 switching which may be able to do the work for you.
0
mberryazAuthor Commented:
the procurve models are 2610-24-pwr and 2724
0
ExEx-AustinCommented:
The 2724 does not appear to support L3 switching.
The 2610-24 series does appear to support it.  The HP manual is here:  http://cdn.procurve.com/training/Manuals/2610-AdvTrafficMgmt-Dec2007-59918641.pdf

The switch should support up to 16 static routes, which should provide what you need.  Chapter 7 talks of this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Cisco

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.