Network drive "access denied" using UNC, works ok using IP

Hi,

Windows Vista SP1 workstation....

I have a logon script that runs and maps various network drives on logon, but I am finding that when I map to 1 of my servers I am getting an access is denied message, using: (all other drives map ok)

net use R: \\servername\sharename

That command works perfectly ok on Windows XP and Windows 2000 workstations. I can however map a network drive using:

net use R: \\192.168.0.1\sharename

The server I am mapping to is a Windows 2000 server

Can anyone point me in the right direction?

Thanks
Matt
sys_admin_picAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Zabee_80Commented:
Have you tried pinging that particular server on which folder is shared by name on w2k server?
0
Zabee_80Commented:
And also try to browse the server for shares, in your case by going on RUN and type \\ServerName and see does it shows the shares.
0
sys_admin_picAuthor Commented:
Hi,

I can not access the UNC at all using the Servername - just prompts me for a username and password, but IP address lets me in ok!

Thanks
Matt
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

alikaz3Commented:
sounds like a DNS/NTLM issue. Vista uses a newer version of NTLM authentication than xp/2000. I'd try changing the NTLM security policy on vista to allow it to connect using NTLM v1 rather than the new NTLMv2. Use secpol.msc to change it.

0
Zabee_80Commented:
just add the host name and ip address of the win2000 server in the host file and then try.
0
sys_admin_picAuthor Commented:
Hi,

The hosts file was my first thought but its already in there, not sure if that was causing the problem. As soon as I get back to work in the morning I will give both solutions a try and hopefully award some points :) - really appreciate the quick responses though! :)

Cheers
Matt
0
alikaz3Commented:
>>>The hosts file was my first thought but its already in there


That waves a red flag in my head, is the entry correct? An incorrect ip in that entry would cause this problem exactly. Could you copy/paste the hosts file here and I'll take a look.
0
sys_admin_picAuthor Commented:
Hi,

I have now taken the Hosts file out of the equation and I am just using the windows default. I found that before I put the machine onto the domain I could UNC to the server with no problems but as soon as I put the machine on the domain I am getting an access is denied message again.

When the machine was off of the domain I ensured that I logged on locally making sure that the username/password was the same on the local machine as it was on the domain - no problems

Any other ideas?

I have also changed the NTLM to a value of 1 in the registry using this value:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

and setting the:
LmCompatibilityLevel key to 1

Thanks
Matt
0
Zabee_80Commented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sys_admin_picAuthor Commented:
Hi All,

I have looked at all the possible solutions and I can not come up with a resolution. I have looked at NetBios and all the networking basics.

Its just strange that it only happens when the machine is on the domain?

Thanks, Matt
0
alikaz3Commented:
0
alikaz3Commented:
For the sake of clarity, here is the solution quoted from the link:


This behavior can occur if both of the following conditions are true:
1. NetBIOS over TCP/IP is not turned on (enabled) on one or more computers in the workgroup
2. The Computer Browser service is not started or is turned off (disabled) on one or more computers in the workgroup.

Try following these steps to see if fixes the problem.


Step 1: Turn On NetBIOS over TCP/IP
1. Click Start, click Control Panel, and then click Network and Internet Connections.
2. Click Network Connections.
3. Right-click Local Area Connection, and then click Properties.
4. Click Internet Protocol (TCP/IP), and then click Properties.
5. Click the General tab, and then click Advanced.
6. Click the WINS tab.
7. Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click OK two times.
8. Click Close to close the Local Area Connection Properties dialog box.
9. Close the Network Connections window.

Step 2: Start the Computer Browser Service
1. Click Start, right-click My Computer, and then click Manage.
2. In the console tree, expand Services and Applications.
3. Click Services.
4. In the right details pane, verify that the Computer Browser service is started, right-click Computer Browser, and then click Start.
5. Close the Computer Management window.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.