Assembly does not allow partially trusted callers

I keep getting this error and no luck fixing:

Exception Details: System.Security.SecurityException: That assembly does not allow partially trusted callers.

Source Error:

Line 1:  <%@ Page Language="VB" ContentType="text/html" %>
Line 2:  <%@ Register TagPrefix="MM" Namespace="DreamweaverCtrls" Assembly="DreamweaverCtrls,version=1.0.0.0,publicKeyToken=836f606ede05d46a,culture=neutral" %>
Line 3:  <MM:DataSet
Line 4:  runat="Server"
Line 5:  id="Procedure1"
LVL 12
Nathan RileyFounderAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

illusioSoftware Architect / Team LeaderCommented:
Use the Microsoft .NET Framework configurator to give the assembly that tries to use that locked down assembly full trust.

If that doesn't help: create a WCF wrapper around that assembly and let it run in a Windows Service. Consume the WCF wrapper from the asp.net pages.

Kind regards.
0
illusioSoftware Architect / Team LeaderCommented:
BTW: the page will get compiled to a DLL (class assembly) and is placed in the bin folder. Ditch the dynamic recompile and add a strong name for your asp.net assembly. This will easy up the rights management you are battling with.
0
Nathan RileyFounderAuthor Commented:
I'm very new to this and not sure what you mean.  I know I can't mess with the .net config as I'm hosted through godaddy.com
0
illusioSoftware Architect / Team LeaderCommented:
Phew this seems a common problem. Mostly solved by moving to another provider that can activate the full trust for you...

If this isn't an option you can try the modified controls found here:
http://www.webxel-dw.co.uk/extensions/DreamweaverCtrls_details.html
(extract the mxp file using the adobe extension manager)

Or you can take a look in the code that should be on this location or similar:
C:\Program Files\Macromedia\Dreamweaver 8\Configuration\ServerBehaviors\Shared\ASP.Net\Scripts\Source\DreamweaverCtrls.cs
(info found on: http://www.communitymx.com/blog/index.cfm?newsid=709)
In the code file you will have to find the System.Security stuff with RequestPermition and .Deny and .Demand and so.

A last resort would be: don't use those controls. (very disappointing answer - i know)

Kind regards.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Nathan RileyFounderAuthor Commented:
Yeah tried that and still not working.  I don't know how to do it without the controls.  Been working on it for a week now.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.