Assembly does not allow partially trusted callers

I keep getting this error and no luck fixing:

Exception Details: System.Security.SecurityException: That assembly does not allow partially trusted callers.

Source Error:

Line 1:  <%@ Page Language="VB" ContentType="text/html" %>
Line 2:  <%@ Register TagPrefix="MM" Namespace="DreamweaverCtrls" Assembly="DreamweaverCtrls,version=1.0.0.0,publicKeyToken=836f606ede05d46a,culture=neutral" %>
Line 3:  <MM:DataSet
Line 4:  runat="Server"
Line 5:  id="Procedure1"
LVL 12
Nathan RileyFounderAsked:
Who is Participating?
 
illusioConnect With a Mentor Software Architect / Team LeaderCommented:
Phew this seems a common problem. Mostly solved by moving to another provider that can activate the full trust for you...

If this isn't an option you can try the modified controls found here:
http://www.webxel-dw.co.uk/extensions/DreamweaverCtrls_details.html
(extract the mxp file using the adobe extension manager)

Or you can take a look in the code that should be on this location or similar:
C:\Program Files\Macromedia\Dreamweaver 8\Configuration\ServerBehaviors\Shared\ASP.Net\Scripts\Source\DreamweaverCtrls.cs
(info found on: http://www.communitymx.com/blog/index.cfm?newsid=709)
In the code file you will have to find the System.Security stuff with RequestPermition and .Deny and .Demand and so.

A last resort would be: don't use those controls. (very disappointing answer - i know)

Kind regards.
0
 
illusioSoftware Architect / Team LeaderCommented:
Use the Microsoft .NET Framework configurator to give the assembly that tries to use that locked down assembly full trust.

If that doesn't help: create a WCF wrapper around that assembly and let it run in a Windows Service. Consume the WCF wrapper from the asp.net pages.

Kind regards.
0
 
illusioSoftware Architect / Team LeaderCommented:
BTW: the page will get compiled to a DLL (class assembly) and is placed in the bin folder. Ditch the dynamic recompile and add a strong name for your asp.net assembly. This will easy up the rights management you are battling with.
0
 
Nathan RileyFounderAuthor Commented:
I'm very new to this and not sure what you mean.  I know I can't mess with the .net config as I'm hosted through godaddy.com
0
 
Nathan RileyFounderAuthor Commented:
Yeah tried that and still not working.  I don't know how to do it without the controls.  Been working on it for a week now.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.