[Okta Webinar] Learn how to a build a cloud-first strategyRegister Now

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 979
  • Last Modified:

MS SQL 2005 SP 2 Merge Replication error - The process could not read file ... due to OS Error 3

I am trying to reinitialize subscriptions with a new Snapshot and getting the following error:

The process could not read file '\\[server]\dist_plus\unc\[server]_TEMPESTIP_TEMPESTIP\20080708104631\KA_TextSearch_76.sch' due to OS error 3.

The folder name referred to does not exist - it has been replaced by a folder created at the time of creation of the new Snapshot.  Additionally, there is not an equivalant file KA_TextSearch_??.sch within the new folder.

I've trawled the web all day and am not confident that setting up an addtional snapshot folder will not end up causing me more problems than solve.

What is causing the error?  I would expect reinitialization to flush through any refrences to old folders.  Can I do anything to prevent it?  Is there a way of configuring replication to point at the new folders?

Any help would be very appreciated.
0
basiclife
Asked:
basiclife
  • 2
1 Solution
 
MohammedUCommented:
You can do it through the publication properties...

http://msdn.microsoft.com/en-us/library/ms151258(SQL.90).aspx
0
 
basiclifeAuthor Commented:
Many thanks for the response - it should've worked but unfortunately it turns out that entries were incorrect on sysmergeschemachange which was causing the issue. I'm going to correct these entries and try again.

I'll award points as the answer was correct - just not in my case.

Thanks again
0
 
basiclifeAuthor Commented:
Many thanks :)
0

Featured Post

NEW Veeam Agent for Microsoft Windows

Backup and recover physical and cloud-based servers and workstations, as well as endpoint devices that belong to remote users. Avoid downtime and data loss quickly and easily for Windows-based physical or public cloud-based workloads!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now