Learn how to a build a cloud-first strategyRegister Now

x
?
Solved

File sharing over a network

Posted on 2008-11-19
10
Medium Priority
?
715 Views
Last Modified: 2013-11-21
HI all,

I have a server running Windows Server 2003 Web, this is a workgroup and not a domain.  I have made a folder on the C: Drive and I want to share it on the network.  I have done everything I can think of, including reading way too much documentation, to no avail.  Anyway.  I have made a user and set their permissions to full access.  From a client machine, I can browes to the folder but when I try to access it, I get an error message that says:' \\Acctserver\Weatherization is not accessible.  You might not have permission to use this network resource.  Contact administrator of this server to find out if you have access.  Access Denied.'  I checked the regisry value of HKEY_LOCAL_MACHINE/SYSTEM/CurrentControlSet/Control/LSA/restrictanonymous. to make sure it was set to 0 on both the server and the client.  They are both set to 0.  I would love to check the firewall but, I get another error that I cant because some other application might be using NAT.  I have also been trying to figure that one out.  Anyway, this used to be very simple with Windows Server 2000, but, I cant think of why my users do not have access. Any thoughts from anyone?  Another interesting thing with this, is that my other server, a windows 2000 server, can access the shared file with no problems.  None of my XP Pro client can however.  

Thanks in advance.

Jay
0
Comment
Question by:jwoodhams
10 Comments
 
LVL 5

Expert Comment

by:thechaosrealm
ID: 22997420
There's two steps to sharing a folder with Server 2003. Right clicking the folder and going to Sharing and Security, the Sharing tab displays first. This tab has a Permissions button, which you should click on and make sure "Everyone" has full permission. Then in the Security tab, you want to make sure you give appropriate permission to all of your users. I prefer the advanced tab, as it shows all of the allows and denies seperately. IIRC, a deny will always override an allow . . .
0
 
LVL 1

Author Comment

by:jwoodhams
ID: 22999873
I have set the permissions to allow everyone to have full permission, and also assigned full rights to users on the security tab and still the same.  
0
 
LVL 5

Expert Comment

by:vguzman
ID: 23000609
Check that the service "server" is started and set to "automatic" in your SERVER and also check that the service "workstation" is started and set to "automatic" in your CLIENT PC.
0
Prepare for your VMware VCP6-DCV exam.

Josh Coen and Jason Langer have prepared the latest edition of VCP study guide. Both authors have been working in the IT field for more than a decade, and both hold VMware certifications. This 163-page guide covers all 10 of the exam blueprint sections.

 
LVL 5

Expert Comment

by:vguzman
ID: 23000635
Also, how is your network setup ?  all the computers and servers connected to the same switch or router ? do they all have the same netmask?  can you PING the server ?
Use IPCONFIG /ALL to check that info on all the pcs before to go any further.
0
 
LVL 1

Author Comment

by:jwoodhams
ID: 23006617
Hi Thank you vguzman,

Server service is started and automatic on server.  Workstation is started and automatic on client.  I can ping the server, all use the same netmask, and all workstations share the same 4 switches (uplinked).
0
 
LVL 5

Expert Comment

by:vguzman
ID: 23010190
Do you have all the updates installed in your server and client PC ?
Are you using WINS in your server ?
Are you manually setting up the IPs on the client PCs or they are setup to automatic ? Can you post the IPCONFIG of the client PCs ?
0
 
LVL 1

Author Comment

by:jwoodhams
ID: 23015671
I do have all the current updated installed.  Just made sure this morning.  Also, I am not using WINS.  And I am getting the IPs automatically through DHCP.  Here is the ipconfig/all of the client:

Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Aaron>ipconfig/all

Windows IP Configuration

        Host Name . . . . . . . . . . . . : D027HS
        Primary Dns Suffix  . . . . . . . :
        Node Type . . . . . . . . . . . . : Unknown
        IP Routing Enabled. . . . . . . . : No
        WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . :
        Description . . . . . . . . . . . : Realtek RTL8168/8111 PCI-E Gigabit E
thernet NIC
        Physical Address. . . . . . . . . : 00-E0-4D-3A-1F-D2
        Dhcp Enabled. . . . . . . . . . . : Yes
        Autoconfiguration Enabled . . . . : Yes
        IP Address. . . . . . . . . . . . : 10.0.0.63
        Subnet Mask . . . . . . . . . . . : 255.255.255.0
        Default Gateway . . . . . . . . . : 10.0.0.2
        DHCP Server . . . . . . . . . . . : 10.0.0.2
        DNS Servers . . . . . . . . . . . : 10.0.0.2
        Lease Obtained. . . . . . . . . . : Friday, November 21, 2008 1:26:35 PM

        Lease Expires . . . . . . . . . . : Sunday, December 21, 2008 1:26:35 PM


C:\Documents and Settings\Aaron>
0
 
LVL 5

Accepted Solution

by:
vguzman earned 750 total points
ID: 23016148
I seems like your subnet mask is wrong.  If you want to use the "10.0.0.63" IP your subnet mask MUST be "255.0.0.0"
Change that in you DHCP settings on your server and "renew" the IP of your computer and try to browse the contents of your sharefolder again.
Also check the "local policies" of your server. (I just received this as an answer in another question I have pending)
Try enabling  the guest account and then:
GO to start run -- gpedit.msc -- Windows settings -- Security Settings -- local policies -- security options --
FInd
Network Access:  Let everyone permission apply to anonymous users -- set to enable
Network Access:  Shares that can be accessed anonymously - add the share name
Now give everyone rights to the folder you are sharing.
Good luck.
0
 
LVL 1

Author Closing Comment

by:jwoodhams
ID: 31519298
Thanks very much, I did enable permission for anonymous users and that did the trick.

Thanks
0
 
LVL 1

Expert Comment

by:vipulg
ID: 23121439
What you need to do is create a user with SAME username and password on the client machine. Another way you can also do this is by mapping a drive with alternate user/pass option.
0

Featured Post

Windows Server 2016: All you need to know

Learn about Hyper-V features that increase functionality and usability of Microsoft Windows Server 2016. Also, throughout this eBook, you’ll find some basic PowerShell examples that will help you leverage the scripts in your environments!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Outsource Your Fax Infrastructure to the Cloud (And come out looking like an IT Hero!) Relative to the many demands on today’s IT teams, spending capital, time and resources to maintain physical fax servers and infrastructure is not a high priority.
As a financial services provider, your business is impacted by two of the strictest federal regulations on record: the Sarbanes-Oxley Act and the Gramm-Leach-Bliley Act. Correctly implementing faxing into your organization to provide secure, real-ti…
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
Suggested Courses

810 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question