This Portion of Remote Web Workplace requires the Microsoft Remote Desktop ActiveX Control

Posted on 2008-11-19
Last Modified: 2012-05-05
Hello Help me please!

Just deployed a MS SBS 2003 R2 Server and MS XP Pro SP3 Desktops required for Remote Desktop Working, everything is configured as usual you can log into the Remote Web Workplace but as soon as you select 'Connect to My Computer at Work" you get the error messages that reads:

This Portion of Remote Web Workplace requires the Microsoft Remote Desktop ActiveX Control. Your browsers security settings may be preventing you from downloading ActiveX controls. Adjust these settings, and try again.

I've tried all the solutions I could find listed here and there which include:

Click on Tools -> Manage Add-Ons - > Enable or Disable Add-Ons in IE to enable Terminal Service ActiveX Control but its not there.

Ive logged in as every user on every PC and Deleted the System Registry Settings identified in the workaround.

I've visited MS Website and found Articel KB951607 which describes the symptons but the solution is only any good if you upgraded from XP SP2 to XP SP3, it doesn't work if you have a fresh install of SP3.

I've spent hours on the phone with Microsoft Support who want to charge me £597.00 to correct their mistake and I simply couldn't afford it even if I wanted to.

I need to correct this problem tonight, the client has gone home and I'm sat here trying everything I can think of, any suggestions please.
Question by:AndrewKTAK
    LVL 4

    Expert Comment

    If you have Adware & or Spybot, try this:

    The reason for this that you installed Spybot and Adware. Save this to a reg file and run it on the client:

    ; --------------------------------------------------------------------------
    ; The following code will remove the ActiveX Compatibility restriction on
    ; CLSID = {7584C670-2274-4EFB-B00B-D6AABA6D3850}
    ; Microsoft RDP Client Control (redist)
    ; --------------------------------------------------------------------------

    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX Compatibility\{7584C670-2274-4EFB-B00B-D6AABA6D3850}]

    Author Comment


    No Adware &/Or Spybot, this is fresh out of the box almost exclusivley MS, the only non-MS applications is the Kaspersky AV which I have unistalled.

    MS Engineers are currently dialed into the Network and they are completely stumped so ti does not boad well for me ambitions of an early night!

    Any more suggestions?
    LVL 4

    Expert Comment

    Found this:

    Suggestion 1:
    Firstly, please ensure you have added the SBS Site (http://FQDN/*) in
    trusted site in IE. You can refer to the following steps:

    a. Start Internet Explorer.
    b. On the Tools menu, click Internet Options.
    c. On the Security tab, click Local intranet zone, and then click Sites.
    d. Click Advanced.
    e. In the Add this Web site to the zone box, type the ConnectComputer
    server's IP address or the ConnectComputer server's FQDN, and then click

    *Note: You must type the ConnectComputer server's IP address or the
    ConnectComputer server's FQDN in the http://IP address or http://FQDN
    f. Click OK, click OK, and then click OK.
    LVL 4

    Expert Comment

    Suggestion 2:
    When you select or click Connect to connect to the machine, the browser is
    going to attempt to download a Microsoft Remote Desktop ActiveX control
    from the server to the client. That''s going to be if the client does not
    already have it installed. The actual file that is downloading is located
    under the %systemroot%\Inetpub\Remote directory, and it''s called After it''s installed, it will be installed to the client under
    whatever their Windows directory is, %windir%\Downloaded Program
    Files\Microsoft RDP Client Control.

    Regarding to your error message, you can re-download the to
    client PC or copy the file from server to the client PC manually.

    If the control cannot be downloaded, you''re going to be returned to the
    main menu with the following error. It will say, "This portion of the
    Remote Web Workplace requires the Microsoft Remote Desktop ActiveX control.
    Your browser''s security settings may be preventing you from downloading
    the ActiveX controls. Adjust these settings, and try to connect again."
    That''s a signal to maybe check some of the security settings in Internet
    Explorer. Please try the following steps:

    A. Open Internet Explorer, click Internet Options on the Tools menu.
    B. Click the Security tab, select Internet and click Custom Level.
    C. Select Prompt or Enable for Download signed ActiveX controls and
    Download unsigned ActiveX controls.
    D. Click OK. Restart IE and have a test.

    **Please note that you need to be a local admin to install Active X
    controls. I recommend logging in as an admin, installing the ActiveX
    control, then logging in as the regular user to use the RWW or anything
    LVL 4

    Expert Comment

    LVL 4

    Expert Comment

    This from an Expert:
    SP3 disables a required active-x component. This may be the problem. You can usually re-enable in internet explorer but others have found they have to edit the registry.
    or see ID:21980987 in:


    Author Comment


    Hi still on the phone with MS, they're truly spectaular, I called with the error message and they've crawled all over the network for the last 4.5 hours discovering little anomolies.

    They proudly announced that they had the fix, it was my nVidia drivers, they made the required changes to the System Registry and hey presto I still get the same message.

    So after 4.5 Hours I'm still sat here listening to the MS Music on hold (a jazzy little number) and the support technician has just announced that it's deffinatley something to do with IE7, which I had to say to him "Like I said when I first called, I've got a problem with ActivX controls in IE7".

    Read all the posts you've discovered as I've been having this problem since last Thursday, none of the work as the 'Workaround' is when you upgrade from XP SP2 to XP SP3 and presupposses that the Missing ActiveX Control is disabled when it is actually not there cause they haven't bloody written it.

    Already tried all combinations of MS IE7 Security settings, including trusted sites, intranet etc., still no joy it simply does not work.

    Have to keep jumping on and off machines as MS guys take control of them so bit random at responding but thanks for the support glad to know someone wants to help.
    LVL 4

    Expert Comment

    All right Andrew,

    Please keep me posted when they give you a final solution.

    Thanks for the feedback.

    Accepted Solution

    Hello Fiuca

    Below is the reoslution from Microsoft, after several days of no sleep and pulling out what little hair I had left they tried everything and this is what worked,

    But be warned it only worked per user! I had to log onto the machine as each user and when I created a new account it still defaulted to the original setting but at least the ActiveX Control was there and was simply disabled.



    Unable to use the RWW Connect to Client Desktop feature from Windows XP SP3 machines



    Changed the value of the registry key HKLM\SYSTEM\CurrentControlSet\Control\Windows\CSDVersion to 200 (hex)
    Deleted the folder tsclientmsitrans from C:\Windows\Installer
    Deleted mstscax.dll.mui from C:\Windows\System32\en-us
    Deleted mstsc.exe.mui from C:\Windows\System32\en-us
    Deleted aaclient.dll.mui from C:\Windows\System32\en-us
    Deleted the files tsgqec.dll, rhttpaa.dll, mstscax.dll, mstsc.exe, aaclient.dll from  C:\Windows\System32\Dllcache folder
    Deleted tsgqec.dll, rhttpaa.dll, mstscax.dll, mstsc.exe, aaclient.dll from  C:\Windows\System32
    Rebooted the client machine
    Downloaded and installed RDP client 6.1 from the following link 479E088570AD&displaylang=en

    ·         Changed the value of the registry key HKLM\SYSTEM\CurrentControlSet\Control\Windows\CSDVersion to 300 (hex)

    ·         Rebooted the client machine


    LVL 4

    Expert Comment

    I'm glad it's working now. Thanks once again for the feedback.
    Good luck!

    Featured Post

    Threat Intelligence Starter Resources

    Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

    Join & Write a Comment

    Suggested Solutions

    I wanted to pass this along in case anyone has a problem removing a device from the Device Manager, or if you suspect a corrupted Driver that you want to remove in its entirety. I know it is kinda lengthy and very basic in its format, but I figured …
    Most of the time we are in fix when all of sudden our systems behave weirdly.  Such problems cost time and effort... so it's best to take some preventive actions so that we can avoid such issues or overcome such problems more easily. Preventive M…
    Illustrator's Shape Builder tool will let you combine shapes visually and interactively. This video shows the Mac version, but the tool works the same way in Windows. To follow along with this video, you can draw your own shapes or download the file…
    Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

    729 members asked questions and received personalized solutions in the past 7 days.

    Join the community of 500,000 technology professionals and ask your questions.

    Join & Ask a Question

    Need Help in Real-Time?

    Connect with top rated Experts

    17 Experts available now in Live!

    Get 1:1 Help Now