• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3320
  • Last Modified:

DPM 2007 not seeing Quantum Tape Library


Hi there,

I have a Quantum ATL Superloader (L600 model; SDLT320 drive) attached to a Dell DP500 server running DPM (Data Protection Manager) 2007. I installed an Adaptec 29320LPE SCSI card (plus drivers) and the Quantum SDLT320 Drive drivers, as well as the SDLT320 Library & Drive firmware updates.

However, in Device Manager on the backup server (DP500), the Tape Drive showed up, but the Medium Changer showed up as "unknown". And in the DPM 2007 software, it saw the device as a Stand-alone (with only one slot/drive), when it is a 16-slot library. I downloaded a medium changer driver for a newer model of Quantum...now the library slots all show up, but the backups fail with the error:

"DPM encountered a critical error while performing an I/O operation on the tape in Drive Quantum SDLT 320 Drive. (ID 30101 Details: The request could not be performed because of an I/O device error (0x8007045D)"

Dell support suggested the problem was with the driver -which makes sense as it's not for this model- but when this driver is not installed,  the software does not see the library, period.

Does anyone have any experience or suggestions? If there is no driver for this, am I just out of luck?

Thanks so much.
0
designpac
Asked:
designpac
  • 3
  • 3
1 Solution
 
honmapogCommented:
The main problem may be that your tape library does not seem to be supported by DPM. See http://technet.microsoft.com/en-gb/dpm/cc678583.aspx#quantum

The errors you see were reported when a tape filled up. See http://support.microsoft.com/kb/946647. I suggest you install the feature pack to fix this - if you haven't done so already: http://www.microsoft.com/DOWNLOADS/details.aspx?familyid=AD5CD1A2-9B87-4A2C-90A2-9DBAF1024310&displaylang=en

Also make sure that the Removable Storage service is stopped and disabled.

Do you see any events with number 7, 9 ,11 or 15 in the System event logs at the time of the failed backup?

0
 
designpacAuthor Commented:
honmapog,

I saw that the tape library was not technically supported on the Microsoft website - we were told by our Dell reps at the time that it was supported, but only verbally. However, I was hoping to find a way around this, as I could see the library after installing a similar (but incorrect) Quantum Medium Changer driver, I just kept getting the errors mentioned previously.

I had already installed Hotfix KB946647 and the Rollup Feature Pack KB949779, neither of which solved the issue.

The Removable Storage service (DPMRA) is stopped. I also disabled it. (Q: Should the Library Agent service -DPMLA- be started? It currently is stopped and manual.)

I see events with number 7, 9, 11 and 15-

 7: "The device, \Device\TapeDrive0, has a bad block"
 9: "Broadcom BCM5708C: Network controller configured for 100Mb full-duplex link"
11: "The driver detected a controller error on \Device\TapeDrive0"
15: "The device, \Device\Scsi\adpu3201, is not ready for access yet"

Do these errors imply that the tape drive hardware is an issue?

Thanks again.

0
 
honmapogCommented:
Yes I think this may be hardware problem.
If the driver you installed for the tape drive is the correct driver for your SDLT320 drive, then the library driver shouldn't matter that much in the context of this specific error. Make sure you get the latest driver for your type of tape drive.

Clean the drive if not done yet. Reconnect the SCSI cables. Use new tapes if you have them (event 7 may be a media problem). If none of that helps, you should suspect anything along the SCSI chain. Tape drive, terminator, cable or SCSI card.

This will be a hardware or (tape) driver problem.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
designpacAuthor Commented:

The driver for the tape drive is the latest driver for the model, and I'm pretty sure it's the correct driver (Quantum Driver_v3-7-0.exe for ATL Superloader Win2K/2K3/XP x86, x64, ia64), even though it only enables me to see the drive, and no the library.

I also have the latest tape drive and library firmware (v.82, v.40 respectively).

I don't see how the library/medium changer driver can be irrelevant, unless the correct tape driver should inherently make visible the tape library (as well as the drive) in the backup software also?

Note: You mentioned earlier about the errors being related to the tapes filling up. However, the Protection Group that I was attempting to backup was only a few Gigs in size, certainly nowhere near big enough to fill up a 250GB SDLT tape. It would backup the System State just fine - and tell me that the tape was ready for Offsite Storage - but then would fail to backup any shares.

I have cleaned the drive, but not messed with the SCSI hardware, as the fact that it backed up something seemed to indicate a driver issue as opposed to hardware. Which I guess brings us back to the fact that since there is no specific driver for this model of taper drive, I may just have to upgrade my hardware.

If you see anything in my comments here that trigger a response, please feel free to add to this thread.

0
 
honmapogCommented:
Here's the reason why I'm saying the Medium Changer driver may be irrelivant.
It is important to get the Medium Changer seen by DPM so DPM can move tapes from slots to drive and back. The medium changer driver is used for those kinds of operations. I understood that, now you loaded the Quantum driver for a different model of Quantum library, you get to see the library in DPM. To my knowledge DPM is able to successfully give you an inventory of the slots of the library and it is able to load and unload tapes to/from the tape drive.
So by adding a medium changer driver for another library, it looks like all the operations that DPM needs to pass through the medium changer driver are working fine. That would lead me to believe this driver - although for a different library model - is coping just fine.

However, the problems seem to appear for operations to the tape drive. Both events 7 and 11 mention problems to device \Device\TapeDrive0. DPM's communications with this device all pass through the tape driver driver - which is the correct driver for this model of tape drive.

I hope you can see where I'm coming from when I say I believe the incorrect Medium Changer driver may be irrelevant. I may be wrong, but I believe I'm right.


I'd have to disagree that the fact that it backs up something indicates a driver issue. You'll can get this sort of symptom with for example flaky electrical contacts in the SCSI chain, or a dying SCSI terminator. It can also happen when you have a dirty area on a tape (event 7 is indicative of this).


All that said, you still may want to invest in a new tape library with newer tape drive technology such as LTO - it may save you a lot of hassle. And it would allow you to get support from Microsoft or Dell - so you're not on your own with problems like this.
0
 
designpacAuthor Commented:
Yes, all that you say makes sense. I think I'm fighting a losing battle here in trying to tweak this issue by issue, when it appears to be just the larger issue in general of needing a newer system. Thank so much for your attentiveness and your attention to detail.

Sincerely,
Catherine
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now