I moved mydomain.com from DC/DNS server to a webserver - www.mydomain.com works but mydomain.com does not.

I am in the process of retiring mydomain.com DC's and have moved mydomain.com to a different webserver.  Changed www dns A record to new server edited IIS headers for ip and domain www.mydomain.com and mydomain.com.
www.mydomain.com always works.  mydomain.com http request works most of the time, sometimes not.
any ideas how I direct http requests for mydomain.com to www server?
nslookup on mydomain.com returns all dns adresses as well as www server address.
LVL 13
Greg HejlPrincipal ConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

tigermattCommented:

Hey,

If looking up mydomain.com (without the www. component) returns the correct IP address of the web server, then the problem is not DNS and would appear to be with IIS itself instead.

I would suggest you take a look at the host headers in IIS. Consider adding a second host header entry (use the button marked 'Advanced' I believe beside the standard host header/IP configuration section), listening on the same port and IP address as the first is configured to listen on, but with a host header value of mydomain.com too. This should iron out any issues with browsing on either of those domain names.

-tigermatt
0
Henrik JohanssonSystems engineerCommented:
All DCs will automatically register its IP as A-record for mydomain.com in DNS as "sasme as parent" to handle domain-based DFS.
The web browser that works has propably a setting enabled that it shall try to add www before domain name or that some of the DCs has IIS running with the website and sometimes responds depending on DNS roundrobin.
If you want to ensure that it always work to use http://mydomain.com, you nead to install IIS on all DCs and configure them to redirect to http://www.mydomain.com
IIS manager on each DC: Web sites -> Default web site -> Right-click -> Properties -> Home Directory -> "A redirection to a URL"
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Greg HejlPrincipal ConsultantAuthor Commented:
Thanks Henjoh09!
This is a great option!  I had already done tigermatts suggestion and yours will work great
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking

From novice to tech pro — start learning today.