Problems exporting the X display to a client terminal

I keep getting the error "Error Can't open display: workstation1" whenever I try to run an X display via something like xclock. I have a RHEL 5 server with SE Linux turned off. I am trying to display X to a remote client workstation that is running RHEL 5 WS. I have "xhost +"ed the workstation and I have issued the command, "export DISPLAY=workstation1:0.0" . I have ssh'd into the server with and without the -X option. Either way, I get the "Warning: no auth data" warning. I have used the "gdmsetup" command on the server to allow X forwarding and I have confirmed this in the /etc/sshd/sshd_config file; "X11Forwarding yes". I did a netstat and confirmed that tcp port 6000 is open and running Xorg. My firewalls are turned off. What else am I missing?
jazzkiAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joolsCommented:
Have you run `xhost +`?

Check the man page before you run it, you may want a more secure option.
0
jazzkiAuthor Commented:
I have xhost +'d the client, not the server.
0
joolsCommented:
sorry, I misread the Q.

Anything in the logs?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

macker-Commented:
Just to clarify, you ran the "xhost +" command on the client, or on the server?

Specifically, you need to make sure the client is running a valid X server on 0.0, and is accepting connections from the server.

The other question I would have is if DNS is working properly, etc.

From a troubleshooting standpoint, have you tried doing a "telnet workstation1 6000"?

And lastly, to confirm, you aren't running a host-based firewall on either side?

Tunneling X over SSH should eliminate any firewall issues.  This really sounds like a client auth issue, or an inability for the session to be tunneled correctly.  It sounds like you've checked over most of the possible issues.  While it seems like it should be a complex issue, I'd suspect it's actually a simple issue, that's slipping thru somehow.  The telnet test should give significant insight, but I'm hoping this is actually an issue of xhost being run on the wrong side.
0
omarfaridCommented:
if you run

echo $DISPLAY

what do you get?

Try

DISPLAY=workstation1:0.0 ; export DISPLAY
0
jazzkiAuthor Commented:
I've checked the /var/log files and have found no errors related to X display issues. The DISPLAY variable is also being exported properly. When I do an "echo $DISPLAY", it returns "workstation1:0.0". I also confirmed that Xservers are running properly on BOTH the client and server. I also am NOT running any host-based firewall on either side.  I think you are on to something Macker. I tried the telnet command as you suggested and this is what I got:
"Trying 192.168.X.X......
 telnet: connect to address 192.168.X.X: No route to host
 telnet: Unable to connect to remote host: No route to host"

So I suspect this is a DNS issue as you said. Not sure where to go from this point.

0
omarfaridCommented:
are you able to resolve the name to the correct ip address? if you put the ip address rather the name in DISPLAY, do you get the same problem?
0
jazzkiAuthor Commented:
Yes. It is done staticly, in the /etc/hosts file. Same result whether I use the hostname, "workstation1:0.0" or ip address "192.168.X.X:0.0". "Error: Cannot open display: 192.168.X.X"
0
joolsCommented:
are they on the same subnet? does a route need to be added?
0
jazzkiAuthor Commented:
Yes, they are on the same subnet
0
jazzkiAuthor Commented:
Anything....anyone?
0
joolsCommented:
I think we need to get back to basics; please provide the following information;

1/ Network listings with ipaddress and network mask of all systems; ifconfig -a
2/ DNS info; cat /etc/resolv.conf
3/ Any firewall configuration; iptables -L
4/ Copies of /var/log/messages and /var/log/secure as attachments.
5/ Routing table information; netstat -r
6/ Network interface setup; mii-tool or ethtool
7/ output from when you type telnet <ip> <port> [where you change ip and port! :-)]
8/ output from when you type ssh <user>@<ip> [and again :-)]

0
jazzkiAuthor Commented:
1.  I have typed in an "abridged version" of the output. FYI, I am doing channel bonding on 4 channels.

     bond0:
              inet addr: 192.168.1.1   Bcast:192.168.1.255   Mask: 255.255.255.0
     eth0:
              UP BROADCAST RUNNING SLAVE MULTICAST
     eth1:
              UP BROADCAST RUNNING SLAVE MULTICAST
     eth2:
              UP BROADCAST RUNNING SLAVE MULTICAST
     eth3:
              UP BROADCAST RUNNING SLAVE MULTICAST

2. search localdomain

3. Chain INPUT (policy ACCEPT)
       target prot opt source destination
    Chain FORWARD(policy ACCEPT)
       target prot opt source destination
    Chain OUTPUT(policy ACCEPT)
       target prot opt source destination

4. There was NOTHING in /var/log/message or /var/log/secure that indicated any display errors, X errors, or network connectivity errors.

5.    Kernel IP routing table
      Dest        Gateway        Genmask        Flags        MSS        Window        irtt        Iface
192.168.1.0         *           255.255.255.0       U              0                0               0        bond0
169.254.0.0         *           255.255.0.0           U              0                0               0        bond0

6. SIOCGMIIPHY on 'eth0' failed: Operation not supported
    eth1 negotiated 100baseTx-FD flow-control link ok
    eth2 negotiated 100baseTx-FD flow-control link ok
    eth3 negotiated 100baseTx-FD flow-control link ok
    eth4 no link
    eth5 no link
    eth6 no link
    eth7 no link

7.
Trying 102.168.1.5....
telnet: connect to address 192.168.1.5: No route to host
telnet: Unable to connect to remote host: No route to host

I get the same error above when trying to connect from the client (192.168.1.5) to the server(192.168.1.1)

8. <user>@192.168.1.1's password:
0
jazzkiAuthor Commented:
All, I discovered this was my own stupid mistake. I ran the ssh -X command but did not realize that it was unnecessary to "export DISPLAY=" on the command line after sshing in. If I simply ran the ssh -X, and then ran my x program like "xclock", it worked. Otherwise, if I explicitly set the display it failed. I did not know this. Thanks for all your help.
0
macker-Commented:
Ah, yes... I'm surprised I/we overlooked that.  SSH sets up its own values for DISPLAY, to tunnel back over, and this was probably stepping on it.  I do think there may be a separate issue present, in that you were unable to telnet to the port, but I'd say that if things are working now, and you don't encounter any further problems, best to leave it as-is.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.