Specifically setting NFS ports, rogue statd port

I have NFS set up on a server using static ports due to having iptables running on the same machine.  I set up mountd, lockd, and statd to use specific ports, but on reboot statd uses one of the ports I specified and additionally picks a dynamic port in the 6xx range.  I have confirmed this with netstat, see below

tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      3417/portmap    
tcp        0      0 0.0.0.0:32765           0.0.0.0:*               LISTEN      3436/rpc.statd  
tcp        0      0 0.0.0.0:32767           0.0.0.0:*               LISTEN      3904/rpc.mountd
udp        0      0 0.0.0.0:644             0.0.0.0:*                           3436/rpc.statd  <-- The elusive port
udp        0      0 0.0.0.0:111             0.0.0.0:*                           3417/portmap    
udp        0      0 0.0.0.0:32765           0.0.0.0:*                           3436/rpc.statd  
udp        0      0 0.0.0.0:32767           0.0.0.0:*                           3904/rpc.mountd

I am running on Ubuntu 8.04 and have done the following:
/etc/default/nfs-common
  STATDOPTS="--port 32765 --outgoing-port 32766"

/etc/default/nfs-kernel-server
  RPCMOUNTDOPTS="-p 32767"

/etc/modprobe.d/options
options lockd nlm_udpport=32768 nlm_tcpport=32768

Any help is appreciated.
LVL 1
mynamebecory2Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mynamebecory2Author Commented:
Apparently this is a bug in Ubuntu 8.04, dont know if its resolved, the page is currently down.  Here is the google cache:

http://209.85.173.132/search?q=cache:rilRBk5W2PoJ:https://bugs.launchpad.net/ubuntu/%2Bsource/nfs-utils/%2Bbug/146252+STATDOPTS+ubuntu&hl=en&ct=clnk&cd=3&gl=us&client=safari

Original Page (again, down as of posting):
https://bugs.launchpad.net/ubuntu/+source/nfs-utils/+bug/146252
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.