Small Business Server, 2003, Service Pack 2, Setup could not verify the integrity of the file update.inf

When I try to to do the Service Pack 2, I get this message, I read a thread with the same error, but it did not indicate if any suggestions actually fixed the problem. It indicated that you have to install Service Pack 1 and 4 other updates, but I was told that Service Pack 2 was cumulative. I would appreciate any help to avoid a lot of unnecessary experimentation.

I am including the text of the svcpack.log
3.890: 2008/11/19 14:48:30.765 (local)
3.890: d:\b088d2c00f4e9d9c1f\i386\update\update.exe (version 6.3.4.1)
3.890: Service Pack started with following command line:
3.906: In Function GetBuildType, line 1170, RegOpenKeyEx failed with error 0x2
4.031: Return Value From OnACPower = 1
4.109: OnACPower returned value( 0x1 ) which is Equal To 0x1
4.109: Condition succeeded for section OnACPower.Section in Line 1 of PreRequisite
4.125: InternalFileName of C:\WINDOWS\system32\HAL.DLL is Not Equal To halcmpx.dll
4.125: Condition succeeded for section CustomHalUnisysBlock.Section in Line 2 of PreRequisite
4.140: InternalFileName of C:\WINDOWS\system32\HAL.DLL is Not Equal To Unisys CMP Server ACPI HAL
4.140: First Condition in CustomHalUniSysBlock.Section2 Succeeded
4.140: Condition succeeded for section CustomHalUniSysBlock.Section2 in Line 3 of PreRequisite
4.156: InternalFileName of C:\WINDOWS\system32\HAL.DLL is Not Equal To HALSRAAC.DLL
4.156: Condition succeeded for section CustomHalStratusBlock.Section in Line 4 of PreRequisite
4.156: InternalFileName of C:\WINDOWS\system32\HAL.DLL is Not Equal To halce52.dll
4.156: Condition succeeded for section CustomHalMarathonBlock.Section in Line 5 of PreRequisite
4.156: Service SpUpdSvc Not Registered in SCM 0x424
4.156: Condition succeeded for section SpUpdSvcBlock.Section in Line 6 of PreRequisite
4.156: Start is Present
4.156: SYSTEM\CurrentControlSet\Services\MSDTC\Start is Not Equal To Specified Value
4.156: Second Condition in MSDTC.Not.Disabled Succeeded
4.156: Condition succeeded for section MDSTC.Check.Disabled in Line 7 of PreRequisite
4.156:  C:\WINDOWS\system32\DRIVERS\elxsli2.sys is Not Present
4.156: First Condition in Emulex.Driver.Compat.Check.Section Succeeded
4.156: Condition succeeded for section Emulex.Driver.Compat.Check.Section in Line 8 of PreRequisite
4.156:  C:\WINDOWS\system32\DRIVERS\ql40xx.sys is Not Present
4.156: First Condition in Qlogic.Driver.Compat.Check.Section Succeeded
4.156: Condition succeeded for section Qlogic.Driver.Compat.Check.Section in Line 9 of PreRequisite
4.156: HotfixRefreshRequired is Not Present
4.156: First Condition in HotfixRefresh.Registry.Check.Section Succeeded
4.156: Condition succeeded for section HotfixRefresh.Registry.Check.Section in Line 10 of PreRequisite
9.078: InstallInfCatalogFile: Installing d:\b088d2c00f4e9d9c1f\i386\update\SP2.cat as _000000_.cat...
9.125: VerifyTargetFileSize: Unable to verify size as Source = NULL for file c:\windows\_000000_.cat
9.562: InstallCatalogFile: InstallCatalog failed for c:\windows\_000000_.cat; error=0xfffffbfe.
9.578: InstallInfCatalogFile: Installation failed; error=0x00000002.
9.578: IsInfFileTrusted: ValidateSingleFileSignature Failed: STR_FAILED_INF_INTEGRITY
9.578: Service Pack 2 Setup encountered an error:  Setup could not verify the integrity of the file Update.inf.  Make sure the Cryptographic service is running on this computer.
9.953: CleanupTrustedInfFile: GetFileAttributes for C:\WINDOWS\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE}\oem27.cat failed: 0x2
9.953: UnRegisterSpuninstForRecovery, failed to delete SpRecoverCmdLine value, error 0x2
9.953:  DoInstallation: Failed to unregistering spuninst.exe for recovery.
9.953: Setup could not verify the integrity of the file Update.inf.  Make sure the Cryptographic service is running on this computer.
16.640: Message displayed to the user: Setup could not verify the integrity of the file Update.inf.  Make sure the Cryptographic service is running on this computer.
16.640: User Input: OK
16.640: Update.exe extended error code = 0xf0da
16.640: Update.exe return code was masked to 0x643 for MSI custom action compliance.



cpmtechAsked:
Who is Participating?
 
cpmtechConnect With a Mentor Author Commented:
I tried reregistring the dlls and several other things suggested in a knowledge base article, but none of them worked. What I realized finally was that when I opened the service pack 2 file it was unpacking the files to an external hard drive that was attached to the server for backup purposes. When it tried to do the install from the external hard drive it produced the error I was running into. As soon as I unplugged the external drive and executed the file again it then unpacked to a local drive and then installed with out any problem. So I learned to watch very carefully when the files are unpacking and make sure they are going to a local drive. Thanks for your help, maybe my experience will help others.
0
 
Hardeep_SalujaConnect With a Mentor Commented:
Firstly, make sure Cryptographic service is running
0
 
Hardeep_SalujaConnect With a Mentor Commented:
http://support.microsoft.com/kb/822798

Try to follow these steps:
Go to command prompt:
 net stop cryptsvc
Rename the %systemroot%\system32\CatRoot2
%systemroot%\system32\oldcatRoot2
 net start cryptsvc

Above should work
Else
Download the file that rebuilds the catalog database "Fixdb.bat" from internet.

Hope this should work for u
pls let me know
0
 
Hardeep_SalujaConnect With a Mentor Commented:
rem Re-registes DLL's :
regsvr32 /s /u softpub.dll
regsvr32 /s /u wintrust.dll
regsvr32 /s /u initpki.dll
regsvr32 /s /u dssenh.dll
regsvr32 /s /u rsaenh.dll
regsvr32 /s /u gpkcsp.dll
regsvr32 /s /u sccbase.dll
regsvr32 /s /u slbcsp.dll
regsvr32 /s /u mssip32.dll
regsvr32 /s /u cryptdlg.dll
regsvr32 /s softpub.dll
regsvr32 /s wintrust.dll
regsvr32 /s initpki.dll
regsvr32 /s dssenh.dll
regsvr32 /s rsaenh.dll
regsvr32 /s gpkcsp.dll
regsvr32 /s sccbase.dll
regsvr32 /s slbcsp.dll
regsvr32 /s mssip32.dll
regsvr32 /s cryptdlg.dll
0
 
cpmtechAuthor Commented:
I did verify that the service running, when I tried suggestion 2 the install went up the point of inspecting configuration and then the same message came back. I will try the third suggestion this weekend.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.