Connecting Switches

I have a Dell PowerConnect 6224 (managed switch) and a SMC SMCGS16 (unmanaged switch).  A cat6 cable is running from a device with a T-1 connection into my rack.  I don't know a lot about the device or cable, but I believe it is a managed switch and I believe the cat6 cable is a straight through cable.  

Also, I have 8 computers connected to both switches, eth0 connects to the Dell, eth1 connects to the SMC.  Both switches recognize every computer.

Now, when I connect the cat6 cable to the PowerConnect managed switch, it isn't recognized.  No lights light up on either end.  But when I connect the cat6 cable to the SMC unmanaged switch, it recognizes it and lights up.

My goal is to connect to the Dell PowerConnect switch.  Initially, I thought it was a straight through cable and I needed a crossover cable.  But then I tried connecting it to the SMC switch and it connected fine.  I called the IT guys that ran the cables and they said its a straight through cable, so that's likely what it is (but I wouldn't be surprised either way...)

My question is, if its a straight through cable, would it connect to an unmanaged switch but not a managed one?  And, would running a crossover cable fix my problem?
LVL 6
philjones85Asked:
Who is Participating?
 
tigermattConnect With a Mentor Commented:

Yep, that would be the other one I'd have suggested checking after the trunking :-)

On devices supporting it, Spanning Tree Protocol attempts to detect any loops on the network (duplicate links between devices) which are not part of a port trunk, and switch off one of them to keep the network happy (otherwise the switches will go mad with hundreds of packets, pulling the whole network down as a result).

Be careful, since having Spanning Tree disabled could potentially cause you to end up with a loop on your network which is not automatically switched off, which could then pull your network down.

-tigermatt
0
 
tigermattCommented:

The simple answer to your question is it shouldn't affect it, although as a rule of thumb the cabling going into a switch should be straight through. The switch handles the crossing of the transmit and receive legs automatically, but as you may know many of today's switches will have an AutoSense feature built-in, which means it will detect whether a crossover or straight cable has been connected and adapt itself automatically.

It may well be that on the Dell Managed Switch, this AutoSense feature has been switched off, meaning if the cable is a cross-over cable, it is applying a cross to an already crossed line, meaning transmit is talking to transmit, receive to receive, and you will have no output at either end.

-tigermatt
0
 
philjones85Author Commented:
Ok, it is autosensing, so the cable isn't the problem.  After talking to the network guys (through somebody else...) it appears that I'm connected to a CISCO device, and the CISCO device is shutting down the port b/c my Dell switch is trying to control it.  I don't really know what that means.  They said to look for trunking or vlan and shut it off.  I found an option for "Port VLAN Mode" and turned it to "Access" from "General", but its still not connecting.

Any ideas?
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
tigermattCommented:

That's one I've not seen before. You've turned the VLAN on the Port off by the sounds of things, but how about the Port Trunking? If you can find where to switch that off, then try again, you might get somewhere.
0
 
tigermattCommented:

And another point, check there isn't more than one Cat5 cable going from the Cisco device to the Dell switch, and if there is, don't disable the trunk.

Can you get at the Cisco management? You may need to disable the VLAN / trunk there, too.
0
 
philjones85Author Commented:
I don't see "trunking" anywhere in the manual...  I see "trunk" in a couple of places.   One of them references GVRP Parameters, but that is set to "disabled" already.

There is only one cable connected.
0
 
philjones85Author Commented:
Ok, it turns out I needed to disable the "Spanning Trees Protocol"
Switching->Spanning Trees->Global Settings

Works fine now...

Thanks for the help
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.