intermittent DNS errors on clients usings SBS 2008 as server

I am having a problem with client PC's on a network using SBS 2008 as server/domain controller. The client PC's all have internet connectivity, but as an example if I do a search on google some of the results will end up in a DNS error. If I plug directly into my router with the workstations and run the same search all the results work fine. So the issue has to be in the DNS of the SBS 2008 Machine, all DNS was setup through the installation and subsequent wizards. Anyone have the same issue, or some ideas as to a fix?
LVL 1
Bill HendersonWeb MarketingAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ormerodrutterCommented:
I think yo need to be more specific about what errors did you receive. Please also say if you have 1 or 2 NICs and if possible, drop down here their configuration. Are you using ISA?
0
Bill HendersonWeb MarketingAuthor Commented:
There is 1 NIC in the machine. In SBS 2008 they killed ISA so it does not exsist. I have found that if I go to a big corporate site such as www.microsoft.com the pages will display. But if I go to my company www.maxgeekpc.com, or one of my clients www.watervalleyland.com they will not display. It pops up a DNS error immediately. I think is is a security setting somewhere that is blocking the smaller site from being displayed.
0
Bill HendersonWeb MarketingAuthor Commented:
here is a screenshot of the error.
error.JPG
0
Learn Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Bill HendersonWeb MarketingAuthor Commented:
I found the problem. SBS 2008 doesn't cnfired DNS fowarders correctly. So you must go into the DNS server and add your dns servers there, and everything works fine.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
J-BCommented:
Can you expand on this please?

Thanks
0
mediamanagerCommented:
I'm having the same problem with DNS and SBS 2008. And the periodically dns error is very annoying. The problem is solved though, by a restart of the DNS server service. It should not be necessary to add forwarders. The roots should do it alone, as it is on ordinary W2K3/8 servers. I'm interested in another solution, if anyone? I'm diving into the eventlog...
0
mediamanagerCommented:
With Windows SBS 2008, it is recommended that you use root hints rather than DNS forwarders for DNS requests. Root hint servers are DNS servers that resolve root domain names and that are both globally accessible and public. Root hints help prevent problems that may occur as a result of DNS poisoning on the local ISP server or of changing a DNS server (http://technet.microsoft.com/en-us/library/cc546471.aspx)
0
trivinCommented:
I have the same problem... I heard the story... But now my SBS is running for one week... And I get dns problems for certain websites...  I hope it doesn't affect my mail...

Grrrr with sbs2003 never had problems... and with this one...damn
0
VinzZCommented:
Solution without using DNS forwarders:

Set the maxcachettl cache to 2 days or more:

1.Start Registry Editor (Regedit.exe)
2.Drill down to the following registry key - HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DNS\Parameters
3.Right click in the right-hand window and select  New > DWORD (32-bit) Value then add give it the name MaxCacheTtl
4.Double click the new value and select 'Hexdecimal' the enter the value 0x2A300
5.Click OK
6.Quit Registry Editor.
7. Restart the DNS server service.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.