OS Commerce Installation Help

I'm installing OS Commerce on my local machine. As i'm installing OS Commerce, I get PHP Warnings and errors after the full install on localhost.

This is the error on "step 4"

PHP Warning: parse_url(http://localhostD:\-=My Documents=-\Web Stuff\Riddle_Percussion\oscopy\catalog\) [function.parse-url]: Unable to parse URL in D:\-=My Documents=-\Web Stuff\Riddle_Percussion\oscopy\catalog\install\templates\pages\install_4.php on line 75

Now when I click on "catalog" or "admin"...it takes me here...

http://localhost/Riddle_Percussion/oscopy/catalog/install/:///index.php
http://localhost/Riddle_Percussion/oscopy/catalog/install/:///admin/index.php

...and gives me this result..."The directory name is invalid"

Now when i fix the URL to
http://localhost/Riddle_Percussion/oscopy/catalog/

...it seems to work but any link i click on is forwarded to ...

http://localhost/Riddle_Percussion/oscopy/catalog/:///index.php?cPath=1
http://localhost/Riddle_Percussion/oscopy/catalog/:///index.php?manufacturers_id=9

I'm thinking that somewhere I defined the URL incorrectly but i don't know what's going on. Help?

wellsinteractiveAsked:
Who is Participating?
 
Bernard S.Connect With a Mentor CTOCommented:
I would worry not so much of blank spaces in purely windows \\ paths (although bad surprises are always possible), but I would worry a lot about the blank space in the "apache // path" , ie /docs/Web Stuff/Riddle_Percussion/oscopy/catalog/
I would probably change that before going any further
Yes, I confess being paranoid at times!
0
 
Bernard S.CTOCommented:
Looks like you gave wrong asnwers to the different fiule names you are asked to provide.
You do not mention your web server, I assume it is Apache but might be IIS

1 - Url to your site seems to be http://localhost/Riddle_Percussion/oscopy/catalog/
2 - Path to your files might be asked / given in 2 forms:
-- disk form would be D:\-=My Documents=-\Web Stuff\Riddle_Percussion\oscopy\catalog\ and probably should not be used, more specifically since this is a windows path where D:\-=My Documents=-\ is an alias for a physical folder that you might consider using instead, say d:\docs\ which would lead to
d:\docs\Web Stuff\Riddle_Percussion\oscopy\catalog\
-- web server form would probably be using the physical folder and forward slashes
/docs/Web Stuff/Riddle_Percussion/oscopy/catalog/
Note that in all cases the presence of a space in the path might create problems
0
 
Bernard S.CTOCommented:
...Note that in all cases the presence of a blank character in the path name might create problems...
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
wellsinteractiveAuthor Commented:
yea I tried different address possibilities as you said to no avail. You think the spaces or have the "-=My Documents=-" (equals and minus signs) characters would have an effect on this?
0
 
wellsinteractiveAuthor Commented:
Hey thanks for your help and patience Fibo. I apologize for the long delay. I've just got back into town from Mexico and December has been a wild month. Anyways, i'm back and should be consistent here...

So far what you said has helped my other errors and now the site seems to be working but not the admin tool. This is what I put during the install

WWW Address
http://localhost/Riddle_Percussion/1/catalog/

Webserver Root Directory
D:/-=My Documents=-/Web_Stuff/Riddle_Percussion/1/catalog/


This worked. Thank you for your help!!

0
 
wellsinteractiveAuthor Commented:
Thank you for you prompt response. I again apologize for the delays but I really do appreciate your help. Thank you
0
 
Bernard S.CTOCommented:
B-)) Glad it helped! Thx for the grade and points
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.