Reply Email Address in Database Mail being Ignored

Hi I have a Database Mail account that is using an administrator email account to send out various information to users.  This email address should not however be the reply address which should be the development team.
I have set up the account as follows
E-Mail Address: Administrator@mycompany.co.uk
Display Name: Administrator Reports-Server
Reply e-mail: IT@mycompany.co.uk
Server name: Mymail   Port Number:  25
The email function works fine, but when a recipient hits reply, Outlook is addressing the new email to Administrator@mycompany.co.uk rather than IT@mycompany.co.uk

Is this the expected behaviour?  How can I get replies to come to the right mailbox?

Thanks
LVL 1
GeniusStealsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Mark WillsTopic AdvisorCommented:
Multi steps.... easy to skip one...



-- Create a Database Mail account
EXECUTE msdb.dbo.sysmail_add_account_sp
    @account_name = 'AdventureWorks Administrator',
    @description = 'Mail account for administrative e-mail.',
    @email_address = 'dba@Adventure-Works.com',
    @replyto_address = 'danw@Adventure-Works.com',
    @display_name = 'AdventureWorks Automated Mailer',
    @mailserver_name = 'smtp.Adventure-Works.com' ;
 
-- Create a Database Mail profile
EXECUTE msdb.dbo.sysmail_add_profile_sp
    @profile_name = 'AdventureWorks Administrator Profile',
    @description = 'Profile used for administrative mail.' ;
 
-- Add the account to the profile
EXECUTE msdb.dbo.sysmail_add_profileaccount_sp
    @profile_name = 'AdventureWorks Administrator Profile',
    @account_name = 'AdventureWorks Administrator',
    @sequence_number =1 ;
 
-- Grant access to the profile to the DBMailUsers role
EXECUTE msdb.dbo.sysmail_add_principalprofile_sp
    @profile_name = 'AdventureWorks Administrator Profile',
    @principal_name = 'ApplicationUser',
    @is_default = 1 ;

Open in new window

0
GeniusStealsAuthor Commented:
Though I set up the account/profile using the Wizard rather than by script, I think all those points are taken into account.

I have attached a view of the Wizard when trying to configure the account.

Everything looks to be set up correctly. I'm wondering whether the problem may lie outside of Database Mail and with Outlook.


MailboxSetup.JPG
0
Mark WillsTopic AdvisorCommented:
Yes, could be - The setup does look OK, so might be something interesting with that address... I mean there is the obvious question that it@mycompany.co.uk is set up in your exchange server...   and all the interesting bit are crossed out ;)

But, on further experimentation, configuration, and testing, the reply_to does not work.

Have checked with a couple of colleagues and they concur - only one way, put the reply to address in the "E-MAIL"  it does not even check if it is real - I had santa.clause@northpole.cold and put in a display name of Hppy Holidays and sure enough it came through. My inbox just showed the display name, and the e-mail had display Name and the bogus address, did a reply and it bounced.

So, the reply to is no go, use the e-mail address as the reply to
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

Mark WillsTopic AdvisorCommented:
apologies was not northpole.cold - that one failed, but my own site has a catchall account and second one did come through as santa.clause@myaccount.com

the rest is quite true and accurate...
0
GeniusStealsAuthor Commented:
Closing question as not resolved
0
Mark WillsTopic AdvisorCommented:
Ummm, you might not have liked my answer but it is the real answer. The reply to is no go, use the e-mail address as the reply to.
0
GeniusStealsAuthor Commented:
Thanks but that is not the real answer.  That is just saying that the reply-to doesn't work.  I already noticed that which is why I posted the question...

Either there is a way for the Reply-to to function correctly or something needs to be done in Exchange to facilitate it.  

I need the Reply-to email address to be different from the Email address and it looks like SQL Server provides a way of doing this.

Apparently not...
0
Mark WillsTopic AdvisorCommented:
Yes, in exchange, you can set up a reply e-mail address for your administrator@your_company.com account.

as a simple test go into config, e-mail accounts, select that e-mail account there are advanced options and nominate the reply-to
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Mark WillsTopic AdvisorCommented:
or if testing and have outlook with admin access go into outlook tools, e-mail accounts, select the account, change, more settings, first tab has a reply to down the bottom.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.