Backup failing with a failure occured querying the writer status

Backup is failing witht the below error. Veritas and server have all avalible patches server has been restarted and the vss admin list writers have been run with no errors.

Job ended: 20 November 2008 at 11:12:22
Completed status: Failed
Final error: 0xe000fed1 - A failure occurred querying the Writer status.
Final error category: Resource Errors

For additional information regarding this error refer to link V-79-57344-65233

Click an error below to locate it in the job log

Backup- \\MAGDC01\D: Data
V-79-57344-34110 - AOFO: Initialization failure on: "\\MAGDC01\Shadow?Copy?Components". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS).
Snapshot provider error (0xE000FED1): A failure occurred querying the Writer status.
Check the Windows Event Viewer for details.
Writer Name: Event Logs, Writer ID: {EEE8C692-67ED-4250-8D86-390603070D00}, Last error: The VSS Writer failed. The operation cannot be retried (0x800423f4), State: Failed during prepare snapshot operation (8).
V-79-57344-34110 - AOFO: Initialization failure on: "\\MAGDC01\System?State". Advanced Open File Option used: Microsoft Volume Shadow Copy Service (VSS).
Snapshot provider error (0xE000FED1): A failure occurred querying the Writer status.
Check the Windows Event Viewer for details.
Writer Name: Registry, Writer ID: {AFBAB4A2-367D-4D15-A586-71DBB18F8485}, Last error: The VSS Writer ran out of memory or resources (0x800423f1), State: Failed during prepare snapshot operation (8).

Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Do u have enough diskspace to do the AOFO snapshot?  

Try this, plug en external USB HDD with plenty space into the server.  Configure the AOFO agent to use the external drive to do the snapshot.

What does the Windows Event Viewer say?

Try running the command 'vssadmin list writers' in command prompt of machine MAGDC01 and find which writer is failing. Check the Status of each writer, usually this wil be fixed by a reboot, but since this is DC I am not sure how you are going to do this.

You may also want to do a reegistering of dlls.
check the below article, it may help
Has this been fixed? Please let me know if you need any help with the same.

The Five Tenets of the Most Secure Backup

Data loss can hit a business in any number of ways. In reality, companies should expect to lose data at some point. The challenge is having a plan to recover from such an event.

I've been able to resolve this issue with a reboot of the system being backed up. Have you tried this?
Hi All,

I Had a similar problem when trying to back up an Information store on Exchange 2007 CCR with Windows 2003 SP2 using Backup Exec 12.5.

After a few days troubleshooting this, I had found that the VSS copy provider services on the individual servers were not restarting in time when backup exec moved on to the next mailbox store. So backup exec would try and start the service again when its still in the process of still shutting down. Thus creating the backup exec writer status error.

My solution for this was to create individual backup jobs for each mailbox store underneath the information store (If you have multiple mailbox stores). This seemed to work for me but not might be the case for others.

I hope this helps

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Kini pradeepDevelopment ManagerCommented:
I am seeing a similar issue. In order to check whether the provider service is starting in time, do we have any debug logging to be enabled ?
would appreciate information on the work around.

From what I am aware of there is no logging for this issue. (other then the obvious errors of course) it is more process of elimination. This is the only way I was able to bypass this issue. Although I am happy if someone has an alternative because backing up individual mailbox stores is a bit messy when you have a few of them
Hi All-

I had tried all options previously discussed here and elsewehere without success.  I received the exact same error but it was caused by a consistency check failing when the First Storage Group was being backed up.  Turning off the consistency check option altogether or selecting the "Continue with backup if consistency check fails" option did the trick for me.  

Sure hope that helps someone out there because it drove me nuts for a week.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.