configuring frame-relay and dsl on cisco 2800 series router

hello expert,

I have cisco 2800 series router that is  configured for "dsl" .
I am using eigrp on this router .
I would like install frame-relay on the same router and if possible use "ospf".
Could any expert share some info on the above.

Regards
jomfraAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

bkepfordCommented:
What do you want to know? Frame relay and ospf configuration?
int se 0/0/0
encapsulation frame-relay
no shut
int se 0/0/0.1 point-to-point
ip address 172.16.0.1 255.255.255.252
frame-relay interface-dlci <dlci>
router ospf 1
network 172.16.0.1 0.0.0.0 area 0

Open in new window

0
jomfraAuthor Commented:
hello expert,
thanks for the configuration
>> What do you want to know? Frame relay and ospf configuration?
I have a working  "dsl" configuration that is using "eigrp" as my routing protocol.
I would like to configure frame-relay on this same router but this configuration (frame-relay)
will be using ospf .
What I am attempting to find out is if having the two different routing protocols on the same router
will cause any problems.

0
bkepfordCommented:
No it won't cause a problem. Are you going to want one routing protocol to know about the routes from the other?
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

jomfraAuthor Commented:
hello expert,

>> No it won't cause a problem. Are you going to want one routing protocol to know about the routes from the other?
 
yes please advise how to do so.

regards
0
bkepfordCommented:
Here you go. I added a route map to tag the routes that are redistributed. The reason you do this is that if you have 2 sites that are redistributing it can cause loops. The taging will prevent loops.
0
bkepfordCommented:
Oops forgot to click the attach code check box
router ospf 1
redistribute eigrp 1 subnets route-map E2O
 
router eigrp 1
redistribute ospf 1 metric 1 1 1 1 1  route-map O2E
 
route-map E2O deny 5
  match tag 10
route-map E2O permit 10
  set tag 20
 
route-map O2E deny 5
  match tag 20
route-map O2E permit 10
  set tag 10

Open in new window

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jomfraAuthor Commented:
Hello  bkepford:,

Thank a million for all the advice and the configurations.
please keep up the good work

Regards
0
bkepfordCommented:
Your welcome
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.