No SSO on windows 2008 terminal Services with Session Broker activated

Hello,

I have installed three terminal server under Windows 2008.
On a server I have installed the Session Broker services.
The load balancing is working well but If I reach a server which has more user, I have no SSO (Single sign On) i.e. I need to write the password again in order to connect to another Terminal server.
I have installed everything as describ in the Ms KB.
To finish, I have modified the securityof the RDP protocol into "RDP compatibility" in order to let TS session Broker work

Regards

Marc
MarcFRANKHAUSERAsked:
Who is Participating?
 
menreeqConnect With a Mentor Commented:
We had a similar problem

http://support.microsoft.com/kb/953760 
This applies only to SP3.

The other fix was to edit the registry for NTLMOnly Single Sign On:
"
[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CredentialsDelegation]
"AllowDefCredentialsWhenNTLMOnly"=dword:00000001
"ConcatenateDefaults_AllowDefNTLMOnly"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\CredentialsDelegation\AllowDefCredentialsWhenNTLMOnly]
"1"="termsrv/TerminalServer"
0
 
MarcFRANKHAUSERAuthor Commented:
It has been solved by itself by changing  the RDP connection properties two times ??
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.