We help IT Professionals succeed at work.
Get Started

.Net 1.1 install failure & .Net 2.0/3.0 uninstall/repair/update failure

respawn
respawn asked
on
1,498 Views
Last Modified: 2012-08-14
I have a program my company just purchased that requires the use of .Net 1.1. If it detects that it is not installed it tried to install it from the package. It does not give me the option not to, it just activates. I tried installing this program onto a specific Win XP SP3 machine and it hung on the .Net install portion. I realized this wasn't working so I canceled the install and ran windows update to install the Net1.1 manually. When i went to the update screen there was about 14 available critical upddates so I selected all of them and the downloaded the .NET 1.1 from the optional portion. After it finished downloading I got 3 failures.

.Net 1.1 install failure
.Net 2.0 SP1 install failure
.Net 3.0 SP1 install failure

I looked up the error codes in windows update history and I cross referenced them with MSDN, & support.microsoft.com, but I came up with "no results," I tried google but that didn't help either.

Anyhow, all the other updates installed fine so I thought I'd check to see if it was some odd anomaly. I reactivated the Windows Update after restarting and tried to update just one of the Service packs. (.Net 2.0 SP1) and it failed again. I wondered if it may have been a bad download so I stopped the Windows Update service and renamed the Software Distribution file which is where updates are downloaded. I restarted the Windows Update service and tried to rerun windows update for just .Net 2.0 update. It re-downloaded but the install failed again. I decided to download the .NET 1.1 redistributable from Microsoft in hopes to install it manually. I downloaded it but when I went to install it failed.

I decided to see if I can remove the existing .NET framework packages (2.0 & 3.0) and then try to install .Net 1.1. When I went to Control Panel>Add/Remove Programs and selected the uninstall it failed for both 2.0 and 3.0. i tried multiple times. I then tried to repair the packages which failed as well.

I don't use 2.0 or 3.0, I just want 1.1 to work. Can you guys think of anything that I may have missed? Thanks!
Comment
Watch Question
CERTIFIED EXPERT
Commented:
This problem has been solved!
Unlock 1 Answer and 6 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE