We help IT Professionals succeed at work.
Get Started

ROBOCOPY permission copy problems...

3,249 Views
Last Modified: 2012-05-05
Hi

I have been around the net looking for an answer to this problem, but with no
luck... And I have also posted this question on technet newsgroups, but still no answer so i will try and see if someone here can help me out in this matter.

Im trying to copy data from server1 over a 10MBit WAN connection to server2
wich is the backupserver.

I want to copy all project data with all permissions and dates from server1
to server2.  Both servers running server 2003 (R1)

I have been trying this out with robocopy version  XP026.
I have set up a temp directory on both servers for trying this out.

On server1 there is some two permisions set. one is domain administrators and the
other one is a group lets call it company_employees in ActiveDirectory that is set on the E: drive itself and therefor is
automatically set on the root foolder and all underlying folders as well when i created a new testfolder.

When im doing this with the initial run it copies all files, but it doesnt
retain the two permissions, instead it sets the permissions that i
automatically created on server2 when setting that root folder up. The folder
on the destination server2 is on D:

If i add another person on server1 it will in the second run copy/add the new
permission correctly to server2, if i erase the permission, it will also erase it
correctly on server2. But still leave the faulty permissions it picked up from the first initial run.
But i cant get it to copy the permissions that is set up from start, why is
this???

If I do the same procedure with robocopy XP010 it DOES work, it copies the
right permissions with no problems, BUT i cant get that version to correctly
copy time stamps on folders! It looks like this is a problem that i fixed in
version xp026 with the /DCOPY:T switch that doesnt exist in version xp010....

And with further testing I have found one cause that is a problem in xp026, IF the folder i am
copying from, is a folder that is set to "Allow inheritable permissions from
the...." in the advanced security tab, then it wont take the permissions
correctly over to the new backupserver. But unchecking this makes it work....
but this seems odd to me, is this a demand that it will work only with that
set??!


Anyone out there that can help me with this? I would be most grateful! It wuite urgent that i get this up and running as i need to backup this server ASAP, thats why i have givien this question a high value of points.

Best Regards
Perra

Comment
Watch Question
CERTIFIED EXPERT
Most Valuable Expert 2019
Most Valuable Expert 2018
Commented:
This problem has been solved!
Unlock 1 Answer and 4 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE