We help IT Professionals succeed at work.
Get Started

PIX 501 configuration check

arron9112003
arron9112003 asked
on
366 Views
Last Modified: 2012-05-05
Hello,

I'm configuring my pix 501 to connect to other pix (I don't know the model), all I have is parameter sheet from other end.

ISAKMP Protocol:
Encryption algorithm: AES256
Hash algorithm: SHA-1
Authentication method: pre-shared secret
Diffie hellmann group: Group2
Lifetime: 86400 sec
IKE keepalives: Interval = 30 sec, retry=5sec

IPsec:
Mode: Tunnel Mode
Encryption algorithm: ESP-AES256
MAC algorithm for authentication: ESP-SHA-HMAC
Perfect forward secrecy (PFS): Yes, Group2
SA Lifetyp: 28800 sec

Those are parameters I need to configure for my pix501, but after I confiugred them and try to establish the tunnel but nothing happend. I think my config file must be wrong, so I'm kindly ask for your expertise to help me check out my config file. I already change the IP to be fake, so those are not real IP ;-)

Thank you for your help, and best regards.


PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list acl_out permit ip any any log
access-list 101 permit ip host 10.21.119.23 host 10.21.159.36
access-list ethernet0 permit tcp any interface outside eq ssh
pager lines 24
logging on
icmp permit any outside
mtu outside 1500
mtu inside 1500
ip address outside 71.201.5.28 255.255.255.248
ip address inside 10.21.119.22 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
access-group acl_out in interface outside
route outside 0.0.0.0 0.0.0.0 71.201.5.30 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication ssh console LOCAL
aaa authorization command LOCAL
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set chevelle esp-aes-256 esp-sha-hmac
crypto map transam 1 ipsec-isakmp
crypto map transam 1 match address 101
crypto map transam 1 set pfs group2
crypto map transam 1 set peer 197.241.175.6
crypto map transam 1 set transform-set chevelle
crypto map transam interface outside
isakmp enable outside
isakmp key ******** address 197.241.175.6 netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption aes-256
isakmp policy 1 hash sha
isakmp policy 1 group 2
isakmp policy 1 lifetime 86400
telnet timeout 5
ssh 0.0.0.0 255.255.255.255 outside
ssh timeout 30
Comment
Watch Question
Top Expert 2009
Commented:
This problem has been solved!
Unlock 1 Answer and 3 Comments.
See Answer
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE