We help IT Professionals succeed at work.
Get Started

Installed 4gb RAM on XP Pro machine but only shows 3.53gb

pelampe
pelampe asked
on
1,433 Views
Last Modified: 2013-11-10
Hello,

I've recently added 2gb to two desktops running XP Pro SP2, and when rebooting, it doesn't show the full 4gb of RAM, it only shows 3.23gb.  I've added the /3GB switch on the boot.ini already, but it didn't change it.

The boot.ini resides in the root of C:  Is that the correct ini to modify for the 3GB switch?

Here's what the boot.ini has in it:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /3GB

1 - What can be done to improve this, if anything?

2 - Why does this limitation occur?

3 - One of our IT guys says that you don't have to have the 3gb switch in the boot .ini.   He says windows will automatically recognize it.

TIA for all your responses.
Comment
Watch Question
This problem has been solved!
Unlock 5 Answers and 11 Comments.
See Answers
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE