troubleshooting Question

java.security.AccessControlException on oc4j

Avatar of at999
at999 asked on
Web ServersJava EE
18 Comments1 Solution646 ViewsLast Modified:
i have created simple applet that connects to oracle database using jdbc thin driver.. i have bundled that applet into  myapplet.jar. i run that applet on oracle oc4j server

i get java.security.AccessControlException error when i try to connect to oracle.

I have tried changing the java.policy in my machine's java.home folder...
I also modified java2.policy on my oc4j server's j2ee's security folder to give all permissions to myapplet.jar
but i still get the same error

grant codeBase "file:/C:/somepath/api/" {
        //grant all permissions
    }

i restarted the oc4j server after making changes

I am missin changes in the policy files etc.?


 pl help thanks....

Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 18 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 18 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros